Raspberry Pi 3

  • Ich möchte hier nur mal erwähnen, dass NOOBS kein Betriebssystem, sondern ein Betriebssystem-Installer ist, der die Installation und die Auswahl des Betriebssystems eigentlich vereinfachen sollte (aber nicht immer tut). Mir selber hat NOOBS mehr Ärger als Freude bereitet. Ich schliesse mich deshalb der Meinung von meigrafd an.

  • Mach das gewünschte System direkt drauf und nutze mehrere SD Karten, falls Du mehrere Systeme nutzen willst. Die Karten kosten ja fast nix mehr.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Der Preis gilt schon nicht mehr aber Dank aktuell ohne Versandkosten immer noch super.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Allgemein kann man sagen das Küpfer Kupfer besser geeignet ist als Aluminium.


    Bei den hier umgesetzten Leistungen egal. Im Gegenteil ist eloxiertes Aluminium ohne zusätzlichen Lüfter dem blanken Kupfer überlegen (deutlich höherer Emissionsgrad der eloxierten Oberfläche gegenüber der blanken Metallfläche).

    Ebenfalls schlucken diese doppelseitigen Klebe-Wärmeleit-Pads ca. 5-10° also sind nicht so effektiv, haben aber den Vorteil das der Kühlkörper nicht verrutscht, denn mit Wärmeleitpaste müsste man den Kühlkörper arretieren


    Wärmeleitender Kleber. Meiner ist allerdings leider durch Überlagerung nach inzwischen 10 Jahren kaputtgegangen. (http://www.reichelt.de/Waermel…rmeleitkleber&OFFSET=500&) Gibts auch als 2K-Epoxy, ist aber teuer.


    Man kann auch stino-Sekundenkleber oder einen normalen Epoxy nehmen, da die Klebeschicht im Idealfall so dünn sein sollte, daß sie für den Wärmewiderstand kaum eine Rolle spielt. Allerdings kann Sekundenkleber bei höheren Temperaturen kaputtgehen, aber der Raspi sollte ja bei 80°C auf jeden Fall runterregeln.

  • Dem muss ich leider erneut widersprechen.


    Aluminium ist billiger und leichter zu verarbeiten, Kupfer hat aber eine höhere Wärmeleitfähigkeit. Deshalb ist eigentlich auch bei passiver Kühlung Kupfer zu bevorzugen, wird nur aufgrund der Kosten selten gemacht...


    Da kein Header vollkommen gerade/eben ist nutzt man Wärmeleitpaste zum "füllen" sodass der Übergang zwischen Kopf der CPU und Kühlkörper effektiver ist... Klar kann man den Kühlkörper auch stumpf für immer fest kleben ist aber weniger effektiv und ist eigentlich nur bei IC's wie zB. Spannungswandler üblich. Kleber benötigt generell einen gewissen Abstand zwischen den Objekten aber genau das wirkt der Kühlleistung entgegen. Paste befindet sich nur in besagten Unebenheiten/Lücken um eine ebene Fläche zu bilden und ein gewisser Anpressdruck sorgt dafür das alle Flächen direkt aufeinander liegen.


    Und runterregeln tut der Pi erst bei 85° wobei das nicht zwangsläufig eine Garantie ist das dadurch auch die Temperatur sinkt :fies: Der Pi3 wird schneller und doller, heiß. Es wäre also schlecht wenn er ständig über 85°C heiß wird und runter regeln muss.


    Ich sehe daher bezüglich Temperatur o.ä. kaum noch einen Unterschied zwischen einem Pi3 oder einem aktuellen Intel Skylake. Letzterer wird nämlich mit entsprechender Kühlung nicht so warm wie ein Pi3, wenn man denn auf gute Materialien achtet ;) Mein i7-6700 Skylake PC ist vollständig Silent also Lüfterlos und der CPU läuft durchschnittlich bei 29°C ... Wobei ich natürlich einen Monströsen Tower-Kühler habe und das nicht wirklich mit dem Pi zu vergleichen ist, dennoch hab ich mit dem selben Kühler auch schon schlechtere Werte gehabt nur weil ich billige Wärmeleitpaste nutzte...

  • Bei den kleinen Kühlkörpern und ohne aktive Umströmung (Lüfter) oder Ableitung (Heatpipe) ist der Wärmeübergang Kühlkörper-Luft um so Vieles höher als die Wärmeleitung im Kühlkörper, daß der Unterschied in der Leitfähigkeit zwischen Alu und Kupfer wirklich nicht ins Gewicht fällt.


    Mal was Anderes: Ist denn anzunehmen, daß die Probleme mit dem Uart auf den GPIOs noch gelöst werden? Ich habe den Raspi 3 gerade auch deswegen genommen, weil ich sowohl den Uart als auch Bluetooth nutzen möchte. Gut, zur Not muß ich halt einen USB-Adapter anstecken.

  • Hallo Timm, hallo Meigrafd,



    Kannst du das genauer spezifizieren (link) ?


    Vielleicht hilft das https://blog.adafruit.com/2016…-3-uart-speed-workaround/
    Ansonsten auf einen neuen Kernel/Firmware warten.


    ist doch schon längst gelöst.


    Das Problem bestand darin, das BT und UART gleichzeitig nicht möglich waren, da die Nutzung von BT die gleichzeitige Nutzung von GPIO14 und GPIO 15 für TX und RX verhinderte.


    Ein kluger Kopf hat einen Workaround geliefert, mit dem über einen DeviceTree andere GPIO-Pins für UART genutzt werden.


    Link erschließt sich durch eine gezielte Suche... denn Stichworte habe ich hier genug gebracht. Und gepostet wurde das auch schon letzte Woche.



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.


  • ...Danke (oder auch nicht) für die Zusammenfassung meines Links... Lesen und etwas durch klicken = Hintergrundwissen und Lösung.



    Und deinen Spruch nach einer gezielten Suche kannst du dir langsam auch sparen - gezielt suchen ohne passende/genaue Suchbegriffe führt zu nichts oder schnellem Frust.


  • Kannst du das genauer spezifizieren (link) ?


    Momentan äußert sich das so, daß ich auf den Uart-Pins beim Booten den "recovery Screen" mit 115200 Baud bekomme, dieser Uart dann aber anscheinend abgeschaltet wird. Ich habe nur eine ttyS0, kann diese mit Gtkterm öffnen, es kommt aber nichts am Uart raus. Könnte also auf das BTmodul ins Nirwana gehen. Konsole auf Uart ist abgeschaltet.


    Auch Versuche mit dtoverlay=pi3-miniuart-bt und so haben nichts gebracht. Version ist natürlich aktuell.


    Bei den Tuts zum Aktivieren / Umstellen des Uart gibt es leider fast täglich Änderungen. Ich werde wahrscheinlich erstmal abwarten und hoffen, daß es bald eine stabile Lösung gibt.

  • Hallo Meigrafd,


    normalerweise ziehe ich mich aus Threads, in denen Du um Dich schlägst und andere triffst, sofort zurück.


    Ich mach hier mal eine Ausnahme - bin dann aber auch gleich aus diesem Thread draußen.


    Ich bin mir mehr als sicher, dass Stichworte wie

    Code
    BT UART GPIO14 GPIO15 RX TX DeviceTree


    und dann noch in Verbindung mit

    Code
    Raspberry Pi 3B

    mehr als ausreichend sind, um den von Dir aufgeführten Link und einige andere zu finden, die bereits in der vergangenen Woche in den bevorzugt englischsprachigen und niederländischen Foren veröffentlicht wurden, zu finden.


    Und solche Links findet man bereits auch dann, wenn man sich dafür interessieren sollte, wie am RPi 3B Bluetooth zu installieren sei.
    Also Stichworte hier:

    Code
    Raspberry Pi 3B Bluetooth install


    oder auf deutsch:

    Code
    Raspberry Pi 3B Bluetooth installieren


    führen zu entsprechenden Links, die dann auch die Problematik mit UART vs. Bluetooth behandeln.


    Und eigentlich sollte man davon ausgehen, dass solche Stichworte ausreichen, um den wirklich Interessierten zur Lösung zu bringen. Es kann wohl nicht Dein Ernst sein, dass sich jemand hinsetzt und die Sachen übersetzt und mit Screen-Shots hinterlegt und die Wirkung beweist (was sich ja schon dadurch erübrigt, da dies von einigen - mich eingeschlossen - schon erfolgreich umgesetzt wurde).



    In anderen Foren postet man einfach Lösungen eigener Probleme - anstatt seine Energie mit Herumgiften zu vergeuden.


    Aber sei's drum. Ich bin hier raus.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Na also, geht doch - war das so schwer die entsprechenden Suchbegriffe als solche auch klar zu kennzeichnen?


    Es scheint für Dich zu schwierig sein klar zu definieren "das hier sind die suchbegriffe", stattdessen schreibst du nen fünfzeiler und erwartest dann das man aus dem geschriebenen selber eine "gezielte suche" entwirft/herausfindet... Diese Vorgehensweise Deinerseits hab ich heute bereits schon mal bemängelt, willst aber anscheint nichts dran ändern - tja, dann leb damit das ich das auch künftig bemängel.

  • Sorry Leute, ihr müßt euch deswegen nicht hier kloppen.


    Diese Links und einige mehr habe ich durchaus gefunden und versucht umzusetzen. Hat aber nicht funktioniert. Trotz update und upgrade und Image der SD-Karte und Recovery, so daß keine kaputtgemachte Installation nur verschlimmbessert wird. Es ist halt auch so, daß die Flickerei vor dem 18.03. eine andere ist, die jetzt nicht mehr funktioniert.


    Es ist schön, wenn es bei anderen funktioniert, bei mir hat es nicht funktioniert. Es ist auch nicht so, daß der Uart einfach mit dem CPU-Takt schwankt. Es kommen schlichtweg bis auf die Konsole am Anfang gar keine Daten.


    Deswegen werde ich jetzt erstmal abwarten, was da noch kommt.
    Uart an USB-seriell-Adapter (ttyUSB0 bzw. ttyUSB1) funktioniert mit Gtkterm.


  • Hallo Forenmitglieder, ich bin heute das erste mal hier. Ich bin im Grunde genommen, schon ein alter Sack. Bisher hatte ich nur mit Windows zu tun. Also seht es mir nach , wenn ich nicht so mit der Materie vertraut bin, wie ihr. Das erste Problem war schon, wie erstelle ich eine Frage.
    Deshalb habe ich mich hier eingeklinkt.
    Nun zu meinem Anliegen.
    Seit drei Tagen habe ich den Raspberry PI 3 . Der soll ein ARM 8 Prozessor haben. Auf dem Prozessor steht BC 28XX.
    Ich habe den Prozessor ausgelesen und zeigt mir die Daten vom PI2 an:


    pi@raspberrypi:~ $ cat /proc/cpuinfo
    processor : 0
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 76.80
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4



    processor : 1
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 76.80
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4



    processor : 2
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 76.80
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4



    processor : 3
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 76.80
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4



    Hardware : BCM2709
    Revision : a02082


    Mein Prozessor Takt wird mit 600 Mhz angezeigt.
    sind bei euch auch so die Daten oder habe ich was falsches geliefert bekommen.



    Befehl Prozessor auslesen


    [font="DejaVu Sans Mono, serif"]cat /proc/cpuinfo[/font]



    [font="DejaVu Sans Mono, serif"]Ich sage schonmal Danke[/font]


  • Seit drei Tagen habe ich den Raspberry PI 3 . Der soll ein ARM 8 Prozessor haben. Auf dem Prozessor steht BC 28XX.
    Ich habe den Prozessor ausgelesen und zeigt mir die Daten vom PI2 an:


    Mein Prozessor Takt wird mit 600 Mhz angezeigt.
    sind bei euch auch so die Daten oder habe ich was falsches geliefert bekommen.


    Das mit dem Prozessor-Takt von 600 Mhz, liegt auch am default governor von jessie. Ist auf "powersave", ... bei wheezy auf "ondemand".


    Wegen dem ARM 8-Prozessor (PI3) müssen wir uns noch etwas gedulden. Siehe z. B. auch diesen Thread: http://www.forum-raspberrypi.d…y-pi-3b-welcher-prozessor


    BTW: Du hast schon das richtige Gerät geliefert bekommen.

    The most popular websites without IPv6 in Germany.

  • apfelwurm: Was hat dein Beitrag mit dem zu tun was du gequoted hast? :s
    Bitte künftig darauf achten, das verwirrt nur unnötig (und zieht die Seite unnötig in die Länge)


    Das was rpi444 mit Fachchinesisch sagte bedeutet: Wenn der Pi nichts zu tun hat taktet er sich runter um Strom zu sparen und weniger Abwärme zu erzeugen. Steigt die CPU Auslastung auf über 50% taktet er sich automatisch hoch - das ist auch schon bei den alten Pis so.
    Lässt sich ändern indem man:
    - Den governor auf performance stellt

    Code
    echo -n performance | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor


    - Oder "force_turbo=1" in /boot/config.txt einträgt.




    PS: Bitte bleibt beim Thema dieses Threads: Raspberry Pi 3