Wie aktiviert man das WLAN beim Raspberry Pi 3

  • Hallo,
    ich habe mir gerade einen Raspberry Pi 3 zugelegt und habe da gleich mal Raspbian installiert. Mit Linux kenne ich mich aber überhaupt nicht aus und daher jetzt meine Frage.
    Der neue Raspberry soll ja Wlan schon on board haben. Leider konnte ich das bisher aber noch nicht in Betrieb nehmen. Weiss jemand wie das geht? Es gibt auf der grafischen Oberfläche oben rechts zwar Einstellungen, da kann ich aber die ssid meines netzwerkes nicht einstellen bzw. finden und die eingabe eines Passortes bringt auch keinen Erfolg. Es hat den Anschein dass es zwar vorbereitet ist, aber die Hardware noch nicht bereit ist, als wenn man da erst noch was einschalten muss.


    mfg
    Gemelon

  • Ich hatte gestern zwar nicht mit raspbian getestet sondern mit ubuntu mate aber es funktionierte einwandfrei sich mit dem Internet zu verbinden (ich Wechsel nachher auf Raspbian). Empfang des Wlan Signals ist nicht schlecht ( 48% bei etwa 20 meter Entfernung zur Box, 3x Beton Wand zwischen).
    Ich versuch das nachher auch mal und wenn noch keine Antwort von jemanden hier aus dem Forum kam schreib ich gerne wie ich vorgegangen bin ;)

    :shy: Legastheniker :shy:


    wer fehler findet darf nachsicht haben


    Klick>Youtube Channel<Klick

  • Hi,


    in der aktuellen Version von Jessie vom 26.02.2016 sollte die Unterstützung für den Pi3 schon enthalten sein. Bei meiner Version vom 09.02.2016 war das noch nicht der Fall aber ein


    Code
    sudo apt-get update
    sudo apt-get upgrade


    hat das OnBoard Wifi sofort zum Leben erwecken können.

  • Danke pedator92 und doing für die schnelle Antwort.
    Ich werde es dann wohl mal ausprobieren ob es mit einem update geht und wenn nicht were ich mal ubuntu installieren. Ich bin aber davon ausgegangen, dass der sich bei der Installation schon die neueste Version aus dem Netz zieht.

    Edited once, last by Gemelon ().


  • Ich bin aber davon ausgegangen, dass der sich bei der Installation schon die neueste Version aus dem Netz zieht.


    bei der neusten version ist es enthalten;)


    2016-02-26:
    * Support added for Pi 3, including Wifi and Bluetooth
    * Option to set wifi country code added to raspi-config

    :shy: Legastheniker :shy:


    wer fehler findet darf nachsicht haben


    Klick>Youtube Channel<Klick

    Edited once, last by pedator92 ().

  • evtl. muss vorher über raspi-config erst das Land für den W-Lan Betrieb eingestellt werden ?!?!?


    Da ich das so oder so als erstes aufgerufen habe, kann ich das nicht mehr sagen. Bei mir hat er danach allerdings mein W-Lan angezeigt und ich konnte mich problemlos einloggen.

  • Um dieses umzustellen gehst du einfach auf Menü > Einstellungen > Raspberry Pi Configuration in dem Fenster einfach auf Localisation und als letzter Punkt steht "Set Wifi Country...". Einfach "De Germany" wählen ok drücken und Neustarten lassen. Oben auf das Netzwerk Symbol gehen mit der Maus und kurz warten bis dein Router auftaucht. Ssid eingeben und schon hast du internet über das pi 3 wlan :)

    :shy: Legastheniker :shy:


    wer fehler findet darf nachsicht haben


    Klick>Youtube Channel<Klick

  • Das was "raspi-config" unter "Change Wi-fi Country" macht ist /etc/wpa_supplicant/wpa_supplicant.conf einen Eintrag hinzuzufügen:

    Code
    country=DE


    Ein reboot ist dafür nicht erforderlich, es sollte eigentlich reichen das wlan0 Device neu zu starten:

    Code
    ifdown -v wlan0 ; ifup -v wlan0

    -v bewirkt "verbose" also genaue Infos was er macht, kann auch weggelassen werden)


    Sofern man die aktuelle Firmware hat müsste WiFi und BT automatisch aktiviert sein. Sollte man keinen aktuellen Kernel haben würde der Pi3 nicht bootn da der alte Kernel vom Pi2 den neuen CPU nicht erkennt... Wenn also dein Pi3 startet kann man davon ausgehen das Firmware und Kernel aktuell sind ;)


    Was dir evtl. fehlt ist ein entsprechender Eintrag in /etc/network/interfaces

    Code
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
  • Ich habe jetzt wohl alle Vorschläge ausprobiert und bin zu keinem Ergebnis gekommen. Ich denke mein Rasperry ist defekt. Ich habe das Land eingestellt, zuerst per Menü dann in der Datei per Texteditor, aber wenn ich oben auf das Netwerksymbol klicke, dann erscheint nur etwas das mir nichts sagt "WLAN-243194", das ist alles. Es gibt auch in meiner Nachbarschaft kein Wlan das so heist. Ich hatte beim ausprobieren noch andere Probleme. Ich kann kein anderes Betriebssystem mehr installieren, da der Rechner beim start des NOOBS nur noch Raspbian anzeigt und keine verbindung per LAN aufbaut. Erst wenn Raspbian installiert ist kann ich eine Verbindung mit dem Internet herstellen. Das Teil zeigt bei vielen dingen ein untypisches Verhalten.
    Ich werden den Raspberry wohl zurück schicken. Übrigens "[font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]/etc/network/interfaces" gibt es bei mir nicht, bei mir heisst der ordner "/etc/network/interfaces.d" und da ist nichts drin.[/font]


  • ... via cat kann man es aus der wpa_supplicant.conf auslesen ...


    Aber nur als root oder mit sudo.

    The most popular websites without IPv6 in Germany.


  • Hi, ich habe das neuste Jessie-Image vom 26.02. installiert und mein PI3 hat leider auch Probleme mit dem WLAN. Der Adapter wird erkannt aber ich bekomme nur 2-3 und mir vollig unbekannte SSID angezeigt.
    Automatisch zusammengefügt:[hr]


    Hi, ich habe das neuste Jessie-Image vom 26.02. installiert und mein PI3 hat leider auch Probleme mit dem WLAN. Der Adapter wird erkannt aber ich bekomme nur 2-3 und mir vollig unbekannte SSID angezeigt. Eine Verbindung kann mit keiner von den angezeigten Netzwerken hergestellt werden. Schade, ist meiner auch defekt?

    Edited once, last by darkwing ().


  • Sofern man die aktuelle Firmware hat müsste WiFi und BT automatisch aktiviert sein. Sollte man keinen aktuellen Kernel haben würde der Pi3 nicht bootn da der alte Kernel vom Pi2 den neuen CPU nicht erkennt... Wenn also dein Pi3 startet kann man davon ausgehen das Firmware und Kernel aktuell sind ;)


    Ich bin mir nicht sicher ob die Aussage stimmt, meigrafd. Ich hatte ein Jessie vom 09.02.2016 auf der SD Karte als ich sie in den Pi 3 steckte. Der Pi 3 bootete ohne Probleme, aber ich hatte keinerlei WiFi und Blauzahn, auch der WiFi Country Eintrag in der Konfiguration fehlte.


    Nach einem apt-get update und einem apt-get upgrade konnte ich einfach oben auf das Netzwerk Symbol klicken - dann tauchte dort WiFi (not configured) als oberster Punkt in der Liste auf, passende SSID ausgewählt, Pre Shared Key eingetragen und das war es.


    Ich musste nichts in eine wpa_supplicant.conf eintragen.

  • Über das Panel oben rechts bekomme ich nur 2-3 merkwürdige und unbekannte Einträge angezeigt. apt-get update und upgrade habe ich gemacht ohne Erfolg. Neben den wlan Problemen ist mir mein PI3 jetzt auch schon 3x hängengeblieben. Maus und Tastatur waren gingen nicht mehr.


    Ich werde jetzt noch das ubuntu-mate-15.10.3 probieren und wenn das auch nicht funktioniert wird mein pi wohl defekt sein.

  • Sicherheitshalber hab ich jetzt auch noch mal [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]apt-get update und apt-get upgrade gemacht, mit null Erfolg. Da es bei den meisten geht und bei einigen nicht, muss es da noch einen gravierenden Fehler geben. Am besten zurück schicken das ding und warten bis die Probleme gelöst sind. Schade.[/font]


  • [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Am besten zurück schicken das ding und warten bis die Probleme gelöst sind. Schade.[/font]


    Wirfst du die Flinte nicht etwas vorschnell ins Korn? Ich würde einfach nochmal ganz von Vorne anfangen, mit einem Raspbian vom 26.02.2016, dann nur die üblichen Einstellungen (Expand Filesystem, Lokalisierung, Zeit und Tastatur), neu booten, dann apt-get update und apt-get upgrade (waren beim mir mehr als 80 MB) nochmal neu starten und dann nochmal nach WiFi ausschau halten...


    Wenn es wirklich Fehler in Raspbian geben sollte, die die WiFi Funktionalität blocken, dann wird in den Pi Towers bestimmt schon heftig dran gefeilt und du kannst in ein paar Stunden/Tagen mit einem Update rechnen.

  • So, ubuntu geht auch nicht. Auch hier stehen nur unbrauchbare UPC3xxx Netzwerke. Meine SSID ist nicht hiden und normalerweise bekomme ich mindestens 5-6 verschiedene wlans angezeigt. Irgendwie will mein PI3 nicht so richtig.

  • Ich habe das ganze jetzt mal mit meinem Raspberry Pi 2 versucht und da geht alle einwandfrei. Ich kann mehrere Betriebssysteme auswählen und Wlan geht auch. Der Raspberry Pi 3 ist definitiv kaputt.


  • ..., auch der WiFi Country Eintrag in der Konfiguration fehlte.


    Ich musste nichts in eine wpa_supplicant.conf eintragen.


    Es gibt noch zwei weitere Dateien wo man das eintragen kann bzw. evtl. schon eingetragen ist. Z. B.:

    Code
    :~$ cat /etc/default/crda | grep -i regdomain=
    REGDOMAIN=DE


    oder

    Code
    :~$ cat /etc/modprobe.d/cfg80211.conf | grep -i regdom
    #options cfg80211 ieee80211_regdom="DE"


    Siehe im Terminal auch die Ausgabe von:

    Code
    iw reg get

    The most popular websites without IPv6 in Germany.