Merkwürdige Werte bei DHT22-Sensor für Luftfeuchtigkeit


  • ich habe das das problem ,das mein dht22 immer nur 1% luftfeuchtigkeit ausgibt ,egal was ich mache ,kennt jemand das problem ? Temperatur schein ok zu sein :


    Hi,


    genau das Problem habe ich mit einem neu gekauften DHT22-Sensor ebenfalls.
    Den Sensor hab ich bereits an den ESP8266 und Arduino gehalten und verschiedene Librarys benutzt, aber immer der gleichen Fehler:
    Temperatur ok
    Luftfeuchtigkeit: permanent "1"


    Ich befürchte, er ist defekt. =(


    Mfg
    Minfred

    Edited once, last by Minfred ().

  • Habe ebenfalls ein Messproblem mit dem DHT22.


    Ich messe im Keller die Luftfeuchtigkeit mit einem Präzisionshygrometer (von der Arbeit ausgeliehen) und einem DHT22 verbaut an einem RPi2 (an GPIO 2) und pimatic (plugin: dht-sensors). Der Sensor und das Messgerät befinden sich direkt beieinander.


    Der DHT misst aktuell 7,4% rel. Luftfeuchtigkeit. Das analoge Messinstrument misst ca. 44%. Die Temperatur ist 19.7°C.


    Wenn ich nun in den DHT eine Zeit lang rein hauche. Geht die Luftfeuchtigkeit auf 100% bei gleichzeitigem Anstieg der Temperatur. Der DHT mach also irgendwas "richtiges". Ist also nicht gänzlich defekt.


    Ich hatte den Sensor zunächst an 3,3V mit einem Pullup-Widerstand an der Datenleitung von 4K7. Aktuell arbeitet er mit 5V. Die Datenleitung ist mit einem Spannungsteiler von 2x 4K7 an 5V und Masse angeschlossen. Auf der Datenleitung messe ich jetzt 3,2V (warum auch immer... ich erwartete eher 2,5V... vermutlich ist ein interner Pullup auf dem GPIO-Pin geschaltet?!?!!?). Bei erster Variante war die Luftfeuchtigkeit im Schnitt 5% höher.


    Pimatic und Pilight liefern übrigens die gleichen Ergebnisse, was mich vermuten lässt, dass es kein Konfigurationsproblem in Pimatic gibt.


    Das ungeschirmte Kabel ist ca. 7m lang und hat einen Querschnitt von 0,14mm².


    Fällt jemandem ein grundsätzlicher Fehler bei einem Aufbau ein? Bin für jede Ideen dankbar.


    P.S.: Ich hatte anfangs durch einen Fehler (4K7-Widerstand gegen Masse beim Spannungsteiler war nicht richtig drin) 5V auf dem GPIO-Pin. Da ich noch immer Messwerte rein bekomme, gebe ich davon aus, dass der Pin die 5V überlebt hat.

  • ich hatte nochmals einige DHT22 bestellt, was soll ich sagen jetzt sind meine Werte plausibel,


    im Wäschetrockenraum, frisch gewaschen gering geschleudert aufgehangen -> steigt von 35-40% also normale Raumfeuchte auf 60% und sinkt danach wieder auf 35-40%
    Betrete ich den Raum steigt die Raumfeuchte um 1-2%
    kommt mir alles plausibel vor ohne Kalibrierung.
    http://www.forum-raspberrypi.d…uino?pid=279615#pid279615
    [Blocked Image: http://www.forum-raspberrypi.de/attachment.php?aid=13045]

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Ich habe mir jetzt auch einen neuen DHT22 aus dem 2017'er Produktionsjahr bestellt. Der bringt jetzt plausible Werte >40%. Das analoge Hygrometer sagt 45%. Mit der Abweichung kann ich leben.


    Vermutlich ist eine Menge Asia-Schrott-Sensoren im Umlauf. Aber für 5 EUR hat man auch keine Lust auf Reklamation.


    Habe übrigens den DHT22 ohne PullUp-Widerstand angeschlossen. Läuft auch ohne Probleme. Werde die nächsten Tage aber einen 4K7 Widerstand und einen 100nF Kondensator einlöten und schauen, wie sich der Wert verändert.