[RPi 3] WiFi & SSH: SSH-Login friert ein / hängt

  • Hallöle,


    ich bin glücklicher Besitzer eines RasPi 3. Habe allerdings ein kleines Problem mit WiFi: :helpnew:
    Sobald ich mich via ssh auf den Pi verbinden möchte friert ssh nach der Eingabe des Passwords ein.
    Gebe ich das falsche Password ein, so erhalte ich erneut die Aufforderung es nochmals einzugeben bzw nach 3 Versuchen: "Permission denied".


    Über RJ45 kann ich mich einloggen. (Ist leider keine Alternative, auch ein externer USB-Stick leider nicht).


    Leider haben beide Tipps nicht geholfen :no_sad:
    - pre-up iw dev wlan0 set power_save off
    - options 8192cu rtw_power_mgnt=0 rtw_enusbss=0


    Hiermal der interessante Ausschnitt aus
    ssh -vvv pi@192.168.0.3


    für jeden sinnvollen hinweis bin ich dankbar.


    P.S. Sonst mach WiFi augenscheinlich keine Probleme. apt-get update, dist-upgrade, surfen und pingen klappt ohne auffälligkeiten)

    Edited once, last by wysen ().


  • Sobald ich mich via ssh auf den Pi verbinden möchte friert ssh nach der Eingabe des Passwords ein.


    Welchen WLAN-Router hast Du?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Thx für die Antwort.


    der aktuelle Debuging-Ausschnitt wurde beim Betrieb mit einer Fritz.Box gemacht.
    Allerdings habe ich dies auch schon ausgeschlossen, weil ich bereits auf der Arbeit (TP-Link) als auch meinen Huawei E355 Router (Mobiler GSM/Wlan-Rauter) verwendet habe.
    Ich könnte noch Ad-Hoc versuchen, aber glaube auch hier, dass es keine Besserung bringt.


  • der aktuelle Debuging-Ausschnitt wurde beim Betrieb mit einer Fritz.Box gemacht.


    Welche FritzBox bzw. mit welcher Firmware-Version?


    Poste mal von deinem PI, wenn dieser per WLAN mit dem Router verbunden ist, auch die Ausgaben von:

    Code
    ip a
    ip r
    ip n s
    ps -fC avahi-daemon,dhcpcd,ntpd
    cat /etc/network/interfaces
    sudo cat /var/log/syslog | grep -iE 'error|warn|fail|reason|deauth|check'

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Danke rpi444


    aber das Problem ist nicht die Netzwerk-Konfiguration...
    Ich habe hier gerade den Pi zusammen mit einem Computer in ein seperates Netzwerk gehangen, damit nix querschlägt. NFS,FTP,Samba funktioniert wunderbar. Das Problem ist besteht nur mit ssh.
    Automatisch zusammengefügt:[hr]
    Zum Auth.log:

    Code
    Accepted password for pi from 192.168.0.2 port 56239 ssh2
    pam_unix(sshd:session): session opened for user pi by (uid=0)
    systemd-logind[405] New session c3 of user pi.


    Beim Client bleibt die Debug-Ausgabe unverändert (siehe erster Post)

    Edited once, last by wysen ().


  • Das Problem ist besteht nur mit ssh.


    Ja, das habe ich auch so verstanden. Du bist nicht der einzige der mit dem PI3, ssh und Wifi, diese Probleme hat.


    Deshalb sollte man sich m. E., auch diese Ausgaben (siehe oben) anschauen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden


  • Ja, das habe ich auch so verstanden. Du bist nicht der einzige der mit dem PI3, ssh und Wifi, diese Probleme hat.


    Deshalb sollte man sich m. E., auch diese Ausgaben (siehe oben) anschauen.


    :danke_ATDE:
    Nichts für ungut, aber genau deshalb habe ich ja bereits an unterschiedlichen Konfigurationen getestet =(
    Ich habe es jetzt sogar nochmals bei Freifunk & AdHoc getestet - nix.
    Die IP-Adressenkonfiguration (sei es v4 oder v6) ist jedesmal stimmig.
    Probleme bereitet nur SSH (scp, ssh) am Pi.
    Dabei ist es egal ob ssh vom Pi3 auf anderen SSH-Server oder ein anderer SSH-Client (Putty, ssh v. Ubuntu, ssh v. debian) auf den Pi3 SSH-Server.


    Ich hatte ja gehoft mit dem Deaktivieren des Energiesparens beim WiFi das Problem zu beheben. Leider ist dem nicht so :( der eine Link gilt wohl nur für Pi2 und der andere (preup iw dev wlan0 set power_save off) hilft leider auch nicht.


    Vielleicht gibt es ja bald einen Update (kernelmodul, firmware, wasauchimmer) welches das Problem beseitigt.


    Grüße und Danke


  • Probleme bereitet nur SSH (scp, ssh) am Pi.


    Ja, und ich denke Du hast kein Interesse, den Fehler bzw. die Ursache zu finden.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ja, und ich denke Du hast kein Interesse, den Fehler bzw. die Ursache zu finden.


    Wieso? Weil ich nicht meine Firmware-Version eines Routers gepostet habe? Oder die verschiedenen IP-Adresskonstellationen der versch. Netzwerke in denen ich den Pi3 teste?
    Kann ich Dir sagen, weil ich keine Zugangsdaten zu den Routern habe. Ausserdem gibt sehe ich keine Notwendigkeit/Fehlerquelle in der Fritzbox & Co und die IP-Konfiguration ist korrekt - dem schrieb ich ja auch und dies ist nicht die Fehlerquelle, weil die Verbinung zum SSH-Server ja jeweils steht, es ist ein Problem was erst nach dem Schlüsselaustausch sich auswirkt.
    Im Syslog war leider nichts passendes. Deswg. postete ich ja auch das auth.log



    Aber gut - habe verstanden, wer hier nach Hinweisen fragt aber nicht folgt wird abgewatscht :-/


    Trotzdem Danke und schönen Sonntag


  • ... dies ist nicht die Fehlerquelle, ...


    Das weißt Du nicht und ich auch nicht, was die Fehlerquelle ist, deshalb sollte m. E. z. Zt. erstmal in "verschiedene Richtungen" geschaut werden.



    ...
    Im Syslog war leider nichts passendes.
    ...


    Warum willst nur Du allein entscheiden, willst was passend oder unpassend ist?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden


  • Das weißt Du nicht und ich auch nicht, was die Fehlerquelle ist, deshalb sollte m. E. z. Zt. erstmal in "verschiedene Richtungen" geschaut werden.


    Natürlich, aber die Netzwerkkonfiguration kann aus logischen Gründen ausgeschlossen werden. Du fragst ja auch nicht nach dem verwendeten Terminal, SD-Karte oder Tastatur am RasPi.



    Warum willst nur Du allein entscheiden, willst was passend oder unpassend ist?


    Weil ich mich lange genug mit Linux-Systemen auseinander gesetzt habe und nur die Aussage:

    Code
    #Passender Zeitstempel:
    Starting Session c6  of user pi.
    Started Session c6 of user pi.

    oder Hinweise auf Filesystemchecks, entfernten Swap ... nicht weiterhilft.


    Ich hatte hier die Hoffnung gehabt, dass jemand hier diesen Fehler schon genauer und detailiert Erkundet vllt. auch schon gelöst hat. Gerne helfe ich dabei auch bei einer Erabeitung einer Lösung oder Lösungsansätze. Aber nicht zum esoterischen Fehlersuche. Schliesslich konnte ich die Fehlerquelle ja bereits rechtweit ein grenzen.
    Ich denke, hier ist - sofern die RasPi-Hardware nicht nen hau weg hat - der Treiber vom WLan (evtl. Bluetooth) schuld.


    Grüße und schönen Sonntag noch...


  • ... aber die Netzwerkkonfiguration kann aus logischen Gründen ausgeschlossen werden.


    Was für dich logisch ist, muss nicht zwangsläufig für andere auch logisch sein.



    Ich denke, hier ist - sofern die RasPi-Hardware nicht nen hau weg hat - der Treiber vom WLan (evtl. Bluetooth) schuld.


    Du hast dir den verlinkten Beitrag aus dem raspberrypi.org-Forum nicht angeschaut. Dort wird berichtet, dass PI3+Wifi+SSH mit manchen WLAN-Routern funktioniert und mit machen nicht. Genaue bzw. ausreichende Informationen werden dort aber auch nicht zur Verfügung gestellt.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Moin,
    ich denke man sollte abwarten bis es eine offizielle Lösung gibt. Dei Entwicker sind sicherlich näher an raspberrxpi.org als an unserem Forum.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.


  • Aber nicht zum esoterischen Fehlersuche.


    Hier funktioniert PI3+SSH+Wifi ohne Probleme.


    Ich denke dein Problem ist:

    Code
    ssh_packet_set_tos: set IP_TOS 0x10


    EDIT:


    Versuch mal auf deinem PI3 (dort wo der sshd-Server ist), mit einem anderen TOS-Wert (Normal-Service statt Minimize-Delay wie vom ssh-Client evtl. gesetzt):

    Code
    sudo iptables -t mangle -I PREROUTING 1 -i wlan0 -p tcp --dport 22 -j TOS --set-tos 0x00


    Evtl. kannst Du (... wenn Du den Fehler auch esoterisch suchen willst ;) ) die iptables-Regel noch etwas optimieren, wenn Du z. B. mit tcpdump auf Client oder/und Server schaust, auf welche Datenpakete (d. h. welches tcp-Flag gesetzt ist) sich der Minimize-Delay-TOS-Wert (... der evtl. vom ssh-Client gesetzt wird und der Verursacher des Problems sein könnte) bezieht. Evtl. auch die Konfiguration des ssh-Clienten anschauen.


    Auf dem PI3, vor der Anmeldung per Wifi mit dem ssh-Client:

    Code
    sudo tcpdump -c 30 -vvveni wlan0 tcp port 22

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().