Raspberry Pi 3 Temperatur und WLAN Probleme

  • Bitte lasst die Finger von rpi-update! Wieso? => https://www.elektronik-kompend…/raspberry-pi/2006061.htm


    Nur wer weiß was rpi-update macht bzw worauf dabei zu achten ist und wofür das eigentlich gut ist, sollte es nutzen - aber blindes verwenden wird oft bestraft.
    Aus diesem Grund ist rpi-update auch nicht mehr standardmäßig beim nächsten Raspbian Release dabei, da das blinde verwenden Ursache 90% aller Problembehandlungen ist.


  • Ah, jetzt hab ich dich verstanden! Ich dachte das Repository von Wheezy wird noch aktualisiert. :s


    Super, werde ich gleich morgen ausprobieren. Ich möchte so wenig wie möglich am System verändern, ganz nach dem Motto "never change a running system". ;)


    Ich melde mich wieder, vielen Dank erstmal! :thumbs1:

  • Hallo meigrafd,


    also hat super geklappt. Danke für den Tipp.


    Ich habe dann vom Pi3 das Upgrade auf Jessie durchgeführt und siehe da, die WLAN Probleme sind weg. Evtl. ist beim ersten Upgrade etwas schief gelaufen und daher stammten die WLAN Probleme.
    Die Leistungssteigerung ist echt nicht schlecht, mein Programm (eine Sprachsteuerung zur Hausautomation) läuft deutlich schneller - TOP!


    Vielen Dank für deine Hilfe.

  • Ich habe auch seit längerem Probleme mit dem WLAN an meinem Pi 3. Ich möchte den Pi als Server mit WLAN-only betreiben. Dazu ist er momentan nicht zu gebrauchen: WLAN reißt nach längerer Zeit komplett ab, d.h. der Pi 3 ist gar nicht mehr per SSH / http zu erreichen.


    Meine Konfiguration:
    JESSIE LITE (komplette updates/upgrades, aktuell [font="Oswald, Tahoma, Verdana, Helvetica, Arial, sans-serif"]4.4.11-v7+[/font])
    rsync und lighttdp sonst nichts
    Energiesparfunktion am WLAN ist aus
    Ich habe ein 3A-Netzteil und eine externe USB-Festplatte angeschlossen. Habe es aber auch anderem Netzteil versucht. Wegen des Problems hängt nun auch eine Tastatur und der Fernseher am Pi 3. Am LAN hängt er nicht.


    Das Problem tritt am Router zuhause auf und auch hier im Urlaub (Fritzbox), daher schließe ich den Router als Ursache aus. Der Pi 3 steht in beiden Fällen nahe beim Router und hat eine sehr gute Verbindung.
    Das Problem ist unabhängig vom Net-Load. Es erscheint mir eher, dass es in Idle-Times auftritt. Der Pi läuft ca. 1 1/2 Tage, manchmal nur ca. einen Tag. Ich habe ihn aber auch schon über 48 h am WLAN gehabt.


    Wenn ich mir die Protokolle anschaue, erscheint es so, dass es ein Problem "bei den Frequenzen" gibt. Im kern.log sind die letzten Einträge:

    Code
    May 21 20:41:25 pi kernel: [112379.481703] cfg80211: Regulatory domain changed to country: DE
    May 21 20:41:25 pi kernel: [112379.481717] cfg80211:  DFS Master region: ETSI
    May 21 20:41:25 pi kernel: [112379.481722] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    May 21 20:41:25 pi kernel: [112379.481730] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    May 21 20:41:25 pi kernel: [112379.481738] cfg80211:   (5150000 KHz - 5250000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    May 21 20:41:25 pi kernel: [112379.481745] cfg80211:   (5250000 KHz - 5350000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    May 21 20:41:25 pi kernel: [112379.481751] cfg80211:   (5470000 KHz - 5725000 KHz @ 160000 KHz), (N/A, 2698 mBm), (0 s)
    May 21 20:41:25 pi kernel: [112379.481757] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)


    Im daemon.log finde ich:


    Die beschriebenen kurzzeitigen Aussetzer habe ich nicht bemerkt. Bei mir ist der Pi 3 nach ca. 1,5 Tagen komplett vom WLAN weg und lässt sich gar nicht mehr erreichen. Bei ifconfig hat er keine IP-Adresse mehr. Mit ifdown && ifup oder networking restart, lässt er sich wieder mit dem WLAN verbinden.


    Hat noch jemand das Problem? Gibt es jemanden der seinen Pi 3 dauerhaft am WLAN hat? Dafür habe ich ihn mir gekauft.


    Danke und Gruß,
    JSO


  • Gibt es jemanden der seinen Pi 3 dauerhaft am WLAN hat?


    Ja, und ohne Probleme. Falls die WLAN-Verbindung mal abbricht, wird diese ohne mein Zutun sofort wieder hergestellt.


    Hast Du bluetooth deaktiviert? ahavi-daemon deinstallieren, nur WPA2, in der FritzBox 802.11n nicht konfigurieren (d. h. nur 802.11g + ?), dhcpcd.service und ein wlan.service nutzen (d. h. kein networking.service und keine interfaces-Datei), cfg80211 optimieren, ntpd optimieren, dhcpcd.conf optimieren, kein ipv6, kein ipv4ll, statische arp-cache-Eintragungen mit renewing per cronjob, regelmäßige arpings zum Router mit einem cronjob, für den Fall der Fälle: direkte Verbindung über eth0 in einem anderen Subnetz möglich (statt Tastatur und Bildschirm), etc.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ja, und ohne Probleme. Falls die WLAN-Verbindung mal abbricht, wird diese ohne mein Zutun sofort wieder hergestellt.
    ...


    Danke für die Info! Das gibt Hoffnung.


    Nein, ich habe keine besonderen Optimierungen vorgenommen und auch nichts deinstalliert.


    Ich mache nun Folgendes: Komplett neues JESSIE LITE auf neuer SD-Karte. raspi-config mir Lokalisierung auf Deutschland vornehmen und Hostname auf "pi" ändern. Dann konfiguriere ich das WLAN, d.h. in der wpa_supplicant.conf ein network mit ssid und psk konfigurieren. Sonst mache ich auf dem System gar nichts.


    Dieses System lasse ich nun laufen und schaue mal was passiert... wenn das WLAN am Donnerstag morgen noch steht baue ich langsam auf.

    Edited once, last by JSO ().

  • Ich habe nun ein frisches JESSIE LITE auf einer neuen SD-Karte installiert, habe mit raspi-config die grundlegenden Einstellungen durchgeführt: PW für pi geändert, hostname auf pi geändert, Internationalisierungs-Optionen gesetzt, inkl. WLAN. Dann habe ich für mein WLAN die SSID und das PW in wpa_supplicant gesetzt. Sonst nichts. Reboot.


    Leider ist es nach wie vor so, dass ich nach ca. 2 Tagen den pi nicht mehr per PuTTY erreichen kann. In der Liste der DHCP-Geräte meines Routers taucht er nicht mehr auf. Auf dem pi direkt zeigt mit ifonfig immer noch die IP an! Wenn ich einen ping auf google.com mache, erhalte ich auch Antworten, wenn ich einen ping auf meinen lokalen laptop (192.168.0.20) mache, antwortet dieser auch.


    Anschließend kann ich den pi auch wieder per PuTTY erreichen! Ohne reboot des pi, ohne Neustart des Netzwerkes.


    Das kann doch kein Hardware-Problem sein? Bin ich wirklich der einzige der das Problem hat? Kann es am Netzteil liegen? Ich verwende ein Aukru Micro USB 5V 3A Netzteil Ladegeräte für Raspberry Pi 3 Model B.


    Leider macht dieser kleine Fehler der pi für mich als Server unbrauchbar: An seinem Zielstandort, hat er weder TV noch Keyboard, dort muss es per PuTTY klappen :(


  • Das kann doch kein Hardware-Problem sein? Bin ich wirklich der einzige der das Problem hat?


    Nein, das ist m. E. auch kein Hardware-Problem. Poste beim nächsten mal, von deinem PI3, vor und nach dem Ping zu deinem Laptop, die Ausgaben von:

    Code
    arp -av
    ip n s


    Ich denke, da wird vor dem Ping, im Pi3 kein arp-cache-Eintrag für den Router vorhanden sein.


    Mit cronjobs kann man den PI3, den (statischen) arp-cache in bestimmten Zeitabständen erneuern lassen und auch regelmäßig arpings ins (W)LAN bzw. an den Router senden lassen,

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hier die Ergebnisse als der pi nicht erreichbar war:

    Code
    arp -av
    ? (192.168.0.20) auf 08:11:96:3c:1b:84 [ether] auf wlan0
    ? (192.168.0.1) auf c4:27:95:b2:d0:12 [ether] auf wlan0
    Eintrage: 2   Ignoriert: 0   Gefunden: 2
    
    
    ip n s
    192.168.0.20 dev wlan0 lladdr 08:11:96:3c:1b:84 STALE
    192.168.0.1 dev wlan0 lladdr c4:27:95:b2:d0:12 REACHABLE
    fe80::c627:95ff:feb2:d012 dev wlan0 lladdr c4:27:95:b2:d0:12 router STALE


    Dann habe ich mich direkt am pi angemeldet und pings gemacht:
    1. auf 8.8.8.8 Antworten wurden empfangen, aber ssh ging danach nicht
    2. auf 192.168.0.1 (mein Router). Nach 12 sek kam die erste Antwort, kein ssh möglich
    3. auf 192.168.0.20 (mein Laptop). Nach 7 sek kam die erste Antwort. Nun kam ich per PuTTY auf den pi



    Hier die Ergebnisse:

    Code
    arp -av
    ? (192.168.0.20) auf 08:11:96:3c:1b:84 [ether] auf wlan0
    ? (192.168.0.1) auf c4:27:95:b2:d0:12 [ether] auf wlan0
    Einträge: 2   Ignoriert: 0   Gefunden: 2
    
    
    ip n s
    192.168.0.20 dev wlan0 lladdr 08:11:96:3c:1b:84 STALE
    192.168.0.1 dev wlan0 lladdr c4:27:95:b2:d0:12 REACHABLE
    fe80::c627:95ff:feb2:d012 dev wlan0 lladdr c4:27:95:b2:d0:12 router STALE


    Ich kann daraus nichts ableiten :(


  • Hier die Ergebnisse als der pi nicht erreichbar war:


    Dann habe ich mich direkt am pi angemeldet und pings gemacht:


    Das verstehe ich (noch) nicht. Wie hast Du die Ausgabe von "arp -av" erhalten, als Du nicht direkt am PI angemeldet warst?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden


  • Das verstehe ich (noch) nicht. Wie hast Du die Ausgabe von "arp -av" erhalten, als Du nicht direkt am PI angemeldet warst?


    Ich habe gewartet, bis der pi wieder einmal nicht per PuTTY erreichbar war. Dann habe ich mich direkt angemeldet und "arp -av" ausgeführt (die ersten Ergebnisse). Als der pi dann wieder über PuTTY erreichbar war, habe ich "arp -av" ein zweites mal ausgeführt. Ich hatte Dich so verstanden, dass ich so vorgehen sollte.


    Zwischenzeitlich habe ich herausgefunden, dass ein ping auf den router nicht zum Erfolg führt. Nur nach dem ping auf den Laptop direkt ist der pi wieder erreichbar. Ich mache mal ping-log-script als hourly cron job...

  • Nun habe ich einen stündlichen cronjob eingerichtet, der jeweils drei pings auf den router, meinen laptop, die diskstation und google.com absetzt. Leider führte das nicht zum gewünschten Ergebnis und der pi bleibt unerreichbar. Da ich den pi in der Liste der DHCP-Geräte auf meinem Router nicht sehe, vermute ich, dass client-seitig (also auf dem pi) etwas am DHCP-Protokoll nicht funktioniert (lease nicht erneuert?)


    Ich versuche es nun mit einem cronjob, der einmal täglich ifdown && ifup macht.


  • Nun habe ich einen stündlichen cronjob eingerichtet, der jeweils drei pings auf den router, meinen laptop, ...


    Ist dein laptop ständig (24/7) online?



    Ich versuche es nun mit einem cronjob, der einmal täglich ifdown && ifup macht.


    BTW: Mit jessie gibt es bessere tools, als ifdown und ipup.



    Automatisch zusammengefügt:
    [hr]


    Da ich den pi in der Liste der DHCP-Geräte auf meinem Router nicht sehe, vermute ich, dass client-seitig (also auf dem pi) etwas am DHCP-Protokoll nicht funktioniert (lease nicht erneuert?)


    Das widerspricht aber deiner Aussage im Beitrag #28. Dort hast Du u. a. geschrieben:

    Quote


    ... ist es nach wie vor so, dass ich nach ca. 2 Tagen den pi nicht mehr per PuTTY erreichen kann. In der Liste der DHCP-Geräte meines Routers taucht er nicht mehr auf. Auf dem pi direkt zeigt mit ifonfig immer noch die IP an! Wenn ich einen ping auf google.com mache, erhalte ich auch Antworten, ...


    EDIT:


    Versuch mal wenn Putty mal nicht mehr funktioniert, mit einer Linux-Live-CD/DVD (oder gleichwertig) und ssh (statt Putty) als Client.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Das widerspricht aber deiner Aussage im Beitrag #28. Dort hast Du u. a. geschrieben:


    Wo siehst Du da einen Widerspruch?


    Ich fasse nochmal das Problem zusammen: Mein pi hat ein nacktes Jessie Lite und hängt am WLAN. Nach ein bis zwei Tagen ist er nicht mehr erreichbar. Er antwortet nicht auf pings, ist nicht in der Liste der DHCP-Geräte am Router sichtbar und ich kann ihn nicht per PuTTY (ssh) erreichen.


    Die Ursachenanalyse ist inzwischen soweit:
    Hardwareproblem ist unwahrscheinlich
    Meine Theorie: Es stimmt etwas clientseitig (also auf dem pi) nicht mit der WLAN-implementierung. Vielleicht DHCP, vielleicht Orchestrierung der Dienste, ...


    Ich versuche nicht nur den pi mit PuTTY von meinem Laptop zu erreichen. Ich habe es auch von einem Debian (in VM auf meinem Laptop probiert). Auch wenn ich mich per PuTTY auf meiner DiskStation einlogge komme ich nicht weiter auf den pi (weder mit ssh noch mit ping).


    Lösungsansätze
    stündlicher cronjob mit pings - funktioniert nicht zuverlässig
    täglicher cronjob mit ifdown && ifup (halte ich für eine Krücke)


    Ich melde mich wieder wie sich das bewährt. Da mein pi aber ein backup-server werden soll, ist es natürlich blöd, wenn während eines Backups die Verbindung wegbricht... mal sehen wie robust rsync hier ist...

  • Nachdem der pi nun längere Zeit up und per WLAN erreichbar war und auch die ersten Tests mit rsync erfolgreich waren, ist das Thema aus meiner Sicht erledigt. Die Lösung ist allerdings wenig elegant:
    Täglicher cronjob mit ifdown && ifup


    Nach der Einrichtung des Jobs ist der pi zuverlässig über WLAN erreichbar. Glücklicherweise kann ich mein "ifdown && ifup" script auch ausführen, wenn der rsync-server aktiv einen Backup durchführt, ohne dass der Backup abbricht (andere Anwendungen sind da vermutlich empfindlicher). Ziel erreicht.


    Diese Woche sprach ich mit einem Kollegen: Als ich ihm von meinem Problem erzählte, erwiderte er nur, dass das WLAN-Problem bekannt sei und dass die Lösungen allesamt Workarounds wären. Aus meiner Sicht ist dieses WLAN-Problem eine schwere Schwäche vom Raspberry Pi oder von Raspbian (oder sogar von Debian).


  • Aus meiner Sicht ist dieses WLAN-Problem eine schwere Schwäche vom Raspberry Pi oder von Raspbian (oder sogar von Debian).


    Warum habe ich mit meinem PI3 + Jessie-lite + builtin-Wifi, dieses "WLAN-Problem" nicht?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • ...Wie bereits in Beitrag#10 erwähnt:


    Für WLAN ist standardmäßig das Power-Management aktiviert. Nur wenn man das Power-Management explizit abschaltet behält der Pi3 dauerhaft das WiFi Module an.
    Um das zu erreichen gibt es mehrere Möglichkeiten, die beste ist jedoch über die Datei /etc/network/interfaces


    Code
    allow-hotplug wlan0
    iface wlan0 inet manual
        post-up iw dev $IFACE set power_save off

    ...letzte Zeile ist die wichtige inkl. Einrückung.


    In seltenen Fällen fehlt das "wireless-tools" Paket was man hierfür benötigt - bei manchen abgespeckten Images zum Beispiel. Dann brauch man das Paket aber nur nachinstallieren damit obiges funktioniert:

    Code
    sudo apt-get install wireless-tools


    Es gibt auch die Einstellung "wireless-power off" im jeweiligen Abschnitt zur wlan0 Schnittstelle in /etc/network/interfaces , allerdings funktioniert das mit einigen Kernel-Versionen nicht.


    Den aktuellen Power-Management Status kann man so abfragen:

    Code
    iw wlan0 get power_save

    Oder auch hierüber:

    Code
    iwconfig

  • Dann habe ich mich direkt angemeldet ...


    Zwischenzeitlich habe ich herausgefunden, dass ein ping auf den router nicht zum Erfolg führt. ...


    Wenn Du bei einer Direktanmeldung am PI3, deinen WLAN-Router (per Funkverbindung) vom PI3 aus immer pingen kannst, warum schlussfolgerst Du, dass die WLAN-Verbindung des PI3 nicht funktioniert?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wenn Du bei einer Direktanmeldung am PI3, deinen WLAN-Router (per Funkverbindung) vom PI3 aus immer pingen kannst, warum schlussfolgerst Du, dass die WLAN-Verbindung des PI3 nicht funktioniert?


    Ich hatte gehofft, dass der Ping auf den Router den PI3 aus dem "Dornrösschenschlaf" holt. Leider war das nicht so.
    Automatisch zusammengefügt:[hr]


    Für WLAN ist standardmäßig das Power-Management aktiviert. Nur wenn man das Power-Management explizit abschaltet behält der Pi3 dauerhaft das WiFi Module an.
    Um das zu erreichen gibt es mehrere Möglichkeiten, die beste ist jedoch über die Datei /etc/network/interfaces


    Danke für die ausführliche Info. Ich hatte es allerdings schon sehr intensiv probiert. Auch mit abgeschaltetem Power-Management hatte ich das Problem. Das war leider nicht die Ursache.

    Edited once, last by JSO ().