WLAN Reconnect nach Verbindungsabbruch ?

  • Hallo,
    leider stürzt mein Router gerne mal ab, dann muss ich das Netzteil ziehen und die WLAN Verbindung zum Raspi geht flöten. Leider baut er dann ohne neustart keine Verbindung mehr auf.
    Gibt es da eine andere Lösung als neustart / ethernet einstecken ?


    Danke :dodgy:

  • Hallo Swopi,


    du könntest per Cronjob zum Beispiel alle 5 Minuten einen Ping an deinen Router schicken. Bekommst du eine Antwort ist alles in Ordnung. Antwortet der Router nicht, kannst du das WLAN-Interface mit ifdown herunterfahren und mit ifup wieder aktivieren. Dadurch sollte auch die WLAN-Verbindung wieder aufgebaut werden.


    Was mich jetzt aber wundert, warum die WLAN-Verbindung nicht automatisch wieder aufgebaut wird sobald der Access Point wieder verfügbar ist.


    Gruß Georg

    • Official Post

    ich geh auch den umweg über ifdown/ifup. meiner Repeater zickt auch gern mal rum, nach Verbindungsabbruch hab ich ne 50% chance das der pi nicht automatisch reconnected. Seltsam, aber ich kann damit leben.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

    Edited once, last by dbv ().

  • Sorry aber das kann doch nicht sein, dass man das WLan Interface neu starten muss, wenn der Sender mal kurz weg ist ....


    Da muss es doch noch was anderes geben.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT


  • ....


    Da muss es doch noch was anderes geben.


    Auf dieser Seite habe ich folgenden Lösungsansatz gefunden:


    Well, there is a very simple solution:

    • Go to /etc/ifplugd/action.d/ and rename the ifupdown file to ifupdown.original
    • Then do: cp /etc/wpa_supplicant/ifupdown.sh ./ifupdown
    • Finally: sudo reboot

    That's all. Test this by turning off/on your AP; you should see that your Raspberry Pi properly reconnects.


    Ich hab das jetzt mal so durchgeführt. Der Rapi ist wieder hoch-gelaufen und via WLAN online. Bin mal gespannt, ob sich der Rapi morgen ordnungsgemäß reconnected.

  • wpa-roam macht das für dich.


    Ist etwas gaga, aber so geht es :


    /etc/network/interfces

    Code
    auto wlan0
       iface wlan0 inet manual      # Wichtig, hier manual
            wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
            iface Wifi inet dhcp    # Hier dhcp oder static IP
                                    # Wenn Static kommt hier die Address Config


    /etc/wpa_supplicant/wpa_supplicant.conf


    in die /etc/rc.local vor Exit 0

    Code
    ifup wlan0

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • Hallo,


    ich habe auch beobachten können, das mein RPI nach ein paar Tagen nicht mehr erreichbar ist.
    Ich werde die Tipps hier mal aufnehmen und auch meinen RPI in der vorgeschlagenen Weise (wpa-roam) pimpen.
    Gibt es ein Log, aus dem ggf. mehr Infos auszulesen sind?


    Danke,


  • Nachtrag:


    Habe soeben den AP wieder in Betrieb genommen und konnte den Rapi sofort wieder erreichen. Toll!


  • genau so habe ich das eingetragen und nach einem Reboot war WLAN nicht verfügbar. Ich habe dann Strom aus, WLAN raus, LAN rein, Strom an und bin wiede rmir LAN auf dem PI
    :-/


  • Ist wohl so wie

    Code
    sudo su
    cd /etc/ifplugd/action.d
    mv ifupdown ifupdown~
    ln -s ../../wpa_supplicant/ifupdown.sh ifupdown


    von
    WLAN: automatisches reconnect


    Funktioniert!
    :danke_ATDE:

  • Hallo liebe Raspberry-Fans,
    ich krame den Thread mal hervor, da mein Raspberry bzw. der WLan-Stick mich bald in den Wahnsinn treibt! Sicher, zu dem Thema gibt es im Inet zig Beiträge, aber leider habe ich bisher keinen zum laufen bekommen. :helpnew:


    So schaut's aus:
    - installiertes System: Raspian auf dem aktuellen Stand
    - Stick: EDIMAX EW-7811UN Wireless USB Adapter
    - WLan funktioniert bis die Verbindung getrennt wird (z.B. Neustart vom Router) und ist nur durch Neustart vom RPi oder ein- und ausstecken des Sticks wiederherzustellen


    Zur Einrichtung der Verbindung habe ich diese Anleitung genutzt, sodass meine Netzwerkkonfiguration wie folgt ausschaut:


    Für den automatischen Reconnect probiert:

    • Diese Anleitung (über ifupdown)
      Ausgabe von 'ps aux | grep ifplugd':

      Code
      root@rpi:/home/pi# ps aux | grep ifplugd
      root      1748  0.0  0.0   1756   496 ?        S    14:36   0:02 /usr/sbin/ifplugd -i eth0 -q -f -u0 -d10 -w -I
      root      1760  0.0  0.1   1756   528 ?        S    14:36   0:03 /usr/sbin/ifplugd -i wlan0 -q -f -u0 -d10 -w -I
      root      1785  0.0  0.1   1756   508 ?        S    14:36   0:00 /usr/sbin/ifplugd -i lo -q -f -u0 -d10 -w -I
      root      2808  0.0  0.1   3556   820 pts/0    S+   15:43   0:00 grep ifplugd


      => anschließend die Datei ifupdown ersetzt, Neustart vom Pi, Neustart vom Router ... kein Reconnect.


    • Diese Anleitung (über die /etc/rc.local)
      => nach einem Reboot vom Pi garkeine Verbindung mehr via WLan.


    • Ein abgewandeltes Script von hier + Eintrag in Crontab (minütliche Ausführung):


      => auch hier bleibt nach Neustart vom Router die Verbindung weg.


    • Ein anderes Script + Eintrag in Crontab (im Grunde das gleiche Prinzip wie bei 3.):


      => kein automatischer Reconnect.


    Mir gehen ein bisschen die Ideen aus. :s


    :danke_ATDE: schon einmal für Vorschläge oder Korrekturen!


    Gruß, RPi-Us3r

  • Versuche mal Deine Netzwerk-Verbindungen mit wicd-curses zu verwalten. Das kann Netzwerk-Verbindungen auf- und abbauen.


  • Hallo,
    niemand eine Idee? :daumendreh2:


    Könnte als Ursache noch der automatische Power Saving Modus in Frage komnen?
    Hast du geprüft, ob dein WiFi-Stick davon betroffen ist?
    Quellen findest du sicher hier im Forum.


    Das war mein Hauptproblem am ersten Tag mit dem Pi und danach ließ such auch das reconnect zuverlässig einrichten.

  • Stick ist vom Power Safing Mode betroffen, aber bereits deaktiviert.


    Den Versuch mit wicd-curses werde ich mal starten. Danke!

    Edited once, last by RPi-Us3r ().