Raspberry Pi 3 als Access Point

  • Ich habe neustens versucht meinen neuen Raspberry Pi 3 als Access Point einzurichten, bin aber auf ein Problem gestoßen:
    beim Versuch mich zu verbinden, kann ich keine IP beziehen.
    Im Terminal werden mir einige Zeilen angezeigt wenn ein Gerät versucht sich zu verbinden.
    Ein paar davon haben mich dazu gebracht hier mal nachzufragen was sie bedeuten, da ich mit Debian bzw. Linux im Allgemeinen nie wirklich etwas zutun hatte.



    Danke im Voraus

    Edited once, last by Brutus ().


  • Ich hatte vor den Pi als AP bzw. Tor Gateway zu benutzen, was aber kein Unterschied ist.
    Nach folgender Anleitung bin ich vorgegangen:
    https://raspberry.tips/raspber…Gateway_ndash_Vorbereiten


    Vielleicht habe ich auch bloß dumme Schreibfehler gemacht, aber da ich alles noch 3 mal durchgegangen bin, denke ich eher nicht
    Automatisch zusammengefügt:[hr]
    Kleines Update:


    Ich habe einen Fehler von mir bemerkt und die nötigen Änderungen gemacht, was nicht viel gebracht hat.


    Die Meldung wenn ich versuche mich zu verbinden sieht nun so aus:


    Edited once, last by Brutus ().

  • Code
    wlan0: STA 8c:3a:e3:18:42:6f WPA: received EAPOL-Key msg 2/4 in invalid state (10) - dropped


    Versuch mal die Einstellungen betr. WPA (d. h. WPA1 bzw. WPA2) und eapol_version, auf dem AP und an der STA zu variieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Versuch mal die Einstellungen betr. WPA (d. h. WPA1 bzw. WPA2) und eapol_version, auf dem AP und an der STA zu variieren.


    Danke für deinen Input, ich weiß leider nicht was ein STA ist bzw. weiß nicht wie man an die Einstellungen davon kommt.
    Ich ging davon aus, dass ich die eapol_version in meiner hostapd.conf verändern solltte, worauf ich bemerkt habe, dass ich diese gar nicht angegeben habe.
    Daraufhin habe ich zwischen eapol_version=1 und eapol_version=2 variiert genauso mit wpa=1 bzw. wpa=2.
    Hat zwar etwas verändert, aber nicht geholfen.


    Meine hostapd.conf:


    Wenn ich die hostapd.conf mit "hostapd /etc/hostapd/hostapd.conf" starte, kommt übrigens das:

    Code
    Configuration file: /etc/hostapd/hostapd.conf
    Failed to create interface mon.wlan0: -95 (Operation not supported)
    wlan0: Could not connect to kernel driver
    Using interface wlan0 with hwaddr b8:27:eb:13:a0:38 and ssid "Test"
    wlan0: interface state UNINITIALIZED->ENABLED
    wlan0: AP-ENABLED


    Vielleicht hilft das weiter.

    Edited once, last by Brutus ().

  • Code
    wlan0: STA 8c:3a:e3:18:42:6f WPA: received EAPOL-Key msg 2/4 in invalid state (10) - dropped


    ... ich weiß leider nicht was ein STA ist ...


    STA ist dein WLAN-Client. Seine Einstellungen sind in der wpa_supplicant.conf-Datei.


    Den "received EAPOL-Key msg 2/4 in invalid state" kannst Du auf dem AP bzw. auf der STA, evtl. mit:

    Code
    sudo tcpdump -vvveni any ether proto 0x888e


    anzeigen lassen.


    Betr. WPA-Einstellungen für den AP siehe z. B.:


    in: http://w1.fi/cgit/hostap/plain/hostapd/hostapd.conf


    Für den Test, sollten die WPA- bzw. die eapol-Einstellungen auf AP und STA, identisch sein.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Ich habe jetzt die /etc/wpa_supplicant/wpa_supplicant.conf und die /etc/hostapd/hostapd.conf mit ieee80211d=1 und country_code=DE ergänzt (bei wpa_supplicant.conf habe ich das selbe angegeben).
    wpa_supplicant.conf sieht nun so aus:


    wobei ich nicht weiß ob das richtig ist.



    Wenn nun der hostapd /etc/hostapd/hostapd.conf Befehl ausgeführt wird, kommt:

    Code
    Configuration file: /etc/hostapd/hostapd.conf
    Failed to create interface mon.wlan0: -95 (Operation not supported)
    wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
    wlan0: Could not connect to kernel driver
    Using interface wlan0 with hwaddr b8:27:eb:13:a0:38 and ssid "Test"
    wlan0: interface state COUNTRY_UPDATE->ENABLED
    wlan0: AP-ENABLED


    und bei hostapd -dd /etc/hostapd/hostapd.conf kommt:



    Ich verstehe nicht ganz wieso der Befehl nicht weiter ausgeführt wird, aber wenn ich hostapd -dd /etc/hostpad/hostapd.conf neu ausführe kommt:


    er stoppt also nicht mehr.

    Edited once, last by Brutus ().

  • Deine Konfiguration, mit u. a. auch der Meldung

    Code
    wlan0: STA 8c:3a:e3:18:42:6f WPA: received EAPOL-Key msg 2/4 in invalid state (10) - dropped


    war m. E. besser.



    wpa_supplicant.conf sieht nun so aus:


    wobei ich nicht weiß ob das richtig ist.


    Ich denke Du verwechselst die wpa_supplicant.conf mit der hostapd.conf. Siehe im Internet, die Beispiele und Kommentare für diese conf-Dateien.


    http://w1.fi/cgit/hostap/plain…icant/wpa_supplicant.conf

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().


  • "wlan0: STA 8c:3a:e3:18:42:6f WPA: received EAPOL-Key msg 2/4 in invalid state (10) - dropped" kam diesmal bloß nicht, weil ich mein Handy diesmal nicht verbunden habe.


    Ich verwechsle die wpa_supplicant.conf nicht, ich habe dich wahrscheinlich bloß nicht richt verstanden als du meintest die WPA-Einstellungen sollen identisch sein.


    Außerdem denke ich daran das ganze erstmal sein zu lassen, da wie ein User bereits im anderen Thread meinte, die Treiber noch nicht so weit sind.
    fred0815 hat den Thread verlinkt, da ich ein sehr ähnliches Problem habe (Danke dafür)

    Edited once, last by Brutus ().

  • Habe das Problem, dass hostapd zwar dauerhaft läuft und einen AP erzeut, beim Verbinden erhalte ich aber nach langem Versuch eine IP-Adresse zu beziehen einen "IP - Konfigurationsfehler" im Handy angezeigt.


    Weiß jemand außer der WPA1/2/eapol_version - Variation noch einen Tip ?