RaspPi3, OnBoard-WLAN wird nicht erkannt

  • Für Lesefaule: Ich kann das Onboard-WLAN vom RaspPi3 nicht mehr nutzen. Beim ersten Starten hat es noch funktioniert. Hat jemand eine Ahnung, woran das liegen könnte?




    Ich habe mir als Ersatz für meinen RaspPi B+, der als Mediacenter so langsam vor der Datenmenge kapituliert, einen RaspPi3 geholt.


    Ausgepackt, angeschlossen, NOOBS auf die Karte, Karte rein, Strom an, in NOOBS mit dem WLAN verbunden, OSMC installiert, läuft alles, ich kann mit OSMC über Onboard-WLAN ins Internet.


    Fertig eingerichtet, runtergefahren, Umzug an den Beamer.


    Alles wieder angeschlossen, hochgefahren, keine WLAN-Verbindung mehr, das Interface taucht auch in keinem Konfigurationsmenü mehr auf.
    Also zurück an den Bildschirm -> kein WLAN
    Karte formatiert, NOOBS drauf -> kein WLAN
    OSMC über LAN installiert -> kein WLAN
    Karte formatiert, Raspbian drauf -> kein WLAN
    OSMC via Installer aufgespielt -> kein WLAN


    Nach jeder Neuinstallation zunächst update und upgrade, auch das hat nicht geholfen.


    Ich weiß nicht, was ich noch ausprobieren soll


  • Nach jeder Neuinstallation zunächst update und upgrade, auch das hat nicht geholfen.


    D. h., Du hast deinen PI3 immer auch per LAN (eth0) mit deinem Router verbunden? ... sonst hättest Du ja kein update/upgrade machen können.


    Hast Du danach, ohne LAN-Verbindung versucht bzw. ist dein WLAN-Router für die WLAN-Verbindung des PI3 "vorbereitet"?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden


  • D. h., Du hast deinen PI3 immer auch per LAN (eth0) mit deinem Router verbunden? ... sonst hättest Du ja kein update/upgrade machen können.


    Aber sicher, sonst wäre das mit dem update/upgrade nicht so einfach gewesen... (mit nem stick den apt-cache umziehen zu lassen - nein danke)



    Hast Du danach, ohne LAN-Verbindung versucht bzw. ist dein WLAN-Router für die WLAN-Verbindung des PI3 "vorbereitet"?


    "Vorbereitet"?
    MAC-Filterung ist aus, DHCP ist an, IP ist der MAC-Adresse zugeordnet, sollte also klappen




    Das Problem ist eher, dass das Interface einfach nicht in der Konfiguration auftaucht...
    Bei OSMC hatte ich beim ersten Booten unter den Einstellungen die Möglichkeit, WLAN zu konfigurieren, jetzt steht nur noch "Wired Connection" zur Auswahl
    Bei 'nem normalen Rechner würde ich sagen, die WLAN-Karte ist nicht eingebaut, aber ich hatte definitiv schon eine Verbindung...

    Edited once, last by Kojara ().


  • ..., aber ich hatte definitiv schon eine Verbindung...


    Eine WLAN-Verbindung, wenn gleichzeitig eine LAN-Verbindung zum Router bestand?


    Das es funktioniert ist bekannt, denn ich habe einen PI3 (mit jessie), der nur per WLAN mit der FritzBox verbunden ist.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Nein, anfangs hat das WLAN aber noch funktioniert und die Hardware wurde erkannt, GUI und CLI haben Konfiguration angeboten bzw. das Interface gelistet
    Nach dem zweiten Boot hatte sich das dann aber erledigt, keine Konfiguration und kein Interface mehr


    Danach hab ich dann auf LAN umgestellt
    An sich hab ich mir den 3er ja geholt, weil er WLAN mitbringt und keine Extra-Hardware braucht

    Edited once, last by Kojara ().


  • An sich hab ich mir den 3er ja geholt, weil er WLAN mitbringt und keine Extra-Hardware braucht


    Poste mal aus dem Terminal deines PI3, die Ausgaben (evtl. dort wo erforderlich, richtig anonymisiert) von:

    Code
    lsmod
    iwconfig
    ip a
    ps -fC wpa_supplicant
    sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • lsmod


    iwconfig: command not found


    ip: command not found


    ps -fC wpa_supplicant

    Code
    UID        PID  PPID  C STIME TTY          TIME CMD
    root       333     1  0 21:45 ?        00:00:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant


    cat: No such file



    das interpretiere ich mal als "keine Treiber"...


    edit: aktuell läuft das letzte OSMC-Build über den Windows-Installer nach update/upgrade Stand ~19:30 heute abend

    Edited once, last by Kojara ().


  • das interpretiere ich mal als "keine Treiber"...


    Ja.

    Code
    ...
    brcmfmac              177635  0 
    brcmutil                5501  1 brcmfmac
    cfg80211              407580  1 brcmfmac
    ...


    Code
    :~ $ modinfo brcmfmac | grep -i description
    description:    Broadcom 802.11 wireless LAN fullmac driver.


    Hast Du evtl. eine SD-Karte mit raspbian-Jessie (aktuelle Version)?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Negativ.
    Hab im Moment auch nur die eine Mikro-SD für der Pi3 zur Hand
    Ich geh morgen mal einkaufen, dann sehen wir weiter


    edit: hab jetzt jessie laufen, update/upgrade über lan gemacht, immer noch das gleiche problem

    Edited once, last by Kojara ().