GPIO-Outputs lassen sich nicht abschalten

  • Hallo Leute,


    ich habe einen Pi 1-B und würde gern ein Relais via GPIO ansteuern. Das Relais ist dieses hier (Affiliate-Link), wobei das Relais aber an sich scheinbar nicht das Problem darstellt.
    Ich habe mir via Tutorials zeigen lassen, wie man die Pins via Python ansteuert und ein Signal ausgeben lässt oder wieder deaktiviert. Mein Problem ist jedoch, dass die GPIOs bei 0-Einstellung aktiv bleiben.
    Sowohl über Python als auch über WebIOPi schaffe ich es, den Ausgang zu deaktivieren, wenn ich den Pin auf IN statt OUT setze. Das ist aber eigentlich nicht Sinn der Sache, oder? Über WiringPi kann ich nicht einmal mehr den Pin deaktivieren, wenn ich den Pin auf IN stelle, da bleibt das Signal weiterhin aktiv. WebIOPi zeigt mir übrigens an, dass sobald ich den GPIO auf IN setze, ein Signal hinein kommt, was für mich auch etwas verwunderlich ist.


    Angeschlossen ist wie folgt:
    VCC (Relais) -> 5V (Pin 2) des Pi (alternativ mit 3,3 und dem anderen 5V-Anschluss probiert, selbes Ergebnis)
    GND (Relais) -> Ground (Pin 6) des Pi (alternativ anderen Ground-Pin benutzt)
    IN (Relais) -> Pin 11 als GPIO 17 (in WiringPi mit -g Parameter, damit standard-Nr. benutzt wird), aber hier verschiedene GPIOs benutzt, alle mit selbem Ergebnis


    Naja, das Ende vom Lied ist, dass das Relais nicht wieder geöffnet wird (die angeschlossene Lampe leuchtet weiterhin vor sich hin), wenn ich es "regulär" abstellen will. Hat da jemand zufällig eine Idee, woran das liegen kann? Bei weiteren Rückfragen bemühe ich mich natürlich um genaue Auskunft.


    Lieben Dank und beste Grüße.

  • Ich hab auch schon mal überlegt, mir ein Relais zu kaufen, und habe dann gelesen, dass es anschaltet (dass der große Strom fließt), wenn man ihm keinen Strom gibt. Ist das bei dir auch der Fall?

  • Hallo.


    ...das Lied ohne Ende... ist glaube ich schon X x durchgekaut worden.
    Das ist ein 5 V Relais, auch auf der Steuerseite.Der GPIO liefert nur 3,3V
    Und dann:

    Quote


    Steuerstrom pro Relais: ca. 15 - 18 mA


    ...das packt der Pi nicht.Wundert mich, dass du ihn nicht schon gegrillt hast
    also, nen NPN/PNP-Transistor als Treiber dazwischen... den aber bitte richtig beschalten.


    gruß root

  • Danke für die Antwort. Das Lied höre ich übrigens zum ersten Mal, und die Suchfunktionbrachte auch nichts, daher habe ich einen neuen -und auf meine Symptome passenden- Thread eröffnet.
    Also auch wenn ich via 5V-Pin das Relais betreibe ist das egal, weil der GPIO zum Steuern nur 3,3V rausgibt? Ich dachte, das Betreiben mit 5V und das Ansteuern mit GPIO wären 2 verschiedene Angelegenheiten.


    Allerdings frage ich mich dann, wieso unzählige Tutorials und auch die Produktbeschreibungen behaupten, es würde funktionieren, ohne den Pi zu schrotten. Ich nehme an, Deine Antwort darauf würde in etwa lauten "weil das alles Deppen sind" ;)


    Nungut, dann muss ich mir halt etwas anderes einfallen lassen.

  • Hi


    Das Lied höre ich übrigens zum ersten Mal, und die Suchfunktionbrachte auch nichts, daher habe ich einen neuen -und auf meine Symptome passenden- Thread eröffnet.


    ....ist so alt wie die Menschheit... dann google mal nach 3,3V-5V Anpassung



    Also auch wenn ich via 5V-Pin das Relais betreibe ist das egal, weil der GPIO zum Steuern nur 3,3V rausgibt? Ich dachte, das Betreiben mit 5V und das Ansteuern mit GPIO wären 2 verschiedene Angelegenheiten.


    ...sind es ja, dazu eben der Treiber (siehe Anhang).Die Löschdiode ist i.A. auf der Platine vorhanden.



    Allerdings frage ich mich dann, wieso unzählige Tutorials und auch die Produktbeschreibungen behaupten, es würde funktionieren, ohne den Pi zu schrotten. Ich nehme an, Deine Antwort darauf würde in etwa lauten "weil das alles Deppen sind" ;)


    ...Gegenfrage... wenn du sowas nachbaust und es geht nicht obwohl, die es behaupten... wer ist wohl in deinen Augen der Depp ? (geb dir die Antwort selbst)


    Det iss so wie mit den Führerscheinen.


    Wenn du deine Autoführerscheinprüfung auf nem Auto mit Automatikgetriebe machst, darfst kein Auto mit Schaltgetriebe fahren.
    Umgekerht schon, denn du bekommst Automatik und Schaltgetriebe Stunden, und kennst den Unterschied.


    Wenn du deine PC-Führerscheinprüfung auf 5V CPU's machst, darfst keine 3v3V CPU' "fahren".
    Umgekerht schon, denn du bekommst auf 5V und 3,3V CPU's Stunden, und kennst die Unterschiede.
    :D:D:D


    gruß root

  • ...Gegenfrage... wenn du sowas nachbaust und es geht nicht obwohl, die es behaupten... wer ist wohl in deinen Augen der Depp ? (geb dir die Antwort selbst)


    Ich würde mal sagen es ist derjenige, der neue und unerfahrene Foren-User blöd anmacht und unterschwellig beleidigt, weil er der Meinung ist, jeder Anfänger fiele als Meister vom Himmel und wisse sofort, warum ein Tutorial und sogar die Produktbeschreibungen nicht stimmen können und deswegen auch gar nicht erst nachfragen muss. Und ich dachte, dieses Forum wäre dafür da, um als Unwissender und nicht als Experte Fragen zu stellen. Wie man sich doch irren kann...

  • Hallo,


    so ein Relais hab ich auch und bei mir hat es ohne Probleme am Pi2 funktioniert. :)
    Allerdings hab ich das Relais nicht für Stunden am Pi2 betrieben.!...max. 2 Minuten.
    Von daher kann ich nicht beurteilen ob der Pi2 das auf Dauer mitmacht.


    Quote


    Ich würde mal sagen es ist derjenige, der neue und unerfahrene Foren-User blöd anmacht und unterschwellig beleidigt, weil er der Meinung ist, jeder Anfänger fiele als Meister vom Himmel und wisse sofort, warum ein Tutorial und sogar die Produktbeschreibungen nicht stimmen können und deswegen auch gar nicht erst nachfragen muss. Und ich dachte, dieses Forum wäre dafür da, um als Unwissender und nicht als Experte Fragen zu stellen. Wie man sich doch irren kann...


    Ich fühle mich heimisch. Kenne ich aus anderen Foren :D


    Gruß
    Jauy

    Edited once, last by jauy ().

  • Hi,


    ... und die Suchfunktionbrachte auch nichts ...


    dann frage ich mich, wieso ich vier Seiten mit Treffern habe, wenn ich nach Relais allein schon im Betreff suche :s
    Für mich heisst das schlicht und ergreifend, dass Du nicht (sorgfältig) recherchiert hast.



    ... unerfahrene Foren-User blöd anmacht ...


    Dich hat hier imho keiner blöd angemacht und Du hast sogar eine Lösung präsentiert bekommen.
    Wenn Dir die nicht passt, kann niemand was dafür ...
    -> Hier <- findest Du im Übrigen eine Erklärung, warum die Lösung so ausfällt ...


    cu,
    -ds-


  • Ich würde mal sagen es ist derjenige, der neue und unerfahrene Foren-User blöd anmacht und unterschwellig beleidigt, weil er der Meinung ist, jeder Anfänger fiele als Meister vom Himmel und wisse sofort, warum ein Tutorial und sogar die Produktbeschreibungen nicht stimmen können und deswegen auch gar nicht erst nachfragen muss. Und ich dachte, dieses Forum wäre dafür da, um als Unwissender und nicht als Experte Fragen zu stellen. Wie man sich doch irren kann...


    zum 1: ich hab niemanden blöde angemacht, und dich schon gar nicht, sondern versucht das auf ne lockere Art zu erklären.(deswegen die vielen Smileys)
    zum 2: ich hab dir ne Lösung präsentiert
    zum 3: kein Anfänger fällt als Meister vom Himmel, deswegen gibt es dieses Forum, da wird halt auch mal geschäkert.
    zum 4: vlt. ist es besser, in Zukunft bei Antworten den User vorher um sein perönliches psychisches Datasheet zu bitten, damit die Antwort Userfriendly gestaltet werden kann.


    Mannometer, jedes Wort wird (von manchen) auf die Goldwaage gelegt.

    Edited once, last by root ().

  • Hallo,


    Quote


    ...[..]..jedes Wort wird auf die Goldwaage gelegt.


    Gibt es dafür auch ein Tutorial? :D


    Sorry für OFF Topic


    Gruß
    Jauy

  • Hallo, ich finde es fahrlässig, zu empfehlen, den Raspi über einen GPIO-Pin mit Strom zu versorgen. Besonders wenn der Fragesteller offenbar die Verhältnisse nicht übersieht. Ich würde ein Y-Kabel nehmen, dessen einer Mikro-USB-Anschluß den Raspi und dessen anderer Zweig das Relais und eventuelle Ansteuerschaltungen versoegt. Die 0-Verbindungen ("Masse")geschieht dann auch über das Y-Kabel. Den zweiten Mikroanschluß kann man getrost abschneiden und die passenden Anschlüsse anbringen. Im genormten Kabel ist rot = 5V, schwarz = 0V.
    Weiter viel Spaß mit dem Raspi
    nehcil

  • Moin,
    ein Relais nimmt man um grössere Lasten(Strom/Spannung) zu schalten. Oder um eine galvanische Trennung herzustellen.
    Ein Relais hat eine Spule und Kontakte. Uns interessiert nur die Spule.
    Die Spule benötigt eine Spannung damit das Relais anziehen kann. Das wird normalerweise damit erledigt, das ein Bein der Spule an Masse kommt und das andere Bein an, eine geschaltete, positive Spannung.


    Soweit klar??


    Da die Pin's des Raspberry nur wenige Milliampere liefern können, bevor kapputt, empfiehlt es sich eine Transitor zu benutzen. Siehe Beitrag #6.


    Soweit wurde hier, im Forum, alles richtig gemacht. Und die Aussage der Verkäufer, diese Teil kann man am Raspberry Pi nutzen, ist auch nicht falsch!!
    Man kann es ja, nur muss man es richtig ansteuern.


    Und nun werden wir wieder ruhiger und basteln weiter an den Raspberry's


    Nix für ungut...
    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • ich finde es fahrlässig, zu empfehlen, den Raspi über einen GPIO-Pin mit Strom zu versorgen


    Wer macht denn sowas? Dürfte auch nicht gehen, da der Bonddraht am GPIO oder die interne Schutzdiode eher durch sind, als der Pi hochgefahren ist.


    Du hast da wohl etwas falsch verstanden.

  • Hallo Timm, hallo nehcil,



    Wer macht denn sowas? Dürfte auch nicht gehen, da der Bonddraht am GPIO oder die interne Schutzdiode eher durch sind, als der Pi hochgefahren ist.


    Du hast da wohl etwas falsch verstanden.


    Unser User Dreamshader hat hier mal einen beachtenswerten Beitrag zur Stromversorgung des Raspberry Pi geschrieben. Dieser Beitrag wurde zwar am damaligen RPi B getestet - sollte aber, da sich in der Hinsicht wenig geändert hat, auch an allen weiteren Modellen funktionieren.


    Wie bei Allem gilt auch hier, man muss halt wissen was, man tut und sich der Risiken bewusst sein, wenn man beim Basteln etwas falsch macht.



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo,


    ich habe das selbe Modul, das der TE verwendet.
    Das hab ich mir mal genauer angeschaut.


    Auf dem Modul ist ein Transistor verbaut, der die Spule ansteuert.
    Ergo: Der Raspi wird nicht gegrillt :)


    Gruß
    Jauy

  • Hi


    Auf dem Modul ist ein Transistor verbaut, der die Spule ansteuert.
    Ergo: Der Raspi wird nicht gegrillt :)


    ah.. ok.Das sollte der Hersteller aber schreiben.
    Aber... wieso dann der Hinweis "Steuerstrom pro Kanal ~15mA" ?
    Soll wohl der Spulenstrom sein ?, wenn nicht, 15mA Basisstrom in den Transistor pressen ?


    ...na, der schaltet dann aber mit aller Gewalt... :D und braucht seinerseits auch wieder nen Treiber :D


    gruß root

    Edited once, last by root ().

  • Hi jauy.


    Der Hersteller hat es geschrieben. Ich hab den Text aber nicht genau gelesen. :(


    wen das die tatsächliche Schaltung ist, reicht der reine GPIO Ausgang.
    Basis Rv ist drin, und ne Löschdiode.


    Ich würde dann noch den internen Pull-down des GPIO's aktivieren, damit er in LOW Zustand sauber auf GND gezogen wird.
    Dann ist er auf der sicheren Seite.


    gruß root

    Edited once, last by root ().