Accesspoint RTL8188CUS

  • Moin!


    Die letzten Abende habe ich stundenlang gegoogled, ausprobiert, weitergegoogelt etc... leider hat nichts geholfen.
    Folgendes Problem:


    Ich möchte mit meinem RPi einen AccessPoint erstellen, um auf meinen Webserver zuzugreifen. Ich möchte nicht über den AP ins Internet.


    Das Problem liegt in der Einrichtung des APs.
    Ich habe ein WIFI Dongle mit Realtek8188CUS Chipsatz. Dieser funktioniert laut mehreren Foren nicht out of the box sondern man muss den Treiber/die hostapd(?) selbst ändern.


    Ich bin dieser Anleitung gefolgt.


    Ich habe die hostapd direkt von der Realtek Seite runtergeladen und selbst kompiliert.
    Jetzt bin ich soweit, dass ich die hostapd ohne Fehlermeldungen (glaube ich) starten kann, jedoch finde ich den Hotspot mit keinem Gerät.


    Starte ich die hostapd im Debug-Modus kommt folgende Ausgabe:


    Ich habe leider zu wenig Ahnung um daraus schlau zu werden.
    Liegt ein Fehler vor? Habe ich etwas vergessen?
    Ich wäre mehr als dankbar, wenn ihr mir helfen könntet den Hotspot zum laufen zu bringen.


    Edit:
    zur Ergänzung:
    Ich nutze Raspbian Jessie, upgedated
    Kernel: 4.1.19-v7+

    Edited once, last by Bauer1 ().

  • Juhu! Ich finde es mit anderen Geräten! :thumbs1:


    Aber leider kann ich mich nicht verbinden. Das hängt dann wohl irgendwie mit dem DHCP Server zusammen oder?


    Was mich verwirrt ist:


    Wenn ich

    Quote

    iw wlan0 info


    eingebe, kommt:


    Quote

    pi@raspberrypi:~ $ iw wlan0 info


    command failed: No such device (-19)


    Könnte das dafür verantwortlich sein?

    Edited once, last by Bauer1 ().

  • Moin,
    noe, das Programm "iw" ist nicht schuld. Der Befehl geht bei mir auch nicht. Keine Ahnung warum nicht....


    Aber eventuell hilft "iwconfig" weiter.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin!


    Nach zwei Stunden weiterer Recherche, mal gehts mal gehts nicht, funktioniert es jetzt einigermaßen.


    Ich habe diese Anleitung benutzt.


    Erste Frage: ich muss jetzt um den AP zu starten nach jedem Start des RPis wieder "sudo hostapd -dd /etc/hostapd/hostapd.conf"
    eingeben. Und der AP läuft anscheinend auch nur solange, wie ich die Ausgabe in der Kommandozeile nicht mit STRG+C abgebrochen habe.
    Mit "sudo service hostapd restart" kann ich den AP nicht starten.
    Ich habe auch schon
    "sudo update-rc.d hostapd defaults" und
    "sudo update-rc.d hostapd enable" probiert. Leider ohne Erfolg.
    Wie kann ich den Start automatisieren?



    Ich kann ihn jetzt finden und mich auch verbinden.
    Jetzt muss ich allerdings irgendwie noch was konfigurieren, damit ich meinen eigenen Webserver, der auf dem RPi läuft über das Netzwerk erreichen kann.
    Wo muss ich die IP Addressen vergeben oder wie wird das geregelt?
    Hier meine hostapd.conf



    Und wie kann ich mich über Putty/SSH via AP mit dem RPI verbinden? Wie muss ich den RPi konfigurieren?
    Wäre sehr dankbar über Hilfe!

    Edited once, last by Bauer1 ().