Problem mit PiFace 2

  • Hallo zusammen,


    habe das PiFace 2 aufgesteckt und die Treiber wie folgt installiert:


    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install python3-pifacedigital-emulator
    sudo reboot


    Danach liese sich der Emulator auf dem Desktop starten. Weder die Eingänge noch die Ausgänge konnten simuliert werden. Keine Reaktion.


    Danach habe ich ein Pythonprogramm geschrieben:

    Python
    import pifacedigitalio as pf
    from time import sleep
    pf.init()
    while True:
        if pf.digital_read (0):
              pf.digital_write (0, 1)
        else:
              pf.digital_write (0, 0)
        sleep (0.1)


    Danach folgende Fehlermeldung:


    Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 40, in open_fd
    self.fd = posix.open(spi_device, posix.O_RDWR)
    FileNotFoundError: [Errno 2] No such file or directory: '/dev/spidev0.0'


    During handling of the above exception, another exception occurred:


    Traceback (most recent call last):
    File "piface_test.py", line 4, in <module>
    pf.init()
    File "/usr/lib/python3/dist-packages/pifacedigitalio/core.py", line 169, in init
    init_board)
    File "/usr/lib/python3/dist-packages/pifacedigitalio/core.py", line 53, in __init__
    super(PiFaceDigital, self).__init__(hardware_addr, bus, chip_select)
    File "/usr/lib/python3/dist-packages/pifacecommon/mcp23s17.py", line 91, in __init__
    super(MCP23S17, self).__init__(bus, chip_select)
    File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 32, in __init__
    self.open_fd(spi_device)
    File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 44, in open_fd
    % (spi_device, SPI_HELP_LINK)
    pifacecommon.spi.SPIInitError: I can't see /dev/spidev0.0. Have you enabled the SPI module? (http://piface.github.io/piface…tml#enable-the-spi-module)


    Kann mir jemand helfen und sagen, wo der Fehler liegt?



    Vielen Dank und einen schönen Abend.


    whitechristmas

  • Hi, whitechristmas;


    Anscheinend hast Du spi noch nicht aktiviert?


    In der Datei /boot/config.txt solltest Du den Eintrag:


    dtparam=spi=on


    finden. Wenn nicht, entweder in die Datei einfügen oder über die raspi-config / 8 Advanced Options / A6 SPI aktivieren.


    Dann kommt dazu, dass die Dokumentation für das PiFace ziemlich bescheiden ist und man dort sogar noch Beispiele finden kann, die eine nicht mehr gültige syntax haben. Aber erst mal nach SPI schauen;


    Grüße, rasray
    [hr]
    jou, klar, bis Ich meinen Krempel fertig getippt habe, schießt der alt aus der Hüfte dazwischen :D

    Edited once, last by rasray ().

  • Hallo zusammen,


    SPI ist jetzt aktiviert. Die Eingaben werden vom Emulator angenommen, aber bei den Ausgaben tut sich nichts. Die LED`s sind auch aus.


    Vielen Dank für die Hilfe.


    whitechristmas

  • Hallo rasray,


    pifacedigitalio ist bereits installiert und es funktioniert nicht.
    Der Emulator funktioniert ebenfalls nicht bzw. nur die Eingabe werden angezeigt, die Ausgänge werden nicht gesetzt. Keine LED geht an.


    Vielen Dank.


    whitechritsmas
    Automatisch zusammengefügt:[hr]
    Hallo rasray,


    hab das Programm blink.py probiert, funktioniert auch nicht.


    VG


    whitechristmas

  • Mit dem Emulator habe Ich schon ewig nicht mehr gearbeitet, aber wie gesagt: Ich bin schon auf das Problem gestoßen, dass die mein Programm nicht mehr lief, weil die wohl zwischendrin einiges geändert haben.


    Ohne Garantie:


    ...Spätestens jetzt kommt bestimmt der meigrafd mit 'ner Klatsche für die Anfänger...
    -Bin weg!

  • Hallo rasray,


    funktioniert leider auch nicht. from time import sleep hab ich noch ergänzt.


    Ich bin kurz vor dem Verzweifeln.


    Trotzdem Danke und einen schönen Abend.


    whitechristmas
    Automatisch zusammengefügt:[hr]
    Hey,
    ich hab's, das Board hat offensichtlich einen Wackler. wenn ich es etwas hin und her bewege gehen die LED's jetzt an.


    So eine Sch....


    Trotzdem vielen herzlichen Dank.


    whitechristmas

  • ...ups, beim kopieren abgeschnibbelt :blush:


    Letzte Idee für heute:
    in /etc/modprobe.d/raspi-blacklist.conf :


    Da sollte ein "#" vor folgender Zeile stehen:
    #blacklist spi-bcm2708


    ???
    [hr]
    ...Schon wieder zu langsam...
    was konkret heißt jetzt hin und her bewegen? Sicher, dass Du es richtig auf die Kontakte gesteckt hast (Pins des Pi komplett von der schwarzen Kontaktleiste des Piface bedeckt)?
    http://www.electrokit.com/publ…ctimage/52486-17987-4.jpg

    Edited once, last by rasray ().