Automatisches Erstellen eines Backups (Pi sichert sich selbst)

  • Hallo und danke für deine Antwort.

    Der Ordner /Backupfolder/mount/ existiert bereits, den habe ich schon angelegt.

    Unmount habe ich reingetan, danke für den Tipp.

    Ich möchte ja ganz am Anfang bevor ich ein Backup erstelle den Service deaktivieren und nicht starten, er läuft ja bereits.

  • Automatisches Erstellen eines Backups (Pi sichert sich selbst)? Schau mal ob du hier fündig wirst!

  • ...Ich möchte ja ganz am Anfang bevor ich ein Backup erstelle den Service deaktivieren und nicht starten, er läuft ja bereits.


    Da hast Du mich wohl missverstanden. Natürlich musst Du vorher alles soweit stoppen und hinterher wieder starten.

    Quote

    STOP_SERVICES="service freeradius stop; service apache2 stop; service mysql stop; service samba stop; service slapd stop"

    START_SERVICES="service freeradius start; service apache2 start; service mysql start; service samba start; service slapd start"


    Ich meine nur, dass Du die Services, die Du in STOP_SERVICES stoppst in umgekehrter Reihenfolge wieder starten solltest. Z.B. sollte vermutlich mysql vor apache gestartet werden, denn apache benötigt vermutlich eine mysql DB. Ich könnte mir vorstellen, dass auch LDAP vor apache gestartet sein müsste. Ich empfehle einfach die Reihenfolge beim Starten genau umgekehrt zu der Reihenfolge beim Stoppen zu nehmen. ;)

  • Ah okay, da haben wir aneinander vorbeigeredet. :)

    Das hat leider auch nichts gebracht.
    Ich bekomme beim Stoppen immer noch die selbe Fehlermeldung.

    Hiermit hab ichs jetzt geschafft.

    Code
    eval $STOP_SERVICES

    Damit wird alles schön gestoppt und auch wieder gestartet.

  • Warum muss man den Backupfad

    Code
    BACKUP_PFAD="/backup/raspi"


    eigentlich bei dd nicht excluden? Sonst sichert er doch auch mein ganzes NAS mit weil es gemountet ist oder?

    Gruß
    kuemmel


  • Warum muss man den Backupfad

    Code
    BACKUP_PFAD="/backup/raspi"


    eigentlich bei dd nicht excluden? Sonst sichert er doch auch mein ganzes NAS mit weil es gemountet ist oder?

    Weil

    Code
    dd if=/dev/mmcblk0 of=...


    ein Device blockweise kopiert und sich nicht um Filesysteme etc. kümmert, ergo auch keine gemounteten Filesysteme anfasst.

    Wenn du nichts zu sagen hast, sag einfach nichts.

  • Hab mal ne Frage zu dem Script und gestehe offen ich bin grade zu faul alles durch zu lesen :daumendreh2:

    Ich würde das Script auch gerne nutze und mich vorher Erkundigen ob das auch auf nem BTRFS Filesystem läuft?
    Bevor ich mich umsonst damit rumschlage und mich in das Thema einarbeite :D

    Aktuell hab ich nen Ordner auf meiner Synology per NFS/btrfs gemountet und würde halt gerne per rsync die Backups vom
    raspi mit dem Script machen.

    Geht das? Meine Platten in der Nas haben entweder btrfs oder ntfs

  • Ich benutze btrfs nicht und musste mich erst einmal etwas schlau lesen. So wie ich es sehe unterstützt btrfs Hardlinks und damit sollte raspiBackup dort rsync Backups ablegen können.

    Du kannst ja mal kurz zum Test folgende Befehlssequenz auf einem auf der Raspi gemounteten btrfs Filesystem ausführen:

    Code
    touch test.hlinkfile
     cp -l test.hlinkfile test.hlinklink
    links=$(ls -la test.hlinkfile | cut -f 2 -d ' ')
    [[ $links == 2 ]] && echo "Hardlinks supported" || echo "Hardlinks not supported"
  • Code
    .
    .
    root@test-osmc:/# [[ $links == 2 ]] && echo "Hardlinks supported" || echo "Hardlinks not supported"
    Hardlinks supported
    root@test-osmc:/#

    Sieht mich soweit ganz gut aus ...
    Dann werd ich mich wohl mit dem raspibackup beschäftigen in der Hoffnung das ich da durchblicke ;)
    Und es zum laufen bekomme..... das ganze Thema PI ist leider total Neu für mich.

    Besten Dank für deine Hilfe.

  • Quote from "MadM4x" pid='292312' dateline='1500926110'


    Dann werd ich mich wohl mit dem raspibackup beschäftigen in der Hoffnung das ich da durchblicke ;)

    Das sollte mit Quickstart eigentlich schnell gehen.

    Quote

    ... das ganze Thema PI ist leider total Neu für mich.

    Bzgl raspiBackup ist das weniger ein Pi Thema als ein Linux Thema :) Aber da gibt es hier im Forum genügend Leute die Dir helfen können und werden ...

  • Quote from "framp" pid='292314' dateline='1500926790'


    Das sollte mit Quickstart eigentlich schnell gehen.

    Werde ich mir mal in Ruhe anschauen.
    Irgendwie klappts ja immer ;)

    Quote from "framp" pid='292314' dateline='1500926790'


    Bzgl raspiBackup ist das weniger ein Pi Thema als ein Linux Thema :) Aber da gibt es hier im Forum genügend Leute die Dir helfen können und werden ...

    Naja ich werde das Gefühl eh nicht los, das sich so gut wie alles um Linux dreht was mit dem PI zu tun hat.
    Daher schiebe ich das gleich alles in eine Schublade und jeder fängt ja bekanntlich irgendwann mal klein an ;)

    Sollten sich noch Fragen oder Probleme ergeben auf die ich keine Antwort finde melde ich mich schon ;)

  • Hallo Forum,

    ich habe mir ein Backup nach der hier beschriebenen Anleitung eingerichtet.
    Der Pfad zum Backup ist auf einem dauerhaft eingehängtem USB-Stick (/media/USB-Stick/Backup).
    Nun Mounte ich aber das Verzeichnis zu meinem NAS.
    Beim Backup passiert es immer wieder dass das Image zwar aufs NAS geschrieben wird, es aber zusätzlich noch auf dem USB-Stick verbleibt (was mir immer das Dateisystem voll schreibt).
    Kann ich das irgendwie ändern, oder ist die Idee prinzipiell nicht so gut auf den USB-Stick noch ein Verzeichnis zu mounten ?

    Danke für Euere Hilfe

  • So ganz verstehe ich dein Problem nicht :s

    Quote from "Raser" pid='294935' dateline='1502429283'

    ...Der Pfad zum Backup ist auf einem dauerhaft eingehängtem USB-Stick (/media/USB-Stick/Backup).


    Welches Backup? Ich denke Du sicherst auf die Nas?

    Quote

    ...Nun Mounte ich aber das Verzeichnis zu meinem NAS...


    Die Nas mountest Du auf /backup ?

    Quote

    Beim Backup passiert es immer wieder dass das Image zwar aufs NAS geschrieben wird, es aber zusätzlich noch auf dem USB-Stick verbleibt (was mir immer das Dateisystem voll schreibt).


    Das verstehe ich nicht. raspiBackup erstellt nur ein Image - nicht zwei. Mir scheint Du hast da irgendwie merkwuerdig gemounted. Zeig doch mal die Ausgabe von

    Code
    mount
  • ich glaube ich habe den Fehler gefunden. Hab gerade gesehen, dass zwei Backupjobs in der Crontag stehen *rolleyes
    Mal sehen, ob es morgen Nacht richtig läuft...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!