Problem: Programm mit systemd starten

  • Ich versuche die T.38-Unterstützung per systemd-service zu starten.


    Bislang erfolgte dies über ein init-Skript und zwar durch "exec t38modem ....".


    Das funktioniert jetzt mit der .service-Unit leider nicht wie gewünscht.


    Starte ich dieses Programm von der Kommandozeile, dann erhalte ich einige Ausgaben und das Programm läuft ewig weiter. Ich sehe also kein neues Kommandozeilen-Prompt.
    Ich kann aber durchaus das Programm mit ^C beenden.


    Mit ExecStart=t38modem .... versuche ich nun dieses Programm über systemd zu starten.


    Ein systemctl start t38modem führt nun auch dazu, daß ich kein neues Kommandozeilen-Prompt sehe. Die gescheiht erst ca 2 Minuten später, dann bekomme ich auch eine Fehlermeldung.


    Schaue ich während dieser 2 Minuten mit ps ax nach, dann sehe ich durchaus, daß der Prozess t38modem läuft, später ist er dann weg.
    Ich gehe davon aus, daß t38modem gestartet wird, dann aber wegen der fehlenden Rückmeldung nicht als gestartet eingestuft wird und schliesslich irgendein Time-out greift.


    Was mache ich falsch ?

  • Auch mit Jessie funktionieren weiterhin die sysVinit Scripte. Nur wenn du das explizit deinstallierst funktioniert nur noch systemd.


    Man kann einen Prozess in den Hintergrund schicken indem man ein & ans Ende einfügt. Allerdings wird der Prozess dann trotzdem beendet wenn man das manuell ausführte und dann seine Konsole schließt. Abhilfe schafft dann ein "nohup" ganz am Anfang...


    Wenn du bereits ein init.d Script hast kannst du dies einfach in deine systemd Unit eintragen - wichtig ist für sowohl ExecStart als auch für ExecStop damit dieser auch beendet werden kann.



    PS: google mal nach: t.38 modem systemd

  • Moin,
    mach mich mal schlau, bitte.
    Die T38-Unterstützung ist ein eigenständiges Programm oder gehört es zu einem Packet??


    Rennt es als daemon?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Mach dich selbst schlau indem du danach googlest :D


    t.38 modem => erster Treffer => https://sourceforge.net/projects/t38modem/ => Fax-over-IP ..läuft aber unzuverlässig.. Besser wär Asterisk, siehe dazu auch https://www.plastic-spoon.de/H…zBox--Debian-Squeeze.html (da findet man auch das init.d Script mit der "exec" Zeile und einem & am Ende :fies:)

  • moin,
    das habe ich alles gesehen!! Ich wollte doch nur wissen was genau damit gemacht wird. Was T38 ist weiss ich. Habe nur keine Vorstellung was das Programm so alleine machen soll.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Das Programm "macht" die T.38-Unterstützung und stellt auch "virtuelle" Modems zur Verfügung.


    Das & am Ende habe ich eigentlich drinne - hat nur nichts geändert

  • Moin,
    gehen wir mal davon aus, das deine t38modem.sevice richtig ist. Dann mach mal ein

    Code
    sudo systemctl enable t38modem

    Und einen Reboot, bitte.


    Falls es nicht so ist wie du es dir vorstellst, kann man das ganze wieder mit

    Code
    sudo systemctl disable t38modem

    ausschalten.


    Wichtig ist das der Name nach enable so heisst wie die Datei. Beispiel

    Code
    /lib/systemd/system/t38modem.service


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Bernd beschreibt m.E. den korrekten Weg unter Jessie.
    kleine Ergänzung: man kann mit systemctl einen Service auch einmalig starten, nachdem man ihn als Startup Service definiert hat, dann spart man sich den Reboot:


    Code
    sudo systemctl enable t38modem
    sudo systemctl start t38modem

    Edited once, last by kaiuwe ().


  • Mach dich selbst schlau indem du danach googlest :D


    t.38 modem => erster Treffer => https://sourceforge.net/projects/t38modem/ => Fax-over-IP ..läuft aber unzuverlässig.. Besser wär Asterisk, siehe dazu auch https://www.plastic-spoon.de/H…zBox--Debian-Squeeze.html (da findet man auch das init.d Script mit der "exec" Zeile und einem & am Ende :fies:)


    Ja, mir scheint das t38modem auch nicht sehr uverlässig.
    Die Alternative iaxmodem habe ich aber ÜBERHAUPT nicht zum Laufen gebracht.
    Das mag aber auch daran liegen, daß meine Kenntnisse in Asterisk marginal sind und ich das Ganze hinter einer Frotzbox betreiben muss.


    Zumindest bin ich nicht soweit gekommen, daß es am iaxmodem auch nur geklingelt hätte !