SSH Verbindung auf den pi

  • dann muss aber ein


    rlogin 192.168.3.2 -l pi


    auch funktionieren und sollte keinen "Connection refused" bringen.


    Alternative: gibt es noch einen Benutzer auf dem Pi?
    Wenn nicht, dann leg doch bitte mal einen an und versuche es mit dem ( man page useradd ), also rlogin xxxx -l neuerBenutzer


    cu,

  • Trying 192.168.3.2...
    Connected to 192.168.3.2.
    Escape character is '^]'.
    SSH-2.0-OpenSSH_6.0p1 Debian-4
    Connection closed by foreign host.


    Also ich habe den Prozess nicht abgebrochen und der hat mir in der letzten Zeile "Connection closed by foreign host." angegeben hat das dennoch geklappt?


    nochmal via copy;paste:


    rlogin 192.168.3.2 -l pi
    192.168.3.2: Connection refused

  • Also ich habe den Prozess nicht abgebrochen und der hat mir in der letzten Zeile "Connection closed by foreign host." angegeben hat das dennoch geklappt?



    Tja, das wär jetzt meine nächste Frage gewesen wo das closed her kommt.
    Geht's mit einem neuen Benutzer?


    Und das raspbian ist unmodifiziert und neu aufgesetzt?
    Was spricht rlogin xxx -l root?



    cu,
    -ds-

  • also mit der raspberry ist komplett neu aufgesetzt und der Fehler trat beim neuen Benutzer als auch bei dem root login auf.
    Ob SSHD auf dem läuft kann ich nicht zu 100% sagen (ich bin ja blöd wie ein Fisch was das angeht) allerdings wird mir auf der man page etwas dazu angezeigt, daher geh ich stark davon aus das sshd drauf ist.


  • Ob SSHD auf dem läuft kann ich nicht zu 100% sagen (ich bin ja blöd wie ein Fisch was das angeht) allerdings wird mir auf der man page etwas dazu angezeigt, daher geh ich stark davon aus das sshd drauf ist.


    Ich sprach von deinem MAC oder was für einen Rechner verwendest Du?
    Welche Hardware steht Dir zur Verfügung, Dich per rsh oder rlogin auf dem Pi anzumelden?



    cu,
    -ds-

  • Hallo zusammen,


    also ich wundere mich gerade über einige Vorschläge hier.


    Welches Tastaturlayout auf dem Raspberry Pi ausgewählt ist, betrifft nicht die SSH-Verbindung. Hier kommt das Tastaturlayout des Clients zum Tragen. Es müsste also schon auf dem Mac das falsche Tastaturlayout eingestellt sein.


    Befehle wie rsh und rlogin sollten schon längst ausgestorben sein. Dafür gibt es ja die weitaus sichere Variante SSH.


    Ich kann auch nicht nachvollziehen was es bringen soll wenn jetzt auf dem Mac ein SSH-Daemon installiert werden soll.


    Was mich aber am meisten wundert, dass scheinbar noch keinem aufgefallen ist, dass Menaiseen ständig den Benutzer root verwendet.


    Menaiseen:
    Warum versuchst du dich mit dem Benutzer root am Raspberry Pi anzumelden? Standardmäßig ist dieser Account deaktiviert weil kein Passwort gesetzt ist. Des Weiteren wäre zu prüfen ob der Root-Login über SSH nicht bereits in der /etc/ssh/sshd_config gesperrt wurde.


    Du schreibst auch etwas von einem neuen Benutzer. Wie hast du diesen angelegt und welche Rechte hat dieser?


    Gruß Georg



  • Hall Georg ...


    rlogin und rsh könnten sich anders verhalten?


    Was den MAC betrifft: wenn sich das alles so darstellt, wie er geschrieben hat, kann es ja eigentlich nur an einer Unverträglichkeit des Protokolls liegen, oder? Was ich allerdings andererseits auch nicht so recht glauben mag, weil OSX imho ja auch aus BSD entstanden ist. Deshalb die Idee, es vielleicht mal in die andere Richtung zu probieren.


    Andere Benutzer haben wir ja extra ausprobiert - selbes Fehlverhalten.


    Und über telnet bricht die Verbindung einfach ab.
    Bleibt evtl. noch iptables ... aber das System ist ja neu aufgesetzt.
    Irgendwie gehen mir zumindest langsam die Ideen aus.


    cu,
    -ds-

  • Hallo zusammen,


    Quote from dreamshader

    rlogin und rsh könnten sich anders verhalten?


    1) rlogin/rsh sind nicht ssh.
    2) Die r-Befehle sind aufgrund der unverschlüsselten Datenübertragung nicht mehr zu empfehlen und sollten auch nicht mehr eingesetzt werden.
    3) Es sind unterschiedliche Protokolle und können sich somit sehr wohl unterschiedlich verhalten.


    Quote from dreamshader

    Was den MAC betrifft: wenn sich das alles so darstellt, wie er geschrieben hat, kann es ja eigentlich nur an einer Unverträglichkeit des Protokolls liegen, oder? Was ich allerdings andererseits auch nicht so recht glauben mag, weil OSX imho ja auch aus BSD entstanden ist. Deshalb die Idee, es vielleicht mal in die andere Richtung zu probieren.


    Ich denke nicht, dass es sich hier um ein Problem beim SSH-Protokoll handelt. Es sieht für mich eher nach einem Layer 8 Fehler aus ;)
    Sind wir doch mal ehrlich:
    Es wird immer wieder mit dem Benutzer root versucht eine SSH-Verbindung aufzubauen. Warum wird nicht der Benutzer pi verwendet?
    Die Debugausgaben des SSH-Clients (siehe Post #9) sind auf jeden Fall nicht vollständig. Das sind einfach zu wenig Informationen die der SSH-Client da zurück gibt. Da Menaiseen den Befehl direkt auf dem Raspberry Pi ausgeführt hat, denke ich es waren zu viele Informationen um diese komplett abzutippen und hier zu posten (das ist nur eine Vermutung).
    Es ist ein neuer Benutzer angelegt worden aber es gibt keine Informationen wie der angelegt wurde und welche Rechte der hat.
    Wie sieht es mit der SSHD-Konfiguration aus? Wurde hier eventuell schon was geändert? Zum Beispiel für die Anmeldung mit Schlüsseln.


    Quote from dreamshader

    Und über telnet bricht die Verbindung einfach ab.


    Das wundert mich auch ein wenig.


    Menaiseen:
    Beschreibe bitte den Aufbau deines Netzwerks. Also hast du einen Router welcher den Clients die IP-Adressen über DHCP zuweist oder hast du die IP-Adressen von Hand vergeben? Hängt der Raspberry Pi mit einer festen IP-Adresse vielleicht direkt an deinem Rechner welcher auch eine feste IP-Adresse besitzt?
    Solltest du feste IP-Adressen verwenden, überprüfe bitte mal ob du nicht die gleiche IP-Adresse zweimal in deinem Netzwerk verwendest.


    Quote from dreamshader

    Bleibt evtl. noch iptables ... aber das System ist ja neu aufgesetzt.


    Das kann man ja schnell ausschließen.


    Menaiseen:
    Ruf mal auf deinem Raspberry Pi den folgenden Befehl auf und poste die gesamte Ausgabe.


    Code
    sudo iptables -L -n


    Gruß Georg

  • Moin Menaiseen,


    ich hab' da auch noch zwei Fragen:
    Du schreibst zwar, Du hast die SD-Karte neu beschrieben. Aber ist das ein unverändertes, generisches Image? Oder verwendest Du ein vorkonfiguriertes Image?


    Und dann fiel gerade ein Phänomen ein, das ich auf meinem zweiten Pi beobachtet habe:
    Ich habe auf diesem Pi den watchdog installiert. Dabei hatte ich wohl irgendeinen Unfug in die watchdog.conf eingetragen.
    Das hat dann dazu geführt, dass der watchdog einen reboot ausgelöst hat, sobald ich mich per WLAN eingeloggt habe.


    Was mich direkt zu einem dritten Punkt führt: das leidige Problem mit der Stromversorgung.
    Hast Du mal in den syslog geschaut ob das was auffälliges drin steht?


    cu,
    -ds-


  • ...Was mich aber am meisten wundert, dass scheinbar noch keinem aufgefallen ist, dass Menaiseen ständig den Benutzer root verwendet...


    Ist mir in der Tat nicht aufgefallen :blush: Da haette man sich eine Menge Zeit sparen keonnen.


    Menaiseen:
    Poste doch mal die Ausgabe von

    Code
    grep -v "^#\|^[ ]*$" /etc/ssh/sshd_config

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

    Edited once, last by framp ().

  • So guten Morgen erstmal, also ich denke das Problem könnte schon genannt sein, nämlich das ich den raspberry mit einem LAN-Kabel an meinen Rechner angeschlossen habe.
    Das ganze habe ich nach diesem Tutorial aufgebaut:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    den Rest gehe ich gleich nochmal durch und poste die Ergebnisse.
    [hr]


    Menaiseen:
    Ruf mal auf deinem Raspberry Pi den folgenden Befehl auf und poste die gesamte Ausgabe.


    Code
    sudo iptables -L -n


    Gruß Georg




    Code
    Chain INPUT (policy ACCEPT)
    target        prot opt source                 destination
    
    
    Chain FORWARD (policy ACCEPT)
    target        prot opt source                 destination
    
    
    Chain OUTPUT (policy ACCEPT)
    target        prot opt source                 destination


    [hr]

    Menaiseen:
    Warum versuchst du dich mit dem Benutzer root am Raspberry Pi anzumelden? Standardmäßig ist dieser Account deaktiviert weil kein Passwort gesetzt ist. Des Weiteren wäre zu prüfen ob der Root-Login über SSH nicht bereits in der /etc/ssh/sshd_config gesperrt wurde.


    Du schreibst auch etwas von einem neuen Benutzer. Wie hast du diesen angelegt und welche Rechte hat dieser?


    Gruß Georg


    Ich habe mich am Anfang immer mit pi angemeldet (ssh -X pi@IP)
    danach habe ich den Acc aktiviert und es damit versucht- selber Fehler.
    Daher sollte sich das auch erübrigen mit der Config.
    Der neue Benutzer hat soweit gar keine rechte ich hab ihn einfach mit "useradd test" angelegt.
    [hr]


    Poste doch mal die Ausgabe von

    Code
    grep -v "^#\|^[ ]*$" /etc/ssh/sshd_config


    da habe ich das Problem das ich diesen Befehl mit der Tastatureinstellung nicht eingeben kann :/

  • Also wenn ich das jetzt richtig verstehe... angeschlossen an ein Display via HDMI funktioniert dein RPI problemlos... und du hast auch internet zugang.
    Das einzige was nicht funktioniert ist ssh.
    Das erste was man sich anschauen sollte, ist das Verzeichnis /etc/ssh
    Dort sollten folgende Dateien vorhanden sein
    -rw-r--r-- 1 root root 136156 Sep 13 2012 moduli
    -rw-r--r-- 1 root root 1669 Sep 13 2012 ssh_config
    -rw-r--r-- 1 root root 2489 Feb 9 02:34 sshd_config
    -rw------- 1 root root 668 Feb 9 04:40 ssh_host_dsa_key
    -rw-r--r-- 1 root root 606 Feb 9 04:40 ssh_host_dsa_key.pub
    -rw------- 1 root root 227 Mai 25 08:03 ssh_host_ecdsa_key
    -rw-r--r-- 1 root root 178 Mai 25 08:03 ssh_host_ecdsa_key.pub
    -rw------- 1 root root 1679 Mai 25 08:03 ssh_host_rsa_key
    -rw-r--r-- 1 root root 398 Mai 25 08:03 ssh_host_rsa_key.pub


    Ich hatte schon den Fall, das die Keys gefehlt haben... dadurch war es nicht möglich sich am RPi an zu melden.


    Der ssh daemon scheint ja zu laufen... sonst gäbe es ein connection refuse statt einem not authorized.


    Würde erstmal versuchen es über pi auf die reihe zu bekommen bevor ich einen neuen user ohne parameter an lege...
    root lässt sich normal wegen dem fehlenden Passwort nicht anmelden (wie schon geschrieben wurde)... in andern Betriebssystemen wird es extra in der sshd_conf unterbunden, damit brute-force angriffe auf root immer ins leere laufen... nur wichtig wenn man den port 22 in eine feindliche umgebung NATet.


    Kommt darauf an welche Tastatureinstellung du jetzt hast. Mit English ist es fast einfacher als mit Deutsch.
    ausser backslash und pipe vielleicht. Weil sie dort auf den Tastaturen ohne Ziffernblock in der Zeile über dem enter ist.
    Bei den Systemeinstellungen gibt es unter Sprache & Text die Möglichkeit sich die Eingabequelle Tastatur und Zeichenübersicht in der Menüleiste anzeigen zu lassen.
    Ansonsten muss man halt mal ein wenig suchen wo was ist... 105 Tasten bleiben 105 Tasten

    Edited once, last by SierraX ().

  • Ja das hast du richtig verstanden, wie weit ich mit der Funktion bin. In dem Verzeichnis sieht das bei mir auch so aus- leider fällt mir nun nicht mehr wirklich ein woran die ganze Geschichte liegen kann.

  • ändere mal das Passwort vom pi auf irgendetwas einfaches das auf allen tastaturen gleich ist. Also 1234 oder so ... wenn als root darfst du es ändern auf was du willst.
    Versuche es ggf mit anderen Hostkeys (die werden mit einem Programm erstellt, das ssh-keygen heisst, wird aber warscheinlich auch funktionieren, wenn du die dateien ssh_host_???_key* heraus löschst (ecdsa sagt mir nichts weiss nicht ob der wichtig ist)... davor sollte aber ein Backup existieren damit du nicht von vorne anfangen musst... und danach neu startet)... nicht wundern, dein Mac wird beim ersten mal sagen das die known-hosts nicht übereinstimmt... dann muss man die Zeilen auf dem Mac in der Datei ~/.ssh/known-hosts löschen

    Edited once, last by SierraX ().