Jessie: reservierte IP wird vom PI nicht übernommen

  • Hi,
    ich hab' hier ein echt sonderbares Phänomen:
    Ich hab' für alle RPi als auch Laptops usw. eine IP für die jeweilige MAC-Adresse im Router reserviert.
    Bei allen Rechnern funktionierte das bisher immer einwandfrei.
    Seitdem ich auf einem Pi2 aber Jessie installiert habe, funktioniert das bei diesem einen RPi nicht mehr. Der Pi bekommt dynamische Adressen aus dem Pool des Routers ... mit lease-time und allem pipapo - also so, als wäre da gar keine Adresse hinterlegt.
    Die interfaces und die wpa_supplicant.conf sind identisch mit denen auf den anderen PIs (wo alles nach wie vor klappt), den dhcpd habe ich abgeschaltet.


    Also im Moment verstehe ich die Welt nicht mehr :s
    Im Netz ist auch irgendwie nichts Brauchbares zu finden ( da geht's nur um statische IPs ).
    Hat da vielleicht einer von Euch eine Idee?


    cheers,
    -ds-


  • Ich hab' für alle RPi als auch Laptops usw. eine IP für die jeweilige MAC-Adresse im Router reserviert.
    ..., den dhcpd habe ich abgeschaltet.


    Kannst Du in deinem Router, zusätzlich zur reservierten IP (aus dem DHCP-Pool des Routers?) und der MAC-Adresse, auch den (Host)namen des PI eintragen/konfigurieren?


    Hast Du den dhcpd auf dem PI (jessie) abgeschaltet? Aber ein dhcp-Client/-Dienst muss auf dem PI noch aktiv sein?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hi,


    ... auch den (Host)namen des PI eintragen/konfigurieren?


    Nö, leider nicht. ( siehe screenshots - ich hoffe, man kann was erkennen )



    ... Hast Du den dhcpd auf dem PI (jessie) abgeschaltet? Aber ein dhcp-Client/-Dienst muss auf dem PI noch aktiv sein?


    Der isc-dhcp-client ist aktiv ...
    Den daemon ( isc-dhcp-server ) hab' ich deinstalliert.


    cu,
    -ds-

  • MAC Adresse passt ;) ...
    Die ist auf einer anderen Seite der Reservierungen ( wobei: das sind schon Reserfünfungen ... aber egal ) :)


    //EDIT:
    Vielleicht noch die /etc/network/interfaces:


    wobei die auf mehreren Raspis so aussieht und da funktioniert das eben alles wie gehabt ...



    cu,
    -ds-

  • arp cache leeren - sicherheitshalber?

    --
    man ist das System-Anzeigeprogramm für die Handbuchseiten von Linux.

  • Ich denke, das ist eher ein Problem des Routers und weniger ein Problem des Pi. Auch reservierte IPs werden über den dhcp verteilt. Vielleicht hatte er ein Problem damit, dass der Pi mit wheezy die Adresse noch geleased hat und wollte sie daher nicht neu raus geben. Vielleicht mal paar Stunden warten und noch mal probieren.


    Sonst kann ich nur sagen, dass ich mit der standard Firmware von tp-link auch schon sehr seltsame Verhaltensweisen beobachtet habe. Ein Wechsel zu openwrt wirkt eine Wunder



    PS: Have you tried turning it (den router) off and on again?


  • Seitdem ich auf einem Pi2 aber Jessie installiert habe, ...


    Ist das mit jessie eine neue Installation oder hast Du von wheezy auf jessie updatet?


    Ist der hostanme identisch geblieben?


    Wie ist (mit jessie) die Ausgabe von:

    Code
    systemd-analyze blame


    ?


    Angeblich soll systemd, die Zeile "# Required-Start: ..." des LSB-Headers aus den init.d-Scripten nicht (richtig) berücksichtigen.
    BTW: Wenn die Konfiguration(sdateien) bzw. der DHCP-Client identisch sind, sollte der TP-Link-Router doch gar nichts merken/mitbekommen vom Wechsel wheezy zu jessie.


    Evtl. statt networking und die interfaces-Datei, mal mit .service-Dateien für dhcpcd und wpa_supplicant versuchen.


    EDIT:


    Aus dem Log (screenshot) des Routers ist ersichtlich, dass der DHCP-Server des Routers ein NAK (negative Bestätigung) an den PI mit jessie sendet. Will der Client (PI) evtl. die für ihn reservierte IP-Adresse (... mit permanenter lease-time) vom Server leasen, aber der Server erkennt den Client als nicht dafür berechtigt, und deshalb das NAK?


    EDIT 2:


    War für diesen PI (MAC-Adresse) mit wheezy, evtl. schon mal in diesem Router eine andere IP-Adresse reserviert (... als jetzt mit jessie)?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Hallo -ds-


    Hat da vielleicht einer von Euch eine Idee?


    ...das mit der MAC-Adresse ist so ne Sache.
    Ist mir auch schon passiert... man guckt 100 mal hin, und hat sich doch vertippt.
    Kenn deinen Router nicht, aber bei mir läuft das so:
    Pi auf DHCP stellen, booten und suchen lassen.
    Währenddessen die Routerconfig öffnen "Gerät hinzufügen" und suchen lassen. Nach paar Versuchen hat er den Pi gefunden, zeigt die MAC, "Gerät erlauben" und gut is.
    Wenn das funktioniert hat, definier ich im Raspi ne fixe IP und trag sie im Router ein... geht.


    k.A. ob das bei dir was bringt.


    gruß root

    Edited once, last by root ().

  • Hi,


    ... ein Problem des Routers und


    naja, am Router hat sich nichts geändert. Funktioniert ja auch mit allem anderen, was hier eine IP bekommt, anstandslos.



    ... neue Installation oder hast Du von wheezy auf jessie updatet?


    Das war ein neue, frisch geflashte SD ...



    Ist der hostanme identisch geblieben?


    Ja, soweit ich das nocht richtig in Erinnerung habe, schon.


    Code
    systemd-analyze blame




    ... sollte der TP-Link-Router doch gar nichts merken/mitbekommen vom Wechsel wheezy zu jessie.


    eben, so sollte das sein ...



    ... aber der Server erkennt den Client als nicht dafür berechtigt, und deshalb das NAK?


    Da fragst Du mich zuviel ... keine Ahnung, möglich ...


    Ich zieh mir jetzt mal das kürzlich aktualisierte Jessie und probier das mal ...


    Schon sonderbar,
    -ds-

  • Code
    ...
             1.674s networking.service
            ...
              936ms dhcpcd.service


    Es wird auch dhcpcd (siehe die Ausgabe von "systemd-analyze blame") genutzt, und dieser vor networking (interfaces-Datei) gestartet.
    Wie sind die Ausgaben von:

    Code
    systemctl status dhcpcd.service
    sudo netstat -tulpen | grep -i dhcpcd
    ps aux | grep -i [d]hcpcd
    sudo cat /var/log/syslog | grep -i dhc


    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Ups ... :blush:
    Da habe ich wohl irgendwo gepennt ...


    Also: ich hab an keinem meiner Pi einen Monitor dran. Ich mach' alles über ssh und X-Forwarding.
    Ich hatte über synaptic nachgeschaut und wohl nur auf den isc-dhcp geachtet.


    Jetzt wollte ich das Image vom 10.05. mal booten, aber das gibt sowohl auf dem Pi2 als auch auf dem Pi B nur einen panicä ... :(


    Also wieder zurück zum vorigen Jessie.
    Den dhcpd habe ich jetzt definitiv disabled ;)



    systemctl status dhcpcd.service


    Code
    pi@pi2-jessie:~ $ systemctl status dhcpcd.service
    ● dhcpcd.service - dhcpcd on all interfaces
      Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled)
      Active: inactive (dead)
    pi@pi2-jessie:~ $



    sudo netstat -tulpen | grep -i dhcpcd


    Code
    pi@pi2-jessie:~ $ sudo netstat -tulpen | grep -i dhcpcd
    pi@pi2-jessie:~ $



    ps aux | grep -i [d]hcpcd


    Code
    pi@pi2-jessie:~ $ ps aux | grep -i [d]hcpcd
    pi@pi2-jessie:~ $



    sudo cat /var/log/syslog | grep -i dhc


    pi@pi2-jessie:~ $ sudo cat /var/log/syslog | grep -i dhc


    Wie gesagt, der daemon ist jetzt aber bestimmt disabled, trotzdem nimmt er wieder eine Adresse aus seinem Pool ...
    Ich versteh' die Welt nicht mehr ...


    //EDIT: jetzt hab ich nach dem Abschalten des dhcpd den rooter nochmal gebootet. Die erste IP, die danach der Pi2 bekommt ist auch die für ihn reservierte.
    Den RPi habe ich gerade auch mal neu gestartet ... auch jetzt stimmt die IP.
    Ich denke, das war tatsächlich mein Fehler, weil ich da nicht genauer drauf geachtet habe, ob und was da nun abgeschaltet ist.
    Ist aber auch peinlich :blush:


    Aber was solls ... ich hoffe, das bleibt jetzt so ...


    //EDIT2:
    Also es scheint jetzt zu klappen ...
    Blöder Fehler ... ich mach mal hier zu. Danke jedenfalls für Eure Tipps - wer weiss wie lange ich da noch gebraucht hätte auf den dhcpd zu kommen ...



    cu,
    -ds-