MCP durchgebrannt

  • Hey,


    mein Aufbau war folgender:
    5V/GND von Raspi an Relaisboard
    die 4 IN-Pins über 10k Widerstand an die MCP.


    Jetzt hab ich einen DC-Adapter. Der Minuspol des DC-Adapter ist immer an jeweils eines der Relaisöffnung geschlossen (so dass jedes Relais an den Minuspol angeschlossen ist). Nun ist der Polpol des DC-Adapters jeweils an einen L298-Modul angeschlossen und das wiederrum ist an den anderen Port des Relais angeschlossen.


    Kurz-gesagt: MCP steuer Relaisboard. Relaisboard hat einen eigenen Stromkreis mit L298-Modul.


    Aus welchen Gründen auch immer ist der Motor vom L298 nie angesprungen, also habe ich die mein DC-Adapter höher gestellt (von 3,5V stufenweise auf 12V)
    Irgendwann ist meine MCP durchgebrannt. Relaisboard funktioniert noch, L298 funktioniert noch und Motor funktioniert auch noch..
    Wie kann das sein? Der Stromkreis hat doch gar nichts mit der MCP zu tun. Die MCP schaltet doch nur..


    Im Übrigen hat sich herausgestellt, dass der Motor nicht lief, weil der DC-Adapter zu wenig Strom liefert.. hab jetzt den direkten Anschluss (L298/DC-Adapter und Raspberry(ohne MCP)) mit einem stärkeren Adapter getestet und es funktioniert.. Ein rätsel bleibt mir, warum meine MCP durchgebrannt ist.. Kann das einer vielleicht lösen?


    Ich werd den Aufbau jetzt nochmal mit einer neuen MCP testen.. vielleicht bin ich mit den Adapter-Pins irgendwie an die MCP gekommen oder so..

  • Hallo Madman,


    in Deiner Beschreibung vermisse ich die Freilaufdiode zur Absicherung gegen zu hohe Induktionsspannungen...


    Hast Du eine solche berücksichtigt?
    ( :s Oder ist die im L298 eingebaut?)


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Fehlalarm.. alles zurück..


    Es hat sich exakt in dem Moment als ich den DC-Adapter erneut eingestekt habe anscheinend ein Kabel gelöst. Also ist das Relaisboard kurz aufgeleuchtet, dann ist anscheinend ein Kabel locker geworden und alles ist abgeschmiert. Sah so als, als wär irgendwas durchgebrannt.. und da man das MCP durch i2cdetect nicht mehr gefunden hat, dachte ich, ich müsste es beerdigen :D



    Dennoch danke!


    Und ja, die Dioden sind im L298-Board..