MediaPlayer unter Mate Raspberry 3 ruckelt/kein Bild

  • Moin in die Runde!


    Ich habe für einen bestimmten Zweck einen Raspberry 3 angeschafft und möchte Ubuntu Mate darauf verwenden, da ich einen normalen Desktop benötige.
    Nun brechen wir uns zu zweit einen ab, auf dem Teil zusätzlich HD MKVs mit einem ordentlichen Player zum laufen zu bringen.
    Da mein Kollege keine Ahnung von Linux hat, soll der Player über eine GUI verfügen.

    Per OMX Player gestartet aus der Shell läuft es astrein, leider ohne GUI.


    Wir hatten zuerst Mate in einer der 15er Versionen, inzwischen haben wir auf 16.04 neu installiert.


    Ich bin mit den ganzen Distros nicht so vertraut.
    Könnt ihr mir einen Player oder Weg nennen, mit dem wir HD via GUI zum laufen bekommen?


    Vielen Dank!
    Gruß Workx

  • Eine der Mediadistros? OSMC, OpenELec? Dann aber kein Desktop (bzw nur mit etwas Bastelei)

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

    Edited once, last by dbv ().

  • Zu mplayer und OpenMAX-Beschleunigung findet man wenig.


    Alternativen:


    - VLC gibt's wohl, und hat ne GUI
    - eine Verknuepfung mit OMXPlayer, dann muss man ja nur auf eine MKV-Datei druecken, nix Kommandozeile.

  • Hallo dbv und deets,


    Das es mit einer Mediadistro läuft, ist klar. Allerdings benötige ich einen Desktop (es müsste also nicht Ubuntu Mate sein).


    Eine verlinkung auf einen Shellaufruf zu erstellen, ist keine Option, da die Dateien variable sein müssen.



    VLC haben wir mit allen Einstellungen getestet, wenn überhaupt ein Bild, dann mit geruckel ohne ende. Den Testclip haben wir dazu schon extra auf die SD Kopiert, der Durchsatz stimmt auch.
    Bekommt ihr denn 1080p auf Mate mit VLC zum laufen?


    Gruß
    Workx

    Edited once, last by Workx ().

  • Bei VLC ist die Frage, ob du die optimierte Version installiert hast. Es kann gut sein, dass man die extra installieren muss - einfach aus dem Repo mag da nicht reichen.


    Hier ist eine Anleitung:


    https://www.oblivion-software.de/index.php?id=56&type=98


    Die spricht klar von speziellen Argumenten beim bauen: "--enable-rpi-omxil ".


    Du kannst mal schauen, ob du build-logs fuer Ubuntu Mate findest fuer den PI, und ob dort diese Option gesetzt ist. Ich denke mal eher nicht.

  • Hallo Deets und WaldiBVB!


    Ach was, ok, ich werde das mal testen. Ich meine (ich kanns nicht beschwören) der VLC war von haus auf anbei, da geht man von einer vorhandenen Optimierung aus.
    Ich setze noch einmal neu auf und checke dann ob der VLC schon anbei war. Dazu schaue ich mir dann mal deine Anleitung an.


    Besten Dank!
    Gruß und schönes WE
    Workx

  • Der ist nicht optimiert von Haus aus, leider. Der Weg in dem Link wird der korrekte sein. Stehe vor gleicher Problematik, aber hab das erstmal geschoben ;)

  • Hallo noch einmal!


    Soooo... ,nun ein kurzes Feedback:


    Ich habe die Kiste neu installiert, diesmal als Basis das Raspbian (Debian), um auch mal was anderes zu probieren und weil sich die Anleitung darauf bezieht.
    Dei Anleitung aus deets Beitrag stimmt und ich habe alles wie beschrieben durcharbeiten können.
    Erste tests mit Aufruf der beschriebenen Erweiterung (vlc --vout omxil_vout) verlief top!
    Ich habe dann versucht diesen Aufruf so zu gestalten, dass er auch bei einem Doppelklick auf ein Videofile angewendet wird. Leider habe ich das nicht voreinander bekommen. Man musste immer erst den VLC aus dem Programmmenü starten und dann darüber die Datei aufrufen. Nun setze ich mich heute hin und möchte einen weiteren Test machen, was passiert da, nur Müll. Der VLC scheint die Erweiterung nicht nur vergessen zu haben, er zeigt auch wieder kein Bild beim Aufruf mit der Erweiterung :s


    Ich muss da noch einmal ein wenig fummeln, stabil ist allerdings was anderes...


    Hat jemand von euch schon einmal dieses Verhalten beobachten können und evtl. sogar eine Lösung für das dauerhafte Wirken der Parameter (also auch bei Doppelklick auf ein Video)?

    VG
    Workx

  • Siehe dazu auch den Spoiler am Ende folgenden Beitrags: FAQ => Nützliche Links / Linksammlung => VLC mit hardware acceleration kompilieren


    Desweiteren mal das durchgehen: FAQ => Wieso ruckelt das Video oder der Film/Stream?


  • Siehe dazu auch den Spoiler am Ende folgenden Beitrags: FAQ => Nützliche Links / Linksammlung => VLC mit hardware acceleration kompilieren


    Desweiteren mal das durchgehen: FAQ => Wieso ruckelt das Video oder der Film/Stream?


    Moin meigrafd!


    Die Version von der wir hier sprechen ist neu kompiliert, siehe Anleitung gepostet von deets.


    Edit:
    Ich habe den VLC Player noch einmal nach Codec und Einstellungen durchsucht. Die Hardwarebeschleunigte Dekodierung unter "Eingang/Codecs" ist leer und ich kann auch nichts auswählen...
    Ich kann nicht beschwören das es direkt nach dem kompilieren aktiv war, aber zu dem Zeitpunkt konnte ich 1080p flüssig abspielen, jetzt habe ich wieder schwarzes Bild (wie mit dem Standard VLC).
    Kann es sein das ein Update/Upgrade den Player überklatscht hat? Wie verhält sich APT auf selbst kompilierte Progs im normalen Update-Vorgang?
    Ich werde den Vorgang wohl noch einmal machen müssen =(


    Gruß Workx

    Edited once, last by Workx ().

  • Hey Meigrafd!


    Ok, das ist doch mal eine Ansage. Hat ein wenig gedauert bis ich die Anleitung im Spoiler gefunden habe, nun setzeich noch einmal ganz frisch ohne Noobs auf, damit ich keine Probleme von anderen Baustellen bekomme.
    Was mir aufgefallen ist, deinstalliere ich VLC (purge), bleibt es immer noch auf der Oberfläche verankert und sogar lauffähig.
    Es handelt sich also um zwei Versionen.
    APT sagt, alles runter, gebe ich allerdings '#vlc' in die Shell ein, startet VLC


    Wie kann ich denn wohl sauber die in der Distro hinterlegte version deinstallieren?
    :s


    Gruß Workx

    Edited once, last by Workx ().

  • Na, das wuerde doch dein Problem erklaeren: du hast eine selbstgebaute Version, und eine installierte - letztere wurde dann bevorzugt. In einer Shell mal "which vlc" eingeben, um zu sehen, woher das kommt.


  • Poste mal bitte die komplette Ausgabe wenn du den purge Befehl ausführst - ich vermute das in der Ausgabe ein Hinweis steht dass du noch einen apt Befehl ausführen sollst, und erst danach wäre es wirklich weg.
    am besten via PuTTY copy&paste


    Und um zu prüfen welche Pakete installiert sind:

    Code
    dpkg -l | grep vlc
  • Hi meigrafd, hi deets!


    Erst einmal => Es läuft nun mit 1080p auf dem Pi3 rund!


    Ich kann dir (meigrafd) leider keine weiteren Infos mehr zu der Installproblematik schicken, da ich das Debian kurzerhand wieder neu aufgesetzt habe (das kam mir zu Spanisch vor :daumendreh2: ).
    Neuinstalliert habe ich übrigens bei jedem neuen Versuch. Es können also nicht alle Probleme auf den doppelten Player zurück geführt werden...
    Ich habe also Debian von der offiziellen Quelle in Version "2016-05-27-raspbian-jessie" verwendet und nach der offiziellen Anleitung mit Win32DiskImager auf den USB Stick gespielt.
    Nach Neuinstall ist kein VLC installiert und ich habe diesen neu kompiliert nach Anleitung von meigrafd zum kompilieren des VLC mit Hardwareunterstützung aus diesem Beitrag (klick mich):





    Das Ergebnis: Ich kann endlich bei meinem 1080p Testvideo "Micayala" von divx.com ein laufendes Bild sehen.
    Bei dem Video zeigte sich bei schnellen Stellen (z.B. ab 0:28), dass irgendwas nicht hinterher kommt, Blockbildung, kurze Hängerlein...
    Noch einmal die Einstellung im Audio und Videobereich geprüft. (So wie es bei meigrafd in der Anleitung steht ist es bei mir nicht mehr ganz, der Audiobereich bietet nun mehr Auswahl...)
    Ein Test zeigt, es ist Leistungstechnisch total wumpe was im Audiobereich ausgwählt wird und hilft mir bei der Ruckelproblematik nicht weiter.
    Bei mir steht nun Audio auf "default" und Video auf "OpenMax IL video Output".
    Ich habe also mit den Tipps von meigrafd weiter gemacht, nun die Leistungsoptimierung (overclocking).
    Leider bewirkten die Tipps aus dem Bereich [ALL] nur eine Verschlimmerung und ich habe mir eine andere Anleitung für die "Optimierung" des Pi3 ran gezogen.
    Da ich von Tuning eigentlich überhaupt nichts halte, habe ich mich für "moderate Werte" aus der Anleitung entschieden.
    Mit dem Editor also in der /boot/config.txt am Ende folgende Zeilen eingefügt:

    Code
    [size=10]arm_freq=1300
    core_freq=500
    sdram_freq=500
    over_voltage=2
    [/size]


    Tipp: mit lscpu kann man die eingegebenen Frequenzen überprüfen und mit vcgencmd measure_temp die aktuelle Temparatur abfragen.
    Ich hatte nun eine Temparatur von rund 65°C bei 2Min. Videolaufzeit. Der Pi steckt aktuell in einem Case und hat keine Kühler drauf.
    Wer vor hat sein Heimkino damit zu betreiben, kühlt den Pi besser mit Kühlrippen und/oder aktiv, das tut den Chips und Kondensatoren gut :geek:
    Da sich die Übertaktung wirklich (mit diesen Werten) im Rahmen hält, kann man das wohl gut vertreten.


    Was man noch anmerken sollte, bevor jemand meckert: Der Player zieht sich einen OMX stream und somit ist das Bild in seiner Auflösung wohl fix (ich habe noch nichts anderes finden können).
    Das navigieren ist etwas gewöhnungsbedüftig, funktioniert aber.


    Wer ein OS als reinen Mediaplayer sucht, sollte sich in Richtung Kodi umschauen!


    Ich danke allen für eure Unterstütung und gute Arbeit! :danke_ATDE:


    Gruß Workx

    Edited once, last by Workx ().

  • Laienhafte Frage meinerseits: Braucht man da nicht die Lizenzen von raspberrypi.org, damit das auch ohne Rumgefummel astrein läuft ??

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Nicht zwangsläufig.


    Video Dateien und auch Video Datenströme sind codiert, was unter anderem der Datenkomprimierung dient. Beim Abspielen eines Videos muss der Datenstrom dekodiert werden, was durchaus eine CPU-intensive Sache sein kann - also per Software zu dekodieren. Deshalb wird diese Aufgabe gerne der GPU übertragen, der das in Hardware ausführen kann und so die CPU weniger belastet wird.
    Sofern kein Full-HD dekodiert werden muss, reicht die Leistungsfähigkeit eines RaspberryPi-2 vollkommen aus, um diese Aufgabe softwaregesteuert über die CPU zu erledigen.
    Aussagen wie "ohne MPEG-2 Lizenz bleibt der Bildschirm schwarz" sind aber völliger Unfug... Das liegt wenn dann an gefährlichem Halbwissen, da man Beispielsweise KODI explizit auf Softwaredekodierung umstellen muss da sonst der Bildschirm dunkel bleibt und nur Ton zu hören ist.


    Mithilfe der GPU Lizenzen von raspberrypi.org schaltet man also frei, Video Dateien per Hardware zu dekodieren, wie zum Beispiel MPEG-2.
    H264 und MPEG-4 sind schon ab Werk freigeschaltet, dafür brauch man keine extra Lizenz kaufen.


    Das 1080p Test-Video Micayala Gatto verwendet als Video-Codec MPEG-4, besser bekannt als DivX oder XviD.


    OpenMAX (OMX) ist eine VideoCore API. Es wird also direkt die GPU angesprochen, ähnlich wie bei OpenGL oder OpenVG.
    omxplayer ist wohl der bekannteste für den RaspberryPi, der ebenfalls die API verwendet.



    Du siehst also, es gibt gleich 2 Gründe wieso GPU Lizenzen von raspberrypi.org hier nicht zwangsläufig von Belang sind :fies: