Problem mit GLIB / GTK Update

  • Hallo.
    Ich gebe nun allmählich auf. Versuche nun seit knapp einer Woche die Entwicklungsumgebung auf meinem Raspberry Pi zum laufen zu kriegen, und bin gerade kurz davor den Raspberry ganz dezent irgendwo dagegenzuschmettern - oder ein mal mit dem Auto drüberfahren?
    :s :helpnew: :@


    Auf dem Raspberry läuft Raspbian.
    Ich habe Glade und Ninja IDE installiert - soweit alles ok.
    Leider hat mir Ninja IDE angemeckert dass ich eine neuere GTK+ Version benötige.
    Also eine neue Version von GTK+ runtergeladen, und siehe da - um eine neue Version von GTK+ zu installieren verlangte er von mir neue Versionen von Pango, ATK, sowie Glib. Um diese wiederum installieren zu können habe ich eine neue Version von libffi benötigt.....
    Also eine never-ending-story.


    Nun habe ich alle benötigten Pakete installiert, aber wenn ich nun versuche die neue Version von GTK+ zu installieren bekomme ich nun folgende Meldung:



    Code
    'pkg-config --modversion glib-2.0' returned 2.48, but GLIB (2.42.1) was found! If pkg-config was correct, then it is best to remove the old version of GLib. You may also be able to fix the error by modifying your LD_LIBRARY_PATH environment variable, or by editing /etc/ld.so.conf. Make sure you have run ldconfig if that is required on your system.
    If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    no
    Configure: error:
    GLIB 2.45.8 or better is required.
    ...




    Habe das Problem bereits gegoogled und das scheinen mehrere zu haben - leider hat keine der Lösungen bei mir funktioniert.
    Weiss langsam wirklich nicht mehr weiter und bin kurz vor dem verzweifeln, da ich seit Tagen einfach nur meine Entwicklungsumgebung zum Laufen kriegen möchte.
    Anzumerken wäre wohl, dass mein Raspberry gerade kein Internet hat - sprich ich lade alle Pakete mit dem PC aus dem Netz, kopiere sie auf den Raspberry & führe sie dort aus.


    Vielen Dank an jeden der mir in irgend einer Art und Weise weiterhelfen kann. Ich bin nun wirklich am verzweifeln und weiss absolut nicht mehr weiter. :wallbash:

  • Hallo mhpi,


    abgesehen davon, dass ich von Deiner Entwicklungsumgebung noch nichts gehört habe, vermute ich mal, dass Deine spezielle Vorgehensweise



    Anzumerken wäre wohl, dass mein Raspberry gerade kein Internet hat - sprich ich lade alle Pakete mit dem PC aus dem Netz, kopiere sie auf den Raspberry & führe sie dort aus.


    wohl dazu führt, dass Du einen Mischmasch an Versionen der unterschiedlichen Komponenten hast. Üblicherweise ist es so, dass das, was Du aus dem offiziellen Raspberry Repositorium bekommen kannst, zwar versionsmäßig nicht gerade auf dem aktuellsten Stand ist - aber versionsmäßig so zusammenpasst, dass das Gesamtpaket funktioniert.
    Meiner Meinung solltest Du dort ansetzen, den direkten Internet-Zugang des RPi zum Laufen zu bekommen. Ist kein LAN-Kabel vorhanden - oder kein WLAN-Stick?



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hi Andreas. Erst mal danke für deine Antwort.
    Also das war mir so nicht bewusst. Habe das Internet auf meinem Raspberry Pi nun zum laufen gebracht - ändert jedoch leider auch nichts.
    Beim Versuch GLib über das Terminal zu installieren, bekomme ich die Meldung dass bereits die aktuellste Version von GLib installiert ist.
    Wenn ich nun versuche GTK+ zu installieren, bekomme ich wieder obige Meldung (von meinem ersten Post).


    Zusatzinfo:
    GLib habe ich versucht über folgenden Command zu installieren:
    sudo apt-get install libgtk2.0-dev


    GTK+ habe ich versucht die lokale (heruntergeladene) Version zu installieren, sowie auch mit folgendem Command:
    sudo apt-get install gtk+-2.0


    Was kann ich tun? Ich stecke hier fest und komme einfach nicht weiter, seit nun einer Woche.
    HIIILLFFEEEEEEEE ;(


    edit:
    Habe das Problem jetzt erst mal so gelöst, dass ich den Qt 4 Designer anstatt Glade verwende, nach wie vor mit Ninja IDE. Funktioniert zwar auch, ist aber sehr sehr schade.
    Falls jemand doch noch eine Lösung haben sollte - immer gern her damit!

    Edited once, last by mhpi ().