NAS an RPi anhängen/mounten

  • Hallo zusammen!


    Ich bin ganz neu hier und erlich gesagt auch noch ziemlich "grün" hinter den Ohren was das Thema Linux betrifft!


    Ich beschäftige mich immer und immer wieder mit Linux, und hab auch schon Debian & Ubuntu ausprobiert über längere Zeit. Dann aber wieder mal die Lust verloren und eine Zeit lang nichts mit Linux gemacht.
    Da ich schon länger einen RPi B besitze und diesen bis dato mit OSMC/Kodi nutze konnte bzw hab ich nicht viel probiert.
    Da ich mir für mein Mediacenter aber nun einen RPI 3 zugelegt hab, welches wieder so läuft wie ich das möchte :cool:, steht mir der alte B Rpi nun für Test/Lern & Bastelzwecke zur Verfügung!


    Ich hab auf dem Rpi B mal wieder Raspbian installiert und einmal die Grundkonfig soweit es mir möglich war durchgeführt.
    Sprich Hostname,IP,PW geändert,Raspi-Config durchgeführt, und gleich mal das System auf den letzten Stand aktualisiert!


    Mittlerweile bin ich mit meinen "Linux-Kenntnissen" immerhin schon so weit, dass ich zumindest Programme installieren kann, Dateien & Ordner kopiern,löschen etc kann.
    Was ich noch gar nicht verstehe ist das Thema Berechtigungen in Linux, das ist noch ein großer "Brocken" arbeit für mich.
    Auch google ich viel und lese viel & gerne im Ubuntu Wiki nach gerade was Befehle betrifft da es dort "schön" erklärt ist!


    Jetzt habe ich nach einem im Internet gefundenen Tut einen Torrentclient auf dem Pi B installiert, welcher sogar ohne Probleme funktionieren zu scheint *stolz bin*


    Als nächstes wollte ich lernen, einen Ordner meiner Synology NAS an den PI einbinden bzw. mounten, nur hätte ich da noch ein par fragen an euch.


    Ich weiß das fstab der Autostart ist und das ganze mit dem Befehl mount vollzogen wird!


    Aber nach meiner Recherche in Google nutzt jeder etwas andere Parameter =(


    hier ein par Beispiele:
    mount [Synology NAS IP-Adresse] : [Mount-Pfad des gemeinsamen Ordners] / [Mount-Punkt auf NFS-Client]
    mount -t cifs //192.168.1.2/freigabe /media/freigabe -o user=pi,pass=raspberry
    mount -o username=pi, password=123456 //192.168.X.X/ORDNER /home/EINHÄNGEPUNKT


    Das ich zum mounten einen Einhängepunkt nutze hab ich mittlerweile verstanden, nur manche geben beim Befehl z.b. das Dateisystem an, manche gar keines, manch einer verwendet scheinbar irgendwie auto als Erkennung etc...
    Dan hab ich noch Beispiele gefunden wo Leute uid und gid etc angeben.
    Das alles verwirrt mich derzeit noch sehr.


    Vom Prinzip her möchte ich für den Anfang quasi "nur" einen Ordner meiner Synology NAS mounten in den zukünftig z.b. die TorrentDownloads oder Backups meines Pis landen sollen.
    Auch wäre es mir wichtig zu verstehen warum manche das Dateisystem explizit angeben oder auto verwenden und was es mit uid und gid (es geht hier scheinbar irgendwie um Berechtigungen) auf sich hat!


    LG


    Edit:
    was ich noch anmerken wollte.. auch hab ich mir gerade ein Video2Brain Lernvideo zum Thema Einstieg in Linux gekauft welches ich gerade versuche durch zu "ackern" :lol:
    Sprich die wichtigsten Befehle/Funktionen/Grundlagen Shell etc..

    Edited once, last by xenon2008 ().

  • Also da du anscheinend schon einen guten Weg gehst und versuchst die Sachen zu verstehen, die andere so machen, empfehle ich dir doch erst mal die Manpage zu mount zu lesen:


    Code
    1. man mount


    Wirkt erst mal erschlagend, du brauchst sie auch nicht ganz zu lesen, aber sie gibt dir einen Überblick, was mount kann. Daraus solltest du ableiten, was du für deine Umgebung benötigst bzw. möchtest, z.B. ob du auf deinem NAS einen Samba / CIFS / Windows-Share hast, den du mounten möchtest, oder einen NFS Share, oder noch was anderes...

  • alles was du in der fstab angibst brauchst du nicht beim manuellen mounten angeben.
    was in der fstab wird beim start automatisch gemountet es sei den du gibst bei option noauto an.


    zum testen spar dir die fstab und gib alles beim mount befehl an.
    wenn das klappt kannst das device in die fstab einbinden.


    als beispiel mein fstab eintrag fuer eine win-mount


    //host/freigabe /mnt/host cifs noauto,nounix,noserverino,user=xxx,pass=xxxx,file_mode=0644 0 0


    ixquick.de ist dein freund

    Edited once, last by adora ().

  • Hallo ich bräuchte nochmal eure Hilfe beim einbinden meines NAS Ordners auf dem RPI!


    folgende Situation:
    Am RPI gibt es den Benutzer pi mit der uid=pi und gid=pi
    Danach hab ich unter /media/pi/ einen ordner mit raspberry-an-nas erstellt, für den Mount-Point!


    in der fstab datei habe ich eingetragen:
    //NASIP/FREIGABENAME /media/pi/raspberry-an-nas cifs defaults,noauto,nofail,username=USERANNAS,pass=PASSANNAS,x-systemd.requires=network-online.target 0 0
    Die Leerzeichen habe ich in der FSTAB datei aber jeweils durch ein Tabulatorabstand zeichen ersetzt!


    Mein Problem ist dass es auch nicht klappt wenn ich es manuell mounte! mit ////NASIP/FREIGABENAME /media/pi/raspberry-an-nas -o user=USERANNAS.pass=PASSANNAS
    es kommt zwar kein Fehler beim manuellen mounten jedoch bekomme ich wenn ich auf /media/pi/raspberry-an-nas sprich am Mount Punkt einen Ordner erstellen möchte immer "KEINE BERECHTIGUNG!" - habe auch schon versucht mit gid=pi und uid=pi zu arbeiten klappt aber leider auch ned!


    Könnt ihr mir sagen was ich da falsch mache? :(


    LG
    Automatisch zusammengefügt:[hr]
    ich nochmal...


    jetzt bin ich überfordert
    wollte gerade nochmal manuell mouinten mit :
    "sudo mount //IP/FREIGABE/media/pi/raspberry-an-nas/ -o user=USER,pass=PASS"
    und da erhalte ich jetzt einen Fehler mit no such device...
    Automatisch zusammengefügt:[hr]
    jetzt kann ich den gesmten PI nochmal neu einrichten da er nicht bootet und ich leider kein backup hab...
    seit dem letzten versuch in der fstab geht nix mehr :(


    alles umsnst. deluged alles umsonst eingerichtet nur wegen der dämlichen einbindung des NAS-Ordner *heuL*

    Edited once, last by xenon2008 ().


  • jetzt kann ich den gesmten PI nochmal neu einrichten da er nicht bootet und ich leider kein backup hab...
    seit dem letzten versuch in der fstab geht nix mehr :(


    alles umsnst. deluged alles umsonst eingerichtet nur wegen der dämlichen einbindung des NAS-Ordner *heuL*


    Zwei Dinge: Du hast sicherlich einen Syntaxfehler in der fstab eingebaut und deshalb bootet die Raspi nicht mehr. Du kannst die SD Karte unter Windows (sofern Du einen ext2 Treiber installiert hast) oder direkt unter Linux korrigieren und brauchst nicht mehr neu zu installieren :no_sad:


    Zum Thema Backup empfehle ich raspiBackup ;)

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Torvalds, 28.9.2003

    >>> raspiBackup: Sichere Deine Raspberry regelmäßig im laufenden Betrieb <<<

    Edited once, last by framp ().

  • egal bin schon wieder am neu konfigurieren. schadet eh nicht, bin eh noch so grün hinter meinen Linux-Ohren!


    was mir viel wichtiger wäre wie ich meinen Ordner von der NAS richtig einbinde... siehe oben
    kannst du mir dabei helfen?


    LG


    EDIT:
    In Zukunft werde ich die SD-Karte einfach mit dem Win32DiskImager sichern :D

    Edited once, last by xenon2008 ().


  • EDIT:
    In Zukunft werde ich die SD-Karte einfach mit dem Win32DiskImager sichern :D


    Eine gute Idee :thumbs1: Du musst dann aber immer dran denken, die Raspi runterzufahren und den Backup manuell mit Win32diskImager vorzunehmen. Automatisch geht es einfacher und vor allen Dingen vergisst Du es nicht das regelmäßig zu tun :shy:

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Torvalds, 28.9.2003

    >>> raspiBackup: Sichere Deine Raspberry regelmäßig im laufenden Betrieb <<<

  • das stimmt, genau das möchte ich nämlich!


    aber das sehe ich mir nicht mehr heute um die Zeit an... (konzentration ässt schon nach..)
    noch dazu mach Win32DiskImager ja eine BitfürBit Kopie also sichert mal "eben" 32GB :D


    könnt ihr mir bzgl dem mounten helfen?

  • Hallo zusammen!


    so habe meinen Pi jetzt soweit wieder installiert und läuft auch wieder alles wie es soll!
    Wenn ich zu Hause bin werde ich auf jeden Fall gleich mal ein Backup mit WIn32DiskImager machen!


    Was mir jetzt aber solche Kopfzerbrechen bereitet ist das Mounten meines Freigegebenen Ordners von meiner Synology NAS! Ich möchte nämlich das ganze via SMB realisieren und nicht via NFS!


    Hier noch einmal die Ausgangssitutation:
    Auf der NAS gibt es:
    =>User:"USERAUFNAS"
    =>PW:"PWFÜRDENUSER"
    =>Ordner:"FREIGABEORDNER"


    wie gehe ich jetzt weiter vor, sodass der Ordner automatisch eingebunden wird (stichwort fstab), sodass auch nach dem Rebooten mein PI wieder startet :D


    gedacht hätte ich mich nach längerer Google-Recherche es so:
    Am Pi einen Ordner erstellen in /media/pi/ mit dem Namen "raspberry-an-nas" mit folgendem Befehl:
    "sudo mkdir /media/pi/raspberry-an-nas


    Danach hätte ich als Beispiel folgendes in die fstab-Datei eingetragen:
    "//IP-der-NAS/FREIGABENAME /media/pi/raspberry-an-nas cifs defaults,noauto,nofail,username=USERAUFNAS,passwd=PASSFÜRUSER,x-systemd.automount,x-systemd.requires=network-online.target 0 0"
    (wobei lt. meinem Tutorial dass ich gefunden habe, die Abstände jeweils ein TAB-Schritt ist!)


    Angenommen ich habe das eingetragen und starte meinen PI neu, ob dieser noch bootet bzw. ob das Mounten dann funktioniert?
    Oder mache ich hier grundsätzlich etwas falsch? Wie Wäre dann die richtige Vorgehensweise bzw. Lösung für mein Problem?


    LG