nach Reboot manuelles "sudo service hostapd restart" notwendig

  • Hallo@community,


    ich habe nach der Anleitung http://www.forum-raspberrypi.d…kalem-webserver-betreiben einen AccPoint erstellt. Nach jedem reboot sehe ich auf dem Handy kurz den AccPoint vom RPi3. Jedoch verschwindet der sofort wieder. Ich muss jedes Mal ein
    sudo service hostapd restart / sudo service udhcpd restart eingeben, damit mein AccPoint läuft. Diese Eintragung habe ich bereits gemacht: sudo update-rc.d hostapd enable + sudo update-rc.d udhcpd enable.


    Falls es eine Rolle spielt: der RPi3 startet ohne Login. Ich lande also in der Konsole ohne AutoLogin. Ist auch so gewollt :rolleyes: Oder geht der AccPoint nur, wenn man sich eingeloggt hat? Das wäre ärgerlich :helpnew:


    EDIT:
    mittels "sudo systemctl list-utils -t service" sehe ich, dass bei beiden (hostapd und udhcpd) folgerndes steht: loaded active exited
    Warum sind denn beide beendet? Wieso laufen die nicht mehr?

    Edited once, last by noobee ().

  • Moin,
    es ist hilfreich mal zu posten, wie du die Services startest.


    Und hast du mal in den Logdateien bzw. journalctl befragt??


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.


  • es ist hilfreich mal zu posten, wie du die Services startest.


    Also, mein erster Versuch war in der .xsession der Eintrag "sudo service hostapd restart" - ohne Erfolg.
    Dann in die rc.local der Eintrag "sudo service hostapd restart" geht auch nicht. Bzw. scheint es ja kurz zu gehen, dann wird aber exited...




    Und hast du mal in den Logdateien bzw. journalctl befragt??


    nein, wie kann ich das am Besten tun? Also ich meine so, dass es ein verwertbares Ergebnis gibt :daumendreh2: :daumendreh2:


  • Ich muss jedes Mal ein
    sudo service hostapd restart / sudo service udhcpd restart eingeben, damit mein AccPoint läuft.


    Dieses Verhalten beobachte ich seit ein paar Tagen auch. Es handelt sich um WLAN-Adapter von AVM.


    mittels "sudo systemctl list-utils -t service" sehe ich, dass bei beiden (hostapd und udhcpd) folgerndes steht: loaded active exited
    Warum sind denn beide beendet? Wieso laufen die nicht mehr?


    Ich bin inzwischen soweit, dass ich meine, dass es Probleme mit dem Treiber gibt, oder so. Meine Beobachtung stütz sich darauf, weil die Schnittstelle verzögert in Betrieb geht und dann hostapd beim Starten abbricht.


    Was sagt


    dmesg


    und


    sudo service hostapd status

  • Moin,
    der Eintrag in .xsession kann nicht gehen, weil diese Datei nur greift, wenn sich ein User an der GUI angemeldet hat.


    /etc/rc.local ist schon richtig. Aber ich denke das dein Aufruf falsch ist. Der Aufruf, Achtung, nur ein Beispiel.

    Code
    /usr/bin/hostapd  /etc/hostadp/hostapd.conf &

    sollte so aussehen. Es muss der komplette Pfad zum Programm UND zur conf eingegeben werden.
    Wo das Programm "hostapd" liegt sagt dir

    Code
    which hostapd


    Das "sudo" kannst du weglassen. rc.local wird mit rootrechte ausgeführt.


    Wegen der Logdateien. Ein

    Code
    cat /var/log/syslog | grep hostapd

    sollte schon Ergebnisse bringen.


    Gruss Bernd


    Mir ist noch was eingefallen. Mag sein das das Quatsch ist, aber Versuch macht kluch....


    Das Programm raspi-config hat einen Punkt der nennt sich Warten auf Netzwerk den Schalter mal auf ja setzen.

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • ui, ja. also die Ausgabe von demesg (kannte ich vorher nicht) ist zu lang, um sie zu posten.
    und hostapd status sagt:

    Code
    hostapd.service - LSB: Advanced IEEE 802.11 management daemon
      Loaded: loaded (/etc/init.d/hostapd)
      Active: active (exited) since Mo 2016-08-01 22:37:55 CEST; 1h 10min ago
     Process: 7078 ExecStop=/etc/init.d/hostapd stop (code=exited, status=0/SUCCESS)
     Process: 7084 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
    
    
    Aug 01 22:37:55 Test hostapd[7084]: Starting advanced IEEE 802.11 management: hostapd failed!


    und direkt nach nem redtart von hostapd:

    Code
    hostapd.service - LSB: Advanced IEEE 802.11 management daemon
      Loaded: loaded (/etc/init.d/hostapd)
      Active: active (exited) since Mo 2016-08-01 22:37:55 CEST; 1h 12min ago
     Process: 7078 ExecStop=/etc/init.d/hostapd stop (code=exited, status=0/SUCCESS)
     Process: 7084 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
    
    
    Aug 01 22:37:55 Test hostapd[7084]: Starting advanced IEEE 802.11 management: hostapd failed!

    Edited once, last by noobee ().

  • ah prima. also kann ich in der rc.local folgendes angeben?



    Code
    /sbin/ifconfig ifconfig wlan0 192.168.0.1 &
    /usr/sbin/hostapd  /etc/hostadp/hostapd.conf &
    /usr/sbin/hostapd  /etc/udhcpd.conf &
    ... der Rest, der schon drin stand ...
    exit 0
  • Moin,


    Nein kannst du nicht!!!


    Erstmal musst du probieren ob die Befehle so in der Konsole/Terminalfenster funktionieren.

    Code
    /sbin/ifconfig ifconfig wlan0 192.168.0.1 &

    geht wohl nicht.


    Du hast doch nicht so die Ip-Adresse für deinen AP festgelegt??


    Wird das nicht in der hostapd.conf gemacht?? Wenn nicht, oder es sich um die Standard-Ip handelt, dann solltest du das in der dhcpcd.conf machen.


    Ich dachte es rennt alles bei dir, nur das automatische Starten geht nicht.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • also eigentlich habe ich in der /etc/networks/interfaces eine feste IP für wlan0 vergeben. Die ist aber nach nem reboot nicht mehr vorhanden. Ein ifconfig zeigt, dass es wlan0 nicht gibt. Deshalb hatte ich das händig über sudo ifconfig wlan0 192.168.xxx.1 eingegeben. Ich dachte, das geht auch über rc.local - tut es nun aber nicht.
    Jetzt leuchtet mir aber auch ein, warum u.U. hostapd nicht geht. Sicher deshalb, weil wlan0 keine IP hatte, denn über /etc/networks/interfaces ging es ja nicht.
    Ok, ich stelle also nach jedem reboot die IP neu ein, restarte udhcpd und hostapd und dann gehts. dies gilt es mittels rc.local zu automatisieren.
    udhcpd und hostapd mittels rc.local kann nicht funktionieren, da ich vorher (am liebsten über rc.local) erst die IP von wlan0 festlegen muss :helpnew: :helpnew:

  • Moin,
    bei Raspbian jessie sollte man alle IP'S in /etc/dhcpcd.conf eintragen.
    Beispiel:

    Code
    interface wlan0
    static ip_address=192.168.1.024/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1 8.8.8.8 8.8.4.4
    option noipv6

    Das, mit deinen Daten, solltest du am Ende der Datei eintragen.
    Das solltest du als erstes tun.
    Nach einem Neustart bitte mit

    Code
    ifconfig

    kontrollieren.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Jetzt leuchtet mir aber auch ein, warum u.U. hostapd nicht geht. Sicher deshalb, weil wlan0 keine IP hatte, denn über /etc/networks/interfaces ging es ja nicht.


    Ob hostapd startet oder nicht hat mit der IP-Konfig nichts zu tun.


    hostapd startet immer dann nicht, wenn es ein Problem mit WLAN-Adapter, Chipsatz oder Treiber gibt. Demzufolge wäre es interessant zu wissen, welchen WLAN-Adapter zu hast und auch die Ausgabe von "dmesg".
    Auffällig ist, dass WLAN-Adapter mit Atheros-Chipsatz zur Zeit herumzicken. Da ist nach einem der letzten Firmware-Updates was schief gegangen.


    Außerdem wäre die manuelle Ausführung von hostapd gleich nach dem Boot-Vorgang und ein paar Minuten später von Interesse.

  • boah, verdammt :( ich glaub, jetzt hab ich alles zerschossen. welche ist denn die richtige datei, mit der ich die IP des WLAN0 einstelle?


    Ich hab jetzt in der /etc/udhcpd.conf folgendes stehen:

    Code
    start 192.168.200.20
    end 192.168.200.254
    
    
    opt dns 192.168.200.1
    option subnet 255.255.255.0
    opt router 192.168.200.1


    dann in der /etc/network/interfaces

    Code
    iface lo inet loopback
    iface eth0 inet dhcp
    
    
    allow hotplug wlan0
    iface wlan0 inet static
    address 192.168.200.1
    netmask 255.255.255.0


    und nun soll ich auch noch in der /etc/dhcpcd.conf das hier eintragen?

    Code
    interface wlan0
    static ip_address=192.168.200.1/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.200.1
    option noipv6


    Da bin ich n bissi überfordert. Ich hab ja nun teilweise IPs doppelt drin stehen. So wird Wlan0 nach dem reboot übrigens nicht erkannt. Ich muss also wieder händisch "sudo ifconfig wlan0 192.168.200.1" machen :(

  • Moin,
    mhm, das ist ein büschen zuviel.


    Entweder /etc/network/interfaces ODER /etc/dhcpcd.conf.


    In beiden Dateien was eintragen ist nicht sinnvoll. Es handelt dich hier auch nur um die eigene IP des Raspberry.


    Es muss ja erstmal sichergestellt werden, das der sich immer mit der gleichen IP meldet.


    Falls du nicht mehr weisst was in der interfaces stand


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • mhh, naja. aber die Eintragungen in der "/etc/network/interfaces" brauchte ich ja eigentlich, um den AccPoint erfolgreich zu betreiben. Da kann ich also nix ändern. Und die Eintragungen in der "/etc/dhcpcd.conf" haben nix gebracht. Also es gab zwar keine Probleme, es gab aber eben auch nicht die erhoffte feste IP für Wlan0 :(

    Edited once, last by noobee ().

  • Moin,
    wenn kein dhcp und kein hostapd bei dir gestartet ist, welche IP hat dann der Rpi??
    Du musst das erstmal mit der eigenen IP hinbekommen. Sonst brauchen wir nicht weitermachen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • Mhh, also eth0 = 192.168.2.107. Die bekommt er automatisch zugewiesen. Oder meinst du was anderes?
    Wlan0 geht nix über ifconfig. nur wenn ichs manuell setze

    Edited once, last by noobee ().

  • Moin,
    ausserdem wird in dem Tread von ps195 auch nur geschrieben das du in /etc/network/interfaces deine IP eintragen sollst.


    Es sollte keine anderen Einträge dort stehen.


    Dann gebe ich zu bedenken, das das Beispiel aus dem Jahre 2014 ist. zu diesem Zeitpunkt war von Raspbian jessie noch keine Rede.


    Ich hoffe das du den intregierten Wlanadapter des Rpi3 nutzt??



    Gruss Bernd
    Automatisch zusammengefügt:[hr]
    Moin,
    da haben sich unsere Antworten überschnitten.
    Hast du auch ein Netzwerkkabel dran??


    Aber egal, wenn du den ACC auf Wlan machen willst, musst du eine feste IP auf Wlan haben. Und das hat, wie schon geschrieben, erstmal nicht mit den gewünschten Diensten zutun.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • So, also. Jetzt hab ich erstmal meinen alten Pi3 in der Mitte zerknickt, um n bissi Frust abzulassen -.-


    Also nochmal von vorne. Es ist jetzt nach ne reboot alles soweit schick. Eth0 hat die 192.168.2.107 (mit EthKabel), Wlan0 hat nun auch die gewünschte 192.168.200.1 (ohne Kabel :D )


    zu deinen Fragen


    Ich hoffe das du den intregierten Wlanadapter des Rpi3 nutzt??

    na logo ;)


    Hast du auch ein Netzwerkkabel dran??

    japp


    Aber egal, wenn du den ACC auf Wlan machen willst, musst du eine feste IP auf Wlan haben. Und das hat, wie schon geschrieben, erstmal nicht mit den gewünschten Diensten zutun.

    ok, nun hab ich die auch


    Zwischenstand nun:
    nach dem 4. reboot sind die IPs immer noch vorhanden. Das wäre also soweit schonmal schick. Ich sehe den AccPoint nach dem manuellen "sudo service hostapd restart" auch, es kann aber keine IP bezogen werden. Es scheint, als wären wir zusammen auf dem richtigen Weg :-p

  • Moin,
    das ist schön!!!!


    Dann bleiben wir mal bei dem Beispiel von ps915.

    Code
    sudo nano /etc/default/hostapd

    aufrufen und

    Code
    DAEMON_CONF="/etc/hostapd/hostapd.conf"

    eingeben.
    Danach nochmal ein

    Code
    sudo service hostapd restart

    machen.


    Wenn alles rennt, ist das dran

    Code
    sudo update-rc.d hostapd enable


    Dann wieder ein "sudo reboot"


    Wenn alles geht sehen wir weiter.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • leider geht AccPpint nicht mehr.


    hostapd status sagt:

    Code
    hostapd.service - LSB: Advanced IEEE 802.11 management daemon
     Loaded: loaded (/etc/init.d/hostapd)
     Active: active (exited) since Mo 2016-08-04 02:09:55 CEST; 1min 59sec ago
    Process: 538 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
    
    
    Aug 04 02:09:55 Test hostapd[538]: Starting advanced IEEE 802.11 management: hostapd failed!


    ich sehe dieses mal mein AccPoint auch nicht mehr kurz. Vorher hatte ich den AccPoint nach nem reboot des Pi3 wenigstens noch kurz aufm Handy sehen können

    Edited once, last by noobee ().