Der Neue und sein Pi Zero

  • Hallo zusammen,


    ich bin Endric, der neue. ;)


    ich hatte mir einen Pi0 mit dem PXFmini zugelegt, um etwas zu experimentieren. Da ich bisher noch keine Erfahrungen in Sachen RPI oder generell Linux habe, ist das ziemlich mutig.


    Leider fangen die Probleme schon sehr früh an und meine bisherigen Internetrecherchen konnten mir keinen roten Faden geben, um dieses Problem zu lösen.


    Ich hatte Anfangs Noobs installiert, alle Updates gezogen und installiert. Anschließend steckte ich meinen Wlan Dongle von PiHut an und hinterlegte meine Zugangsdaten für den Router. Danach war eine Terminalverbindung mit über xRDP kein Problem. Nachdem das geklappt hatte, installierte ich die Jessie, welcher in abgewandelter Form von Erle Robotics rausgegeben wurde und damit fingen die Probleme an.
    Über Jessie kann ich keine Wlanverbindung herstellen, weil er scheinbar den Dongle nicht erkennt. Einen Treiber habe ich dafür nicht gefunden, sondern nur den Hinweis das angeblich keiner benötigt wird.
    Ok, also eben schnell einen Pi3 besorgt und versucht von dort aus das System einzurichten.... warum einfach wenn es auch schwer geht?
    Die SD Karte, bzw. die Software wird vom PI3 nicht erkannt. Beim Zero geht es. Testweise habe ich eine andere SD Karte genutzt, Image geladen und wieder wird nichts erkannt. Anschließend habe ich die gleiche SD Karte gelöscht und das Standardimage von Jessie installiert. Aber!!!!!! Mit dem PI3 geht alles, aber der PI0 will die SD Karte nicht mehr.


    Weiß jemand wie ich den Dongle nun installiert bekomme?


    Bitte nicht lachen, aber ich übersehe bestimmt was total einfach dämliches, oder?


    Über Hilfe wäre ich dankbar.

  • Servus Endric,


    das klingt alles ziemlich kompliziert ... :s
    Was soll denn am Ende rauskommen?


    Erfahrungsgemäss sind "vorgefertigte" oder "modifizierte" Images oft ein Auslöser für eine Menge anderer Probleme.
    Ich würde deshalb mal die aktuelle Jessie resp. Jessie Lite ausprobieren ( Achtung! Keine grafische Oberfläche in der Lite ).
    Und dann Schritt für Schritt weitermachen.


    Ausserdem:
    Wie hast Du den RPi mit Strom versorgt?
    Welches Netzteil verwendest Du?
    Wie ist der USB Dongle angeschlossen?


    Und dann sehen wir mal weiter ...
    cu,
    -ds-

  • Hallo,


    erst mal vielen Dank, das Ihr euch für mein Problem interessiert und helfen wollt. :)


    Der PXFmini von Erle Robotics ist in Verbindung mit dem PI0 eine Art Autopilot für eine Drohne. Bzw. ist mit der Software ROS ein gewisser Automatismus möglich. Da ich selbst Quadrocopter baue und fliege, für mich ein sehr interessantes Thema.


    Jessie bekomme ich so ohne Probleme zum laufen, also die offizielle Version. Aber auch hier wird nicht mein WLAN Dongle angesprochen. Komischerweise geht das nur wenn ich Noobs nutze.
    Ich nutze ein Standardnetzteil 5V, 2000mah. Angeschlossen wird der Dongle direkt am USB. Ansonsten hängt bis auf den PXFmini nichts dran. Besitze aber noch ein Netzteil 5V mit 2500mah für den Pi3. Den könnte ich mal testen.
    Habe testweise bereits den Akkubetrieb (3S, 11V, 1500mah) getestet mit einem Stepdown auf 5V. Springt alles an, nur WLAN will nicht. Auch hier läuft es aber mit Noobs.


    Ist ein Dongle von Pi Hut. Was da genau drin ist, kann ich leider nicht sagen.

  • Ok ... welcher der beiden Teile von Pi hut ist es denn?
    Blöderweise haben die keine Informationen über Chipsatz ... drin, aber irgendwie bekommen wir das schon raus.
    Was sagt denn

    Code
    1. sudo lsusb -v


    wenn der Dongle eingesteckt ist?
    Wenn Du den Dongle aus und dann wieder einsteckst ... Was erhälst Du anschliessend bei Eingabe von

    Code
    1. dmesg


    als Ausgabe?


    cu,
    -ds-

  • Jetzt hast du mich echt erwischt. Das kann ich nämlich nicht beantworten. Über meinen aktiven Hub läläuft keine Tastatur, Maus oder anderes. Also kann ich immer nur eines in den PI0 stecken.


    Bringt das was, wenn ich dies heute Abend am PI3 teste oder ist das Schwachsinn wegen dem internen WLAN? Würde dann die SD Karte komplett neu auf Jessie formatieren und komplett von 0 anfangen. Evtl wären dann die Schritte und Meldungen nachvollziehbarer.
    Automatisch zusammengefügt:[hr]
    Ach ja, der Dongle ist es


    https://thepihut.com/collectio…pter-for-the-raspberry-pi

    Edited once, last by Cyrgon ().

  • Servus Cyrgon,
    hast Du vielleicht ein PL2303-Kabel?
    Oder einen USB auf seriell Adapter mit 3V3?
    Dann könntest Du die serielle Konsole aktivieren und über diese auf den Pi ... dann brauchst Du nur eine Tastatur ...


    Auf dem Pi 3 testen ... den Dongle meinst Du?
    Ja, das ginge für den Anfang auch. Sollte ja dieselbe Symptomatik sein.
    Da müssen wir nur sehen, dass wir den Dongle aktiviert bekommen ...


    // EDIT:
    BTW: -> gerade entdeckt, ist aber etwas älter


    Quote


    Der "USB WiFi-Adapter für den Raspberry Pi von The Pi Hut" hat laut Beschreibung einen Realtek 8188-Chipsatz. OpenELEC 3.0 für den Raspberry Pi lädt dafür anstandslos die Kernelmodule rt2x00lib, rt2x00usb, rt2800lib, rt2800usb. Laut Beschreibung sind Infrastructure-, Ad-Hoc-Mode und Wireless Roaming möglich.


    Quelle



    -> hier <- steht auch noch was zu dem Teil ...



    cu,
    -ds-

  • Also frag nicht warum, aber es funktioniert. :)


    Hatte Jessie neu aufgespielt und die Routerdaten in die wpa_supplicant geschrieben. Erst keinen Erfolg nach Neustart. Dann dasind OS auf den neusten Stand gebracht und scheinbar hat er sich dann den Treiber gezogen. Nach erneutem Neustart hat er auf einmal den Dongle erkannt und er läuft.


    Bin total happy und danke für die Hilfe. Ich war echt verzweifelt.


    Aber eine kurze Frage am Rande. Via xRDP stelle ich eine Verbindung vom PC zum Pi0 her. Geht das auch von PI3 zum Pi0 problemlos oder kann ich mir beim Versuch sofort das System wieder zerschießen?


    Viele Grüße
    Endric