Pi Zero und Wlan einrichten

  • Hallo Zusammen,


    ich hab mir ein RPi Zero bestellt und die wichtigsten Kabel gleich dazu, mein Problem ist das ich das Wlan nicht zum laufen bekomme.


    Ich hab einen Edimax EW-7811UN WLAN Stickder im Raspi B+ einwandfrei funktioniert hat.
    Netzteil hat 2,5A.


    Ich hab jetzt mehrere Anleitungen durchprobiert aber ich bekomm einfach keine Verbindung.


    Wie bin ich vorgegangen:
    - Rasbian Jessie auf SD kopiert
    - Keyboard und HDMI angesteckt
    - Gebootet und Raspi Config ausgeführt
    - Localisation geändert (Keyboard Layout,..)
    - /etc/network/interfaces geändert


    - /etc/wpa_supplicant/wpa_supplicant.conf geändert

    Code
    1. country=AT
    2. ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    3. update_config=1
    4. network={
    5. ssid="meinnetzname"
    6. psk="meinpasswd"
    7. }


    - Runtergefahren Keyboard aus und WLAN Stick eingesteckt
    - Neu gebootet


    Router zeigt mir das Raspi nicht an, auch mit einem IP Scanner hab ich es nicht finden können.


    Hat jemand eine Ahnung was ich da machen kann, ich bin totaler Linux neuling, und da der Stick immer nur getrennt von der Tastatur angesteckt werden kann, kann ich auch keine Abfragen machen :/



    Danke euch!!

  • Hasst du den Hostnamen Geändert? Vielleicht gibt es ein IP Adressen Konflikt?
    PS ich mache das immer noch über die Grafik(startx) der Rest ist mir zu viel Arbeit. Ich will mit meinen PIs was machen und mich nicht rumärgern :)

  • Hallo ihr zwei!


    Leider hab ich keinen aktiven USB Hub, ich hab aber bereits einen bestellt.


    Hostnamen hab ich auch schon mal geändert, hat auch nicht funktioniert.


    startx nützt mir derzeit nis da ich Tastatur und Wlanstick nicht zur selben Zeit anschliessen kann.

  • Hallo Grand,


    ...
    startx nützt mir derzeit nis da ich Tastatur und Wlanstick nicht zur selben Zeit anschliessen kann.


    dann nimm doch ein PL2303-Kabel ( oder ein Äquivalent ) und schliesse es an den Pins für die serielle Konsole an. Dann kannst Du mit einem Terminal-Programm ( minicom, cutecom, ... ) auf den Raspi zugreifen.
    Per default ist die serielle Konsole ja aktiviert. So hab' ich jedenfalls meine Nullen eingerichtet ;) ...


    cheers,
    -ds-

  • Also so ein Kabel hätte ich da, habs aber noch nie angeschlossen, gibts da eine Anleitung dazu welche 4 pins das beim zero sind, hab glesen das manche schon ihre GPIOs beschädigt haben weil falsch angeschlossen?


    Kann ich da auch mit Putty arbeiten wenn ich auf Serial umstelle oder soll ich mir besser das cutecom ziehen?


    Danke für deine Hilfe!! ;)

  • Nee ... da musst Du nicht vier Kabel anschliessen ... drei reichen.
    Einmal das scharze vom Kabel an irgendeinen GND-Pin des Zero (z.B. Pin #6), dann das weisse des Kabels an Tx ( Pin #8) und das grüne an Rx ( Pin #10).
    Das Kabel zur Spannungsversorgung (rot) nicht anschliessen, weil hier 5V drauf sind - und das mag der Zero genausowenig wie seine grossen Geschwister ...
    Vermutlich haben Deine Kabel andere Farben - da musst Du notfalls mal Tx und Rx tauschen.
    Solange Du die Spannungsversorgung nicht anschliesst kann da nix passieren.
    Das verhält sich dann anschliessend wie eine normale, serielle Schnittstelle und sollte sich auch so verhalten.


    cheers,
    -ds-

  • EW-7811UN - hm


    ich glaub den hab ich auch . Am Anfang hat er anstandslos funktioniert. Dann (1 Jahr Später) überhaupt nicht mehr ständig Abbrüche, mieseste Übertragung und Verbindung.


    lies mal die negativ Kundenrezensionen bei Amazon.


    vielleicht liegt es ja am Stick.

  • ok danke, sind die pins gleich wie bei den B Modellen oder sind die unterschiedlich?


    Würde gerne ein Worksheet für die Pinnummern verwenden :)

  • So Pins sind angelötet, Rasbian über Noobs neu installiert, Settings wie oben beschrieben neu durchgeführt, wlan funktioniert nicht.


    Im Rasbian Menü SSH und Serial aktiviert!


    USB-Serialkabel angeschlossen:
    Pin 6 Schwarz
    Pin 8 weiss
    Pin10 grün
    (Rot nicht angeschlossen)


    Treiber für das Kabel wurde installiert, Im Gerätemanager wird mir unter Com angezeigt das was angeschlossen ist und auf COM3 arbeitet.


    Also Putty gestartet, auf Serial umgestellt, auf COM3 umgestellt und die Rate auf 115200 gestellt, das hab ich auch im Gerätemanger gemacht, hab ich irgendwo gelesen.


    nachdem Rasbian neu gestartet hat hab ich dann versucht zu verbinden, Putty macht ein Fester auf und versucht mit COM3 zu verbinden, gelingt aber nicht.


    Was mach ich jetzt?

  • Tja ... wie ich gerade gelesen habe, hast Du NOOBS installiert.
    Das habe ich noch nie verwendet, solche "Spezialversionen" sind mir suspekt und haben in der Vergangenheit oft durch Probleme bzw. Inkompatibiliät geglänzt :fies:
    Hast Du keine Möglichkeit mal das ganz "normale" Jessie oder Jessie-Lite zu booten?


    cu,
    -ds-

  • Bisher immer Jessie Full drauf gehabt!


    Das war der erste test mit Noobs!


    Und jetzt die gute Nachricht, ich hab keine Ahnung warum aber ich habe gerade wieder mit Ip Scan das Netz durchgekämmt und siehe da raspizero.lan ist da :)
    Ein ganzer Tag verschi**en und ich hab keine Ahnung woran es lag, jedenfalls funktioniert das WLAN jetzt aber das Seriale kabel bringt keine Verbindung zustande. Egal ich nutze WLAN.


    Ich danke dir für deine Hilfe!!!!!


    Schönen nachmittag wünsch ich dir noch!


    ;)

  • Naja ... ist doch schön, dass es jetzt funktioniert.
    Das mit der seriellen Konsole muss auch gehen - wie gesagt, ich tipp' da auf NOOBS und dass da die serielle Konsole eben nicht aktiviert ist ( kannst Du mit raspi-config machen ).
    Ja dann mach hier bitte noch das "erledigt"-Häkchen dran.
    Ich wünsch Dir noch viel Spass und spannende Versuche mit dem Zero ...
    cu,
    -ds-