Mounten bzw. Verbinden mit Synology DiskStation

  • Hallo,
    ich vesuche mit dem Raspberry, auf dem Jessie läuft auf meine Synology DiskStation zu kommen.
    Dabei bin ich hier in Forum auf nachfolgende Anleitung gestoßen:


    http://www.raspbian.org/Raspbi…o_I_mount_an_NFS_share.3F


    jedoch erhalten ich als Ergebnis:


    mount.nfs: Connection timed out


    Dies könnte vielleicht an den fehlenden Berechtigungen liegen, den ich habe nirgens den Punkt gefunden, wo ich Benutzer und Passwort setzen kann.
    Den Benutzer root kann ich auf NAS nicht eintragen, weil gesperrter Name und pi auch nicht, weil zu kurz.

  • Moin,
    mhm, kannst du denn mit einem Rechner deine Station(Nas) erreichen??


    Wenn ja , mit welchen Betriebssystem. Ich denke du gehst von falschen Vorstellungen an die Sache ran.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.


  • Hast du die/das Verzeichnis, welches du mounten willst, in der Synology auch für NFS freigegeben? (Systemsteuerung - Gemeinsame Ordner - Bearbeiten - NFS Berechtigungen)...


    Das wars - super und danke! Ich habe das Verzeichnis nicht freigegeben für den Raspi bzw. die IP.


    Per:

    Code
    mount -t nfs 192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera


    kann ich den Share einmalig anbinden.


    Jedoch nach einem Neustart ist die Anbindung weg.
    Wenn ich in /etc/fstab:

    Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs rsize=8192,wsize=8192,timeo=14,intr 0 0


    schreibe, dann bindet Raspi es nicht an.
    In crontab mit

    Code
    @reboot mount -t nfs 192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera


    geht es leider auch nicht.
    Hast du hierzu auch eine Idee?


  • mir half diese Seite für mein Qnap


    Ich würde gerne bei der vorgehenden Lösung bleiben.
    Wenn ich es manuell nach dem reboot anbinde, dann habe ich die Verbindung.
    Fehlt nur der Zwischenschritt, dass es beim Neustart gemountet wird.

  • Bei mir sehen auf einem rasPi die (nfs) Mounts so aus :


    Code
    Triton:/volume1/SWDevelopment /nas/develop nfs rw,soft,bg,timeo=30 0 0
    Triton:/volume1/Sourcen       /nas/sourcen nfs rw,soft,bg,timeo=30 0 0


    wobei "Triton" der Syno-NAS Hostname ist, welcher in der /etc/hosts referenziert wird...


    Dein Parameter "intr" ist mir nicht geläufig...


    Probleme machen diese mounts nur, wenn die Syno Nachts abschaltet... dann versucht der RP ein reconnect, scheitert...
    Mit automount hab ich da schon herum experimentiert, aber nicht erfolgreich......


    Grüße, das Zen
    Automatisch zusammengefügt:[hr]


    In crontab mit

    Code
    @reboot mount -t nfs 192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera


    könnte an dem fehlenden Pfad zum Kommando "mount" liegen...
    Automatisch zusammengefügt:[hr]


    cifs != nfs


  • cifs != nfs


    hallo Kindergartenkind :)


    das ist mir klar, nur es funktioniert endlich, als du hier warst hattest du ja keine Lösung, also warum dieser Hinweis?

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Also probleme mit reconnect werde ich nicht bekommen, da es sich bei dem Share um eine USB SSD handelt, die an dem NAS hängt. Die wird nie abgeschaltet.


    Aber zurück zum Thema
    Wenn ich in fstab den Befehl umbaue:

    Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs rw,soft,bg,time=30 0 0


    dann wird es ebenfalls nicht angebunden.

  • was soll der : im Link?


    Ich habe mal eine externe Platte am NAS gehängt, die ist auch sichtbar
    Habe aber noch keine Freigabe erstellt, vielleicht später mal.


    Nimm erst mal den : raus kommt mir 'komisch' vor

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • AndyKL versuchs mal mit der _netdev Option.

    Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs _netdev,rw,soft,bg 0 0


    jar der : trennt nfs-Host vom Sharename und ist notwendig

    "Wenn du nichts zu sagen hast, sag einfach nichts."

  • danke, ich sags ja ist ein wirrwar, ich hatte vorletzte Woche 2 Linuxfreunde zum Kuchenessen und keiner hatte einen Plan warum einige PI SMB Freigaben sahen einige nicht....


    egal nun läuft es bei mir, am NAS habe ich noch keine Freigabe für USB Platten eingerichtet, teste ich noch wenn das Case für die 8TB Platte kommt, die Erstlieferung ging beim gilb verloren.

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs _netdev,rw,soft,bg 0 0


    Also weder mit _netdev noch ohne : geht die Anbindung nach reboot.
    Wenn ich es manuell mit
    sudo mount -t nfs 192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera
    anbinde, dann funktioniert es.

  • Und wenn du systemd mounten lässt?

    Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0

    "Wenn du nichts zu sagen hast, sag einfach nichts."


  • Wenn ich in fstab den Befehl umbaue:

    Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs rw,soft,bg,time=30 0 0


    dann wird es ebenfalls nicht angebunden.


    time=30 ist falsch, das muss timeo=30 heissen!


    das Zen
    Automatisch zusammengefügt:[hr]
    ich habe das gerade mal auf meiner Syno nachgestellt:


    Code
    192.168.178.24:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs noatime,rw,soft,bg,timeo=30 0 0


    Genau so funktioniert es...


    Wenn du systemd laufen hast, macht der Beitrag von llutz weiterhin Sinn, da dann gewartet wird, bis das Netzwerk verfügbar ist...

  • Mit ...

    Code
    192.168.178.35:/volumeUSB1/usbshare/Kamera_vorne-Bilder /Kamera nfs x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0


    ist es jetzt gegangen.
    Nach Neustart habe ich den Share.


    Vielen Dank

  • Ich muss zu dem Thema doch noch mal fragen.


    Ist es normal, dass der Raspberry bei einem 4 GB großen Ordner knapp 1 Minute benötigt, um diesen zu öffnen?
    Also ich öffne von außen per FileZilla den Ordner und das dauert knapp 1 Minute.

  • Hallo,

    Zum Thema Synology mounten:

    Ich verwende eine DS416slim.

    Bei mir hat der Tipp den MOUNT-Befel über ein Script laufen zu lassen, geholfen.

  • Das Thema ist ja schon ein bisschen älter. Bin aber gerade darauf gestoßen. Weil ich das Thema mega interessant finde. Und ich das noch mal in Erinnerung rufen möchte. Ich hatte auch vor einiger Zeit Video dazu gemacht:


    Mit DiskStation eigene Geräte verbinden und Alarm ausgeben


    Python-SW:

    git clone https://github.com/Benelli889/SurveillianceProject

    sudo mount 192.168.178.26:/volume1/surveillance /home/pi/Projects/Surveillance nfs rsize=8192,wsize=8192,timeo=14,intr 0 0