Fehlalarme Bewegungsmelder PIR HC-SR501

  • Vielleicht kann man nach erkanntem high-level einfach z.B 2 Sekunden warten und dann den Zustand des gpio nochmal überprüfen?
    Falls es EMV ist sollte das reichen.


    Ich habe eine ähnliche Problematik mit meinem Klingeldetektor für das Eingangstor. Hier brauche ich im Keller wo der RPi im Schaltkasten schlummert nur das Licht einschalten und schon wird detektiert :-)


    Das Verhalten stört mich aber nicht, ich werte es als Funktionsprüfung :D


    VG Leroy

    Manchmal bin ich sooo müde 💤

  • Spontan fällt mir (zunächst) eine RC-Beschaltung des RP-GPIO Einganges ein:

    Da der PIR-Sensor einen Längswiderstand (1k) eingebaut hat, könntest du stumpf einen Keramikkondensator zwischen den GPIO und Masse (GRD) schalten (nahe des GPIOs).
    Als erster Versucht so 10 ... 20 ... 100 nF.
    Das verzögert das Signal nicht merklich, kurze HF-Pulse _könnten_ ausgefiltert werden.


    Aber da du ja recht lange Leitungen hast... sicher ist das nicht.


    Falls du das Verhalten provozieren kannst und ein Oszi hast, könntest du ja auch versuchen, es zu messen...


    Andere Idee: Den GPIO im Interrupt-Mode betreiben und messen, ob nach den Triggern des Eingangs das Signal weiterhin ansteht...

  • Das Gas in der Gastherme wird mit einem Zündfunken mit einer nicht gerade kurzen Funkenstrecke gezündet. Dieser "Sender" kann schon empfindliche Detektoren durcheinanderbringen. Mal mit einem Radio (LW, MW, KW) testen, ob starke Knackgeräusche während des Zündvorgangs zu hören sind. Die Zündelektroden der Therme sind Verschleißteile. Wann sind die zum letzten Mal geprüft und ersetzt worden? Wenn die nicht richtig justiert sind, kann es Überschläge zum Thermengehäuse geben. Dann sind die Verhältnisse noch unbestimmter.


    Hat die Entfernung des Kondensators Erfolg gehabt?


    Marcus

  • Ich hatte mal mit nem Bewegungsmelder für eine Deckenlampe Probleme, als ich einen RasPi in der Nähe des Melders stationiert hatte.
    Zum Glück konnte ich das reproduzieren, denn als ich den Pi deaktivierte, waren die Fehlerkennungen weg.


    Der Auslöser waren die LEDs des RasPi, daher musste ich den Pi woanders (nicht in Sichtweite des Melders) platzieren.


    Fazit: Evtl gibt es irgendwo IR oder LED Gedöns, welches von manchen Meldern zu leicht als Bewegung interpretiert werden.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Quote

    Das Kabel hat ungefähr eine Länge von 10m.
    Dummerweise kann ich das Kabel nicht mehr gegen ein geschirmtes austauschen.
    Vielmehr glaube ich, dass es durch das Einschalten der Gastherme ein EMV-Problem gibt.


    Der Zündfunken wird mit >1kV gezündet, warum sollten da 0,8V ein hohes Störsignal sein ?
    Dann im nachhinein zu versuchen, ein Signal mit 3-5 Volt auf 10m zu entstören, ist ....sorry, mir fällt das Wort nicht ein ;)

  • Zum gleichen Thema einen neuen Thread aufmachen ist aber auch nicht toll.
    Das Problem ist übrigens folgendes: Beide Potis auf dem PIR-Modul sind 105er, also ist mindestens eines zu hochohmig. Mit der richtigen Einstellung ziemlich nahe an dem Anschlag gibt es keine Fehlalarme mehr.


    Vielen Dank
    sagt
    Marcus

  • Hi, konntest du inzwischen die Ursache für die Fehlschaltungen beseitigen?
    Ich hatte das gleiche Problem bei meinem MagicMirror. Der Bildschirm ging ständig an und aus, auch wenn niemand vor dem Spiegel stand.
    Meine Lösung: verdrillte Adern und die Signalleitung 1-2mal um eine kleine Ferritperle wickeln.
    Heutzutage sind in jedem Haus so viele Funksender verbaut, dass jeder cm Kabel sofort wie eine Antenne wirkt.
    Schade, dass du die Leitung nicht mehr wechseln kannst. Ich hätte in diesem Fall ein (Cat5 oder höher) Netzwerkkabel verbaut und alle nicht benötigten Adern mit Masse verbunden.
    Den Regler für die Empfindlichkeit ganz auf Minimum und schon hat alles funktioniert.


  • Ich hatte exakt dasselbe Problem am ESP8266 der sporadischen Fehleralarme, unabhängig von den Poti-Einstellungen.

    Wirklich etwas gebracht hat nur folgender Tipp:

    "You simple need to solder a 220nF ceramic capacitor across pin12 und pin13 of the chip (BISS0001) so that the high-frequency interference coming from the ESP8266 don't influece the gain stage anymore."

    wurde hier diskutiert:

    http://www.letscontrolit.com/f…ic.php?f=5&t=671&start=20


    Seither kein einziger Fehleralarm mehr!

    Gruß

  • Jo!

    Das Puffern der Versorgungsspannung beim ESP mit 220nF ist wirklich sehr zu empfehlen, unabhängig von der Versorgung.


    Ich musste die gleiche Erfahrung bei meinen ESPs machen, ich habe zusätzlich zum 220nF Keramik noch einen 100müF Elko parallel geschaltet...

    Hi, hättet ihr mal ein Bild wo der puffer Elko und der 220nF Keramik genau hinmüssen. Danke


  • So sieht das bei mir aus:


    Ein Keramik- und und ein Tantalkondensator direkt an (über) die Anschlüsse des ESP8266...

    AH super, danke, hätte es schon fast an den PIR gelötet:-)


    Auf welcher Seite hast du - angelötet ? Danke