Rpi3 mit Digital Sound Card [Anfänger]

  • Hallo zusammen,


    ich habe mir den RPi3 gekauft und dazu diese https://www.amazon.de/gp/product/B01HBKQMLW/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1 (Affiliate-Link)


    Hab OpenELEC mit Kodi installiert. Jetzt habe ich aber keine Möglichkeit die Karte auszuwählen.
    Hab schon einen Hinwes dazu gefunden wie ich die Karte auswählen kann, bin daran aber gescheitert. Das Beispiel war mit einer Hifiberry.


    SSH aktivieren
    Mit Putty zugreifen
    den Befehl "mount -o remount,rw/flash" ausführen
    Und dann mit "nano" die Datei /flash/config.txt editieren. Hierbei scheitere ich aber. Ich habe keine Ahnung wie ich den Eintrag "dtoverlay=hifiberry-digi dtdebug=1 " einfügen soll.


    Kann mir jemand helfen?


    Danke!


    Grüße Lizzel

    Edited once, last by Lizzel ().

  • Moin Lizzel,
    erstmal: Herzlich Willkommen im Forum!


    Tja, aller Anfang ist schwer....
    wenn du dann nano mit der config.txt gestartest hast, mach folgendes.
    Geh zum Ende der Datei und gebe folgendenes ein

    Code
    # meine hifiberry-Einstellung
    dtoverlay=hifiberry-digi
    dtdebug=1


    Dann Strg+ o zum Speichern. Du wirst gefragt ob du config.txt schreiben möchtest. Einfach Return/Eingabetaste.
    Dann Strg+x für das Beenden.
    Das war es. Damit es greift einen Reboot ausführen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Dann Strg+ o zum Speichern. Du wirst gefragt ob du config.txt schreiben möchtest. Einfach Return/Eingabetaste.
    Dann Strg+x für das Beenden.
    Das war es. Damit es greift einen Reboot ausführen.


    Gruss Bernd


    Dann kommt "ready only file system" :-/

  • Moin Lizzel,
    du hast in deinem 1ten Post geschrieben

    Code
    den Befehl "mount -o remount,rw/flash" ausführen

    Ich bin davon ausgegangen das dir das klar ist. Erstmal das ReadOnly auf "Schreiben" setzen.


    Aber der Link von raspibastler ist gut.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo. Bei mir läuft es nach der Anleitung.


    Nur bekomme ich nur einen Stereo ton über den Lichtleiter und kein AAC oder DTS.


    Kann das an Kodi liegen oder muss ich noch etwas wo ändern.

  • Nur bekomme ich nur einen Stereo ton über den Lichtleiter und kein AAC oder DTS.

    Kann das an Kodi liegen oder muss ich noch etwas wo ändern.

    Guckst Du hier, was Tante G zu Tage förderte. Ab Schritt 6.


    Gruß, STF