Relaisboard Gefahr


  • 2. Die GPIOs werden über 1. Widerstand, 1. Optokoppler -Diode, und einer LED, in Reihe von der 5V VCC gespeist, wobei die Spannung am In-Anschluss auf ca. 2,9V fällt was ausreicht für die GPIOs, sie schalten bei Low den Stromkreis.


    Verstehe ich das richtig - Du läßt die 5V (am IN-Eingang) über die Strecke Widerstand->LED->Optokoppler gegen die GPIO's fließen?

  • [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]@ [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]BarnyFeuerstein[/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"] [/font][/font]


    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Habe heute auch so ein Relaisboard (8 Kanal) getestet. [/font][/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Angeschlossen habe ich auch (externe) +5 V an VCC von der 10-er Leiste und hier auch GND. [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]JD-VCC und VCC sind überbrückt.[/font] [/font][/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Dabei konnte ich auch nur ca. 2,9 V a[/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]n den IN - Anschlüssen messen.[/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Somit dürfte es für den RPI kein Problem sein, die IN - Anschlüsse direkt über die GPIO´s des RPI zu steuern.[/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Im Kurztest hat mein RPI überlebt.[/font]

  • [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Angeschlossen habe ich auch (externe) +5 V an VCC von der 10-er Leiste und hier auch GND. [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]JD-VCC und VCC sind überbrückt.[/font] [/font][/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Dabei konnte ich auch nur ca. 2,9 V a[/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]n den IN - Anschlüssen messen.[/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Somit dürfte es für den RPI kein Problem sein, die IN - Anschlüsse direkt über die GPIO´s des RPI zu steuern.[/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Im Kurztest hat mein RPI überlebt.[/font]


    Falls Du aber mal einen GPIO Port mit angeschlossenen Relaisboard als Eingang konfigurieren solltest, ist er vermutlich schnell kaputt.

  • Falls Du aber mal einen GPIO Port mit angeschlossenen Relaisboard als Eingang konfigurieren solltest, ist er vermutlich schnell kaputt.


    Habe zwar nicht vor, die am Board angeschlossenen GPIO Ports als Eingänge zu definieren, noch will ich Deine Aussage dementieren. Dazu habe ich viel zu wenig Ahnung.
    Dennoch will ich mir die Frage erlauben: Warum soll der RPI kaputt gehen? Wie schon erwähnt, habe ich an den In - Anschlüssen vom Relaisboard ca. 2,9 V gemessen.

  • Beim Start des RPi sind (fast) alle GPIOs als Eingänge definiert. Da sehe ich aber kein Problem, da über die beiden Dioden (Optokoppler, LED) fast
    2 Volt abfallen.


    Auch ich hab nachgemessen:
    Bei GPIO High (3,3 V) fließt kein Strom. Bei GPIO Low (0 V) sind es 2mA.


    Die 2mA sind zwar an der Grenze was ein einzelnen Port (ohne Anpassung) "schafft" und mein Garagentor& Hoftoröffner läuft jetzt schon das 2te Jahr ....


  • [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Angeschlossen habe ich auch (externe) +5 V an VCC von der 10-er Leiste und hier auch GND. [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]JD-VCC und VCC sind überbrückt.[/font] [/font][/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Dabei konnte ich auch nur ca. 2,9 V a[/font][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]n den IN - Anschlüssen messen.[/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Somit dürfte es für den RPI kein Problem sein, die IN - Anschlüsse direkt über die GPIO´s des RPI zu steuern.[/font]


    Ich glaube, hier liegt eine Verwechselung vor. Wenn ein Sainsmartrelaismodul nicht mit 5V, sondern 3,3V an den IN-Eingängen betrieben wird, dann geht nicht der Pi kaputt, sondern man läuft Gefahr, daß das Sainsmartmodul kaputt geht. Das mag zunächst verwirrend klingen - wie soll bei weniger Spannung/Strom etwas kaputt gehen, wird aber bei näherer Betrachtung leicht verständlich.


    Das kritische Teil auf dem Sainsmartmodul ist der das Relais treibende Transistor. Dieser wird (bzw. sollte) als Schalter betrieben werden. D.h. entweder sollte er (voll) gesperrt sein, womit sein CE-Strom gegen 0 geht oder er sollte voll durchgesteuert werden, womit die CE-Spannung gegen 0 geht. Damit ergibt sich für die am Transistor abfallende Leitung in beiden Fällen 0W, da 0A*5V=0W und xA*0V=0W. Soweit der Gutfall. Wird der Transistor jedoch nicht vollständig durchgesteuert, dann sind beide Werte (Strom und Spannung) ungleich 0 und es fällt eine gewisse Leistung am Transistor in Form von Wärme ab. Übersteigt diese die zulässige Verlustleistung des Transistors, dann brennt er durch.


    Und genau das nicht vollständige Durchschalten (in dem Fall sperrern) des Transistors passiert, wenn der Fototransistor des Optokopplers nicht genügend Licht (bzw. im gesperrten Fall noch Restlicht) erhält. Das Licht kommt seinerseits von der Kette IN-Eingang->Vorwiderstand->LED->Optokoppler-LED. Verbindet man VCC mit JD-VCC, so wird immer ein Restlicht, erzeugt von 5V-3,3V, in der Kette verbleiben.


    Will man nun dennoch auf sauberem Weg das Relaismodul verwenden, dann sollte man zunächst die beiden Kreise trennen (Jumper VCC<->JD-VCC trennen) und Sorge dafür tragen, das der "Primärkereis" (Vorwiderstand->LED->Optokoppler-LED) auf 3,3V abgestimmt wird. Dazu kann entweder der Vorwiderstand auf etwa 200Ohm gesenkt werden oder die LED unter einem Lötklecks begraben werden (sprich entfernt und kurzgeschlossen). In beiden Fällen steigt dann die Spannung um etwa 1,7V, womit die Optokoppler LED wieder das erforderliche Licht erzeugt (und auch voll abschaltet), damit der Relaistransistor voll durchsteuert/sperrt.


    Schaut Euch mal ein wenig bei Transistorkennlinien um - darum geht es hier.



    Schöne Grüße


    schnasseldag

  • Habe zwar nicht vor, die am Board angeschlossenen GPIO Ports als Eingänge zu definieren, noch will ich Deine Aussage dementieren. Dazu habe ich viel zu wenig Ahnung.
    Dennoch will ich mir die Frage erlauben: Warum soll der RPI kaputt gehen? Wie schon erwähnt, habe ich an den In - Anschlüssen vom Relaisboard ca. 2,9 V gemessen.


    Ein GPIO Port hat konstruktionsbedingt einen variablen Innenwiderstand. Je nachdem ob dieser als Ausgang ( niederohmig ), Eingang ( hochohmig ), mit o. ohne softwaregeschalteten Pullup- / Pulldown Widerstand konfiguriert ist, ändert sich auch der Innenwiderstand des GPIO Ports. Dadurch verschieben sich die Verhältnisse im Spannungsteiler und damit auch die Eingangsspannung an einem beschaltetem GPIO Port. Es entsteht die Gefahr, das ein GPIO Pin durch Überspannung kaputt geht.


    Das kannst Du selbst testen, wenn Du zwei gleiche Widerstände z.B. von je 2 KOhm in Reihe zu einer Spannungsquelle schaltest, dann kannst Du ca. die halbe Betriebsspannung zwischen beiden Widerständen und dem GND messen. Tausche nun dem am GND nächsten Widerstand gegen einen viel größeren Widerstand z.B. 20 KOhm aus und miss noch einmal!


    Wenn man aber einen Treiber IC benutzt, bräuchte man sich darüber keine Gedanken machen. Ich hoffe mal, das dich meine Erklärung von weiteren Dummheiten am RPi abhält. Es reicht oft nicht aus, nur mit einem Multimeter etwas zu messen, wenn man nicht weiß, warum dies so ist.

  • Damit wird aber dem GPIO deine geschätzte 1,7V zu den Gemessenen 2,9V addiert was zufiel ist und einen Defekt hervorrufen kann.
    Mit den 2mA Schaltet das Relais zuverlässig.

  • Will man nun dennoch auf sauberem Weg das Relaismodul verwenden, dann sollte man zunächst die beiden Kreise trennen (Jumper VCC<->JD-VCC trennen)


    So ist es Richtig



    und Sorge dafür tragen, das der "Primärkereis" (Vorwiderstand->LED->Optokoppler-LED) auf 3,3V abgestimmt wird


    Ist es schon



    Dazu kann entweder der Vorwiderstand auf etwa 200Ohm gesenkt werden oder die LED unter einem Lötklecks begraben werden (sprich entfernt und kurzgeschlossen). In beiden Fällen steigt dann die Spannung um etwa 1,7V, womit die Optokoppler LED wieder das erforderliche Licht erzeugt (und auch voll abschaltet), damit der Relaistransistor voll durchsteuert/sperrt.


    Damit wird aber dem GPIO deine geschätzte 1,7V zu den Gemessenen 2,9V addiert was zufiel ist und einen Defekt hervorrufen kann.
    Wenn der Steuerkreis, wie schon öfters vorgeschlagen mit 3,3V betrieben würde wäre die Gefahr des nicht richtig durch steuern/sperrt des Transistors eher möglich!


    Mit den 2mA Schaltet das Relais-Port zuverlässig.


  • Mit den 2mA Schaltet das Relais-Port zuverlässig.


    Das deckt sich auch mit meinen Messungen, die ich vor etlicher Zeit anstellte. Was sich allerdings nicht deckt ist der Umstand, daß im Falle des Betriebs von 3,3V am GPIO auch tatsächlich 2mA durch den Optokoppler fließen. An meiner Karte beobachte ich nur 0,32mA bei einer GPIO Spannung von 3,17V.
    Anbei meine Meßwerte.


    Und hier die Messungen zur Ermittlung des kritischen Stromes zum Schalten der Relais.


    Und hier die Schematics, auf die sich meine Messungen beziehen.


    Vielleicht gibt es ja jetzt Relaiskarten mit 170Ohm für den Betrieb unter 3,3V. Meine war eindeutig für 5V ausgelegt und besaß einen 1kOhm Widerstand. Abzüglich der Spannungsabfälle (in der Summe ungefähr 3V) der beiden LED's blieben dann bei den 2V und 1k genau die 2 mA übrig.

  • Darf ich das Thema nochmal aufwärmen. Ich beschäftige mich jetzt schon den ganzen Tag damit, wie viele Relais ich direkt an den Pi schließen kann, ohne sie extern mit Strom zu versorgen.


    Ich hab zunächst hier ein paar Forenbeiträge gelesen unter anderem diesen hier und habe aber dann bei weiteren Recherchen folgende Info gefunden.


    Quote

    An Pin 2 und 4 liegen +5V für die Stromversorgung externer Elektronik an. Im Gegensatz zu allen anderen Pins kann hier so viel Strom entnommen werden, wie das USB-Netzteil des Raspberry Pi liefert.


    Quelle: https://www.elektronik-kompend…/raspberry-pi/1907101.htm


    Stimmt das? Man liest ja sonst immer was anderes.

  • Quelle: https://www.elektronik-kompend…/raspberry-pi/1907101.htm


    Stimmt das? Man liest ja sonst immer was anderes.


    nö das stimmt nicht, kommt die Versorgung über den microUSB so ist der Strom auf den 5V Pins begrenzt, vom Netzteil, von der Polyfuse und was der PI und USB übrig lassen

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)


  • nö das stimmt nicht, kommt die Versorgung über den microUSB so ist der Strom auf den 5V Pins begrenzt, vom Netzteil, von der Polyfuse und was der PI und USB übrig lassen


    Aber so wie ich es verstehe geht der Pi dann in die Knie, er würde aber nicht zerstört werden?


    Nachdem ich das hier gepostet hatte, hab ich auch noch einen Beitrag hier im Forum gefunden, den ich ähnlich verstehe.


    Quote

    Die 5V Pins haben eine Besonderheit: Sie sind vom USB durchgeschliffen und haben somit nur indirekt eine Belastungsgrenze


    Quelle: http://www.forum-raspberrypi.d…rt-die-gpio-schnittstelle