SSH dauerhaft aktivieren

  • Hallo zusammen,


    ich nutze zur Zeit Jessie light.
    Unter raspi-config habe ich keine Möglichkeit gefunden SSH dauerhaft zu aktivieren.
    Mit sudo /etc/init.d/ssh start läuft SSH und ich kann zugreifen.
    Nach einem Neustart nicht mehr.
    Wenn ich sudo update-rc.d ssh defaults ausführe bekomme ich zur Antwort:
    inserv: warning: current start runlevel(s) (empty) of script "ssh" overrides LSB defaults (2 3 4 5)
    inserv: warning: current start runlevel(s) (2 3 4 5) of script "ssh" overrides LSB defaults (empty)


    Gruß
    Micha


  • ich nutze zur Zeit Jessie light.


    Seit wann nutzt Du jessie-lite?




    Wenn ich sudo update-rc.d ssh defaults ausführe bekomme ich zur Antwort:
    inserv: warning: current start runlevel(s) (empty) of script "ssh" overrides LSB defaults (2 3 4 5)
    inserv: warning: current start runlevel(s) (2 3 4 5) of script "ssh" overrides LSB defaults (empty)


    Wie sind die Ausgaben von:

    Code
    systemctl is-enabled ssh
    systemctl status ssh


    ?

    The most popular websites without IPv6 in Germany.

  • Hallo Micha,



    Unter raspi-config habe ich keine Möglichkeit gefunden SSH dauerhaft zu aktivieren.


    unter [font="Courier New"]Advanced Options[/font] befindet sich kein Eintrag SSH?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo zusammen,


    danke für die schnelle Reaktion-
    *jessie-lite* nutze ich seit heute :-)
    systemctl is-enabled ssh --> disabled
    systemctl status ssh
    Loaded: loaded
    Active: active (running)
    Main PID: 959
    CGroup: /system.slice/ssh.service


    Andreas nein da ist nichts :-(

  • Ich glaub das war von Andreas keine Frage an Dich, sondern eine Feststellung, das es unter Advanced Options keinen Eintrag für SSH gibt ;)


    Guck mal unter "Interfacing Options"


    raspi-config macht dort btw folgendes: https://github.com/RPi-Distro/…/master/raspi-config#L533

    Code
    update-rc.d ssh enable &&
    invoke-rc.d ssh start &&

  • *jessie-lite* nutze ich seit heute :-)

    Code
    systemctl is-enabled ssh --> disabled


    Andreas nein da ist nichts :-(


    Dann versuch mal:

    Code
    sudo systemctl stop ssh
    sudo systemctl enable ssh
    sudo systemctl start ssh


    Code
    systemctl is-enabled ssh
    systemctl status ssh


    Code
    sudo shutdown -r +1


    Nach dem reboot

    Code
    systemctl status ssh

    The most popular websites without IPv6 in Germany.

  • Vielen Dank für Ihren so schönen Beitrag zu lehren, wie man diesen Fall in effizienter Weise zu beheben.

  • Quote

    Jetzt geht es :-) Bleibt die Frage nach dem warum.


    Weil die Foundation den Start vom SSH-Deamon per Default ausgeschaltet hat.


    Das muss man erst (normalerweise) durch das passende einstellen z.b. via 'raspi-config' ändern.


    (Oder eben die Konfiguration einschalten 'sudo systemctl enable ssh' )

    Selber denken,
    wie kann man nur?

    Edited once, last by Rasp-Berlin ().