WLAN-Probleme - wie Channel ändern?

  • Liebe Leute,


    ich habe zu Weihnachten einen Raspberry PI 3 bekommen - mit dem HifiBerry DAC+ Pro. Auf dieser Seite ist vermerkt, dass es da regelmäßig zu Problemen mit dem WLAN kommt.
    Unten steht:


    Quote

    Update December 2016:



    The problem seems to occur only on specific WiFi channels. As a fix you can set your WLAN to a fixed channel other than the channels 1, 6, 11 and 14.




    Nun habe ich versucht, den WLAN-Channel zu ändern:

    Code
    sudo iwconfig wlan0 channel 13


    ergibt:

    Code
    Error for wireless request "Set Frequency" (8B04) :
       SET failed on device wlan0 ; Operation not supported.



    andere Channels ergeben das gleiche Ergebnis.


    Wie kann ich den WLAN-Channel meines RasPIs ändern?




    Endziel ist ein funktionaler RasPI mit dem DAC+ Pro, der sich automatisch mit dem WLAN verbindet, wenn er mit Saft beliefert wird. Das funktioniert bisher nur ohne den DAC.


    Vielen Dank für jede Antwort und
    Liebe Grüße
    Leander

    Edited once, last by leander ().


  • Wie kann ich den WLAN-Channel meines RasPIs ändern?


    I. d. R. macht man das bei der Konfiguration des WLAN-Routers.


    Wenn Du es zusätzlich auch auf deinem RasPI machen willst, dann mit Hilfe der wpa_supplicant.conf-Datei.


    Welchen WLAN-Channel hast Du z. Zt. in deinem WLAN-Router konfiguriert?

    The most popular websites without IPv6 in Germany.

  • I. d. R. macht man das bei der Konfiguration des WLAN-Routers.


    Wenn Du es zusätzlich auch auf deinem RasPI machen willst, dann mit Hilfe der wpa_supplicant.conf-Datei.


    Welchen WLAN-Channel hast Du z. Zt. in deinem WLAN-Router konfiguriert?


    Vielen Dank!
    Ich habe in der FritzBOX die Entsprechende Einstellung getroffen. Der Kanal ist jetzt wohl geändert, ich melde mich, wenn ich erforscht habe, wie der Einfluss auf den PI ist.
    Automatisch zusammengefügt:[hr]

    I. d. R. macht man das bei der Konfiguration des WLAN-Routers.


    Wenn Du es zusätzlich auch auf deinem RasPI machen willst, dann mit Hilfe der wpa_supplicant.conf-Datei.


    Welchen WLAN-Channel hast Du z. Zt. in deinem WLAN-Router konfiguriert?


    :danke_ATDE:
    Du hast mir sehr weitergeholfen. Ich suche wirklcih seit Tagen nach dem Fehler und habe jetzt keine Probleme mehr.
    Viele Grüße

    Edited once, last by leander ().

  • Kleiner Tipp für alle, die dasselbe Problem haben, aber nicht den Channel wechseln wollen:

    • [font="Courier New"]sudo raspi-config[/font] ("raspi-config" starten)
    • Localisation Options
    • Change Wi-fi Country
    • DE Germany


    Nach einem Reboot sollte das Problem erledigt sein.


    Technische Erklärung für alle, die es interessiert: In manchen Ländern sind bestimmte Frequenzbereiche "reserviert", d.h. sie dürfen z.B. nicht für WLAN-Übertragung genutzt werden. Channel 13 nutzt Frequenzbereiche, bei denen das der Fall ist - zumindest in den USA. In Deutschland hingegen darf Channel 13 problemlos benutzt werden, ohne von Behörden eins auf die Mütze zu kriegen. Dem Raspberry muss man leider explizit sagen, dass es sich in einem Land befindet, in dem Channel 13 benutzt werden darf...