Raspery Pi 3 mit Putty nicht erreichbar --WARUM??

  • Hallo Community,
    habe nach langem hin und her endlich die IP meines RasperyPi's eruieren können.
    Wenn ich allerdings mittels Putty versuche, mich einzuloggen, bekomme ich nur die Fehlermeldung :"Network error: Connection refused" - Wie kann ich Abhilfe schaffen??
    Meine Verbindungsparameter lauten wie folgt:
    IP(lt. Router):192.168.1.10
    Connection type:SSH
    Port:22


    P.S.: auch mit jedem anderen SSH-Client ist keine Verbindung möglich. Echt schade, zumal ich mich darauf gefreut hatte, endlich durchzustarten.


    Als Betriebssystem hatte ich Raspberian-Jessie auf die SD geschrieben.....


  • Du musst ssh am Pi aktivieren, oder die Lite-Version nehmen.


    oder ich gehe wie folgt vor:


    https://raspberry.tips/raspber…-mit-raspbian-25-11-2016/


    Zu dumm, dass die nützlichsten Funktionen deaktiviert wurden.
    Genau dasselbe Spiel mit den LED'S.....
    Sicherheit hin,Stromersparnis her, wenn ich vorab gewusst hätte,was ich jetzt weiß, hätte ich mir viel Arbeit erspart;
    dabei stehe ich erst ganz am Anfang :=(
    Das kann ja noch heiter werden!


  • Du musst ssh am Pi aktivieren, oder die Lite-Version nehmen.


    Gerade in der aktuellen Jesie Lite-Version muss vorher SSH aktiviert werden um darauf Zugriff zu erlangen.



    In der Lite Version ist es über raspi-config übrigens nicht mehr möglich.


    Warum soll raspi-config in der Lite Version nicht funktionieren?
    sudo raspi-config und schon bist du in der Config.


    Ihr habt schon recht, ich finde es auch nicht wirklich von Vorteil das SSH erst wieder eingeschaltet werden muss.
    Ich finde es umständlich bei der Inbetriebnahme ein "passendes" Display und eine Tastur anbringen zu müssen, um die Grundkonfiguration zur weiteren Verarbeitung zuerst anzupassen.
    Gerade für Neulinge ist diese Vorgehensweise eine große Hürde, wenn man noch keine Linux Kenntnisse hat und das System noch nicht kennt.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

    Edited once, last by Burny ().

  • Einfach über einen SD-Card-Reader im Rootverzeichnis eine leere Datei "ssh" (ohne "") anlegen und dann im Pi wieder erneut davon booten.
    Dann kann man auch wieder raspi-config nutzen, ohne Keyboard und Monitor anklemmen zu müssen.


    Die Datei wird nach dem Hochfahren automatisch gelöscht, sobald SSH läuft.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT


  • Einfach über einen SD-Card-Reader im Rootverzeichnis eine leere Datei "ssh" (ohne "") anlegen und dann im Pi wieder erneut davon booten.


    Diesen Trick kannte ich selbst noch nicht. Danke für den Hinweis.


    Das raspi-config Script ist auf allen Raspbian Versionen identisch.


    Identisch ist nicht ganz richtig. Bei den letzten Updates hat sich hier immer wieder eine Verschiebung einiger Konfigurationspunkte bzw. auch Ergänzungen gegeben.
    Spielt aber keine Rolle. Die Config wurde überschaubarer und Komplexer.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Das kann jedem passieren, dass man vor lauter Bäumen den Wald nicht mehr sieht.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • In der letzten Raspbian Version hat sich einiges im Menü von raspi-config geändert.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • HI,


    ich habe das selbe Problem zur Zeit.


    Habe beim ersten Start SSH Aktiviert und auch nochmal in der Grafischen Oberfläche unter Einstellungen geschaut und SSH ist aktiviert.


    Hab zwischenzeitlich ssh Server gelöscht und und neu installiert ohne Erfolg.


    mit dem Befehl sudo nano /etc/ssh/sshd_conf habe ich heraus gefunden das er auf Port 22 hört.


    Aber wenn ich mit der Ip und dem Port versuche eine Verbindung mit Putty herzustellen kommt immer Connection Refused.


    Was mache ich falsch?


    Vielen Dank
    Tobias

  • Was gibt denn "pgrep -lf ssh" aus?


    Kannst Du Dich vom Pi selbst verbinden? Gib mal die folgenden Befehle ein und poste die Ausgabe:


    Code
    ssh -v localhost
    ssh -v <IP-Adresse des Pi>


    Wie sind der Pi und Dein Windows-Rechner ans Netz angeschlossen?

  • HI,


    wenn ich mein Monitor und Tastatur anklemme wie jetzt komme ich normal ins Internet.


    Kann Seiten öffnen etc.


    pi@raspberrypi:~ $ pgrep -lf ssh
    859 ssh-agent
    904 ssh-agent


    ssh -v localhost
    OpenSSH_6.7p1 Raspbian-5+deb8u3, OpenSSL 1.0.1t 3 May 2016
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug1: Connecting to localhost [::1] port 22.
    debug1: connect to address ::1 port 22: Connection refused
    debug1: Connecting to localhost [127.0.0.1] port 22.
    debug1: connect to address 127.0.0.1 port 22: Connection refused
    ssh: connect to host localhost port 22: Connection refused


    ssh -v 192.168.178.32
    OpenSSH_6.7p1 Raspbian-5+deb8u3, OpenSSL 1.0.1t 3 May 2016
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug1: Connecting to 192.168.178.32 [192.168.178.32] port 22.
    debug1: connect to address 192.168.178.32 port 22: Connection refused
    ssh: connect to host 192.168.178.32 port 22: Connection refused
    pi@raspberrypi:~ $


    Beide Geräte hängen je an einem Lan Port einer Fritzbox Cable

  • Okay, der sshd läuft nicht - warum auch immer. Poste mal bitte die Ausgabe von


    Code
    systemctl status ssh.service
    systemctl is-enabled ssh.service


    Starte danach mal den sshd mit


    Code
    sudo systemctl start ssh.service


    Kannst Du Dich dann mit dem Pi verbinden? Wie ist danach die Ausgabe des obigen Status-Befehls?

  • HI,


    folgende Auswertung
    systemctl status ssh.service
    ● ssh.service - OpenBSD Secure Shell server
    Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
    Active: failed (Result: start-limit) since Di 2017-02-21 17:17:11 CET; 53min ago
    Process: 651 ExecStart=/usr/sbin/sshd -D $SSHD_OPTS (code=exited, status=255)
    Main PID: 651 (code=exited, status=255)


    systemctl is-enabled ssh.service


    enabled


    Ergebnis
    sudo systemctl start ssh.service
    pi@raspberrypi:~ $ systemctl status ssh.service
    ● ssh.service - OpenBSD Secure Shell server
    Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
    Active: failed (Result: start-limit) since Di 2017-02-21 18:15:49 CET; 23s ago
    Process: 1965 ExecStart=/usr/sbin/sshd -D $SSHD_OPTS (code=exited, status=255)
    Main PID: 1965 (code=exited, status=255)


    Kein Erfolg :no_sad:
    Automatisch zusammengefügt:[hr]


    Zur Überschrift: DARUM!!



    Der Thread gehört jemand anderem, sich dort dann einzuklinken weil dein eigenes Anliegen ähnlich ist, ist unhöflich.


    Entschuldigung wenn das hier nicht gewuenscht wird vorhandene Beitraege zu nutzen.


    Koenntest Du es in einen neuen verschieben???

    Edited once, last by tobih83 ().