LED zum Leuchten bringen - Noobie Frage

  • raspbastler hat schon Recht die Temperatur ist zu hoch. Er hat Kühlkörper. Habe ja zwei im direkten Vergleich. Mein anderer - auch mit Kühlkörpern - läuft mit identischem Image wie deiner MarvMan mit 52-54° Da ist wahrscheinlich wirklich hardwareseitig was im Argen :-/

  • Angst nicht! Jedoch finde ich, dass (wir sprechen von IDLE) 63 Grad zu hoch sind! Wie gesagt, meiner drömmelt immer vor sich hin! mit einer Cpu last von max 20% habe ihn mal vergessen herunterzufahren lief also die ganze Nacht und ich hatte immer noch nur 40.3 Grad.
    Ich habe aber auch nicht den Eintrag : force_turbo=1 gesetzt, also das er immer bis zum Thermal Throtteling mit 1.2 GHZ läuft!


    Also subjektiv betrachtet ist 63.4 zu hoch!

    Wenn's brennt 112 hilft weiter!


  • Naja, mein Pi hat 53.3 Grad und hat Kühlkörper, er hat aber immer gut funktioniert. Muss ich jetzt auch Angst haben?


    nicht um den PI, meine sind nur immer ausgestiegen bei über 51°C aber das lag wohl an miese (micro)SD Karten, zuletzt auch bei niedrigeren Temperaturen die "doofen" Toschiba microSD Karten, nun Samung EVO und es läuft!

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • ich würde gerne noch mal auf den Widerstand zurück kommen. Habe heute mal ein wenig gelesen und versuche gerade das Prinzip zu verstehen.
    Andreas hat ja gesagt, dass der Vorwiederstand für eine rote LED ca. 650 Ohm betragen müsste ((3,3-2)/0,002)


    Ich habe jetzt zwei Typen von Widerstände hier ein blauer - also Metall - mit rot - rot - schwarz - orange - gelb also 2 - 2 - 0 - 000 - / - sind das dann 220kOhm und passt dieser Widerstand für die rote und/oder RGB LED?


    Dann habe ich noch die Kohlewiderstände mit braun - schwarz - orange - gold also 1 - 0 - 000 - +-5% also 10 k Ohm?


    Falls ich richtig liegen sollte, wären die Widerstände dann ja beide erheblich größer als benötigt, dass ist dann unschädlich? Nur kleiner dürfen sie nicht sein?


    Lacht mich bitte nicht aus, aber ich habe mich heute zum ersten Mal mit diesem Thema beschäftigt. :daumendreh2:

  • Hallo Hakupapa,



    ich würde gerne noch mal auf den Widerstand zurück kommen. Habe heute mal ein wenig gelesen und versuche gerade das Prinzip zu verstehen.
    Andreas hat ja gesagt, dass der Vorwiederstand für eine rote LED ca. 650 Ohm betragen müsste ((3,3-2)/0,002)


    Je größer der Widerstand, deso weniger hell leuchtet die LED. Wenn bei 650 Ohm rund 2 mA Strom fließen (lt. Rechnung), dann fließt bei einem höheren Widerstand weniger Strom. Ab einem gewissen Widerstand fließt dann so wenig, dass das menschliche Auge kein Leuchten der LED zu erkennen vermag.


    Analog dieser Argumentation über Widerstand und Strom kann man auch über Widerstand und Spannung gehen. Aber das lasse ich mal lieber.


    Deine Widerstände sind also viel zu groß, um mit einer LED funktionieren zu können.


    Aber - hey - schließe die beiden mal parallel...
    Der Gesamt widerstand berechnet sich dann nach
    1/R = 1/R1 + 1/R2
    und nach R aufgelöst:
    R = R1*R2/(R1+R2)


    Da kommt dann was < 10 kOhm heraus. Vielleicht glimmt da was? Jedenfalls geht dabei nichts kaputt. Und vielleicht lernt man noch was dabei.


    Wenn Du zwei von den 10 k-Widerstanden hast und diese parallel schaltest, dann ist der Gesamtwiderstand 5 kOhm. Und vier von denen ergeben dann 2,5 kOhm. Damit sollte die LED dann einigermaßen erkennbar leuchten.




    Lacht mich bitte nicht aus, aber ich habe mich heute zum ersten Mal mit diesem Thema beschäftigt. :daumendreh2:


    Keine Sorge, ich nicht.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Dann hab ich einen Denk- oder Rechenfehler, denn die LED leuchten super mit beiden Widerständen (jeweils einzeln - nicht parallel). Wo liegt mein Fehler bei der Berechnung. Ich hab ja oben geschrieben, wie ich die Farben gedeutet habe.

  • wie du die Farben deutest ist mir egal, Farben sind sehr individuell deutbar (oder gibt es eine Norm für senffarben oder cremeblau?), messe doch den Widerstand einfach


    An einem Port gibt es 2 Spannungen wo sicher! low erkannt wird und wo sicher! high erkannt wird, dazwischen ist alles zufällig und abhängig vom einzelnen PI was bei anderen wieder anders sein kann.


    Mit einem Serienwiderstand zum GPIO wird immer ein Spannungsteiler gebaut der die vorraussichtliche Spannung willkürlich werden lässt.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • die Farbwerte habe ich von hier.
    Aber Du hast sicher recht, ich kann ja auch einfach ein Multimeter ranhalten. Fand die Varianten mit den Farben nur interessant und hätte sie gerne verstanden.

  • so mit Multimeter gemessen und siehe da mit dem braunen Widerstand lag ich farbtechnisch richtig er hat ca. 9,5 kOhm bei dem blauen Metallwiderstand hab ich die Farben in der falschen Richtung angenommen. Er hat ca. 4,5 kOhm mit beiden Widerständen leuchtet die LED gut. Aber mit einem niedrigeren Widerstand dann wahrscheinlich noch ein ganzes bisschen heller. Ich weiß ja nun, dass ich bis auf 1kOhm mit dem Widerstand runter kann. Werde mir mal passende Widerstände besorgen oder in Reihe schalten.

  • Hallo Hakupapa,


    die echten Widerstandswerte erklären dann auch Deine Beobachtungen bzgl. der LEDs.


    Gut!



    Werde mir mal passende Widerstände besorgen oder in Reihe schalten.


    Denke daran: Widerstände addieren sich, wenn sie in Reihe geschaltet werden. Die Formel für parallelgeschaltete Widerstände hast Du bereits.


    Das würde ich dann direkt mal ausprobieren... Schalte Deine beiden Widerstände doch mal in Reihe und dann mal parallel. Da wirst Du gegenüber einzelner Widerstände einen Riesenunterschied erkennen. Und es macht AHA!


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • AHA :thumbs1: Genau wie Du gesagt hast - in Reihe Widerstand addiert sich auf 14,4 und parallel auf 3,18 kOhm und wieder was gelernt. :danke_ATDE:


  • so mit Multimeter gemessen und siehe da .....bei dem blauen Metallwiderstand hab ich die Farben in der falschen Richtung angenommen.


    das passiert auch "Profis" gerne bei MF, deswegen immer messen!



    Denke daran: Widerstände addieren sich, wenn sie in Reihe geschaltet werden.


    und bei parallel addieren sich die Leitwerte also der Kehrwert vom Widerstand



    Die Formel für parallelgeschaltete Widerstände hast Du bereits.


    zum selber rechnen


    10k || 4,7k


    1/10 + 1/4,7 = 0,312


    gibt den Gesamtleitwert und aus 1/ wieder den Gesamtwiderstand


    3,19k

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • hallo jar. Auch dir vielen Dank!


    Ich hab jetzt im nächsten Schritt die if Funktion erkundet. Bin immer noch bei dem "Jugend programmiert Starter Kit" - Wenn ichs schon dahab kann ich es ja durcharbeiten.


    Hier der von mir schon modifizierte Code - die Modifikation betrifft die Farbe grün - die ich als gruen geschrieben hab.



    und hier die Fehlermeldung



    dann hab ich schon versucht mit pylint den Fehler zu suchen. Habe dadurch auch schon die ":" am Ende der if Funktion gefunden. Jetzt komme ich aber nicht mehr weiter. Der Code scheint immer noch Fehlerhaft zu sein. Aber ich habe ihn ansonsten identisch abgeschrieben - dachte ich zumindest. Warum verlangt er dann die Definition von gelb und grün. Erbitte Hilfe :daumendreh2:

  • Hallo Hakupapa,


    um die Warnung wegzubekommen:

    Code
    GPIO.SetWarning(false)


    Code
    gpio.setwarnings(false)


    nach dem Ansprechen der GPIO-Library und vor dem Absetzen des ersten GPIO-Befehls.


    Die Fehlermeldung mit dem "name is not defined" ist wohl eine Inkompatibilität innerhalb der verschiedenen genutzten Python-Versionen. Siehe hierzu den Link. Dort werden auch ein paar Maßnahmen vorgestellt.


    Und am Ende hilft ein

    Code
    gpio.cleanup()


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • danke für den Link. Wenn ich mit raw_input arbeite, läuft das Script schonmal durch. :)
    Dein Tipp mit

    Code
    GPIO.SetWarning(false)


    funktioniert aber leider nicht. Habs an mehren verschiedenen Stellen versucht - auch direkt nach dem Ansprechen der Bibliothek, aber immer die gleiche Fehlermeldung

    Code
    pi@raspberrypi:~ $ sudo python if.py
    Traceback (most recent call last):
     File "if.py", line 2, in <module>
       GPIO.SetWarning(false)


    edit: komisch die Fehlermeldung ist jetzt weg - auch ohne die SetWarning - verstehe ich nicht

    Edited once, last by Hakupapa ().

  • Hallo Hakupapa,



    Dein Tipp mit

    Code
    GPIO.SetWarning(false)


    funktioniert aber leider nicht.


    Da rächt es sich, wenn man nicht in Python programmiert.


    Die Funktion heißt korrekt

    Code
    gpio.setwarnings(false)


    Die passende Position: Vor oder nach der Zeile mit gpio.setmode().


    Hast Du damit mehr Erfolg?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo Hakupapa,


    so?

    Code
    gpio.setwarnings(False)

    (mit einem großen F am Bande)? So erzählt's die Fehlermeldung weiter oben... Wer lesen und sich's merken kann, ist klar im Vorteil...


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.