PI als TVHeadend Server -> Probleme mit HD Sendern

  • Hallo Leute,
    ich habe eine Frage an die die Leute die den Raspberry als TV-Headend "Server" verwenden. Ich hab ein kleines Problem, wenn ich das Programm Live abrufe, egal ob mit Kodi oder VLC, es kommt zu starker Pixelbildung, und keine Ahnung warum (nach ein paar Minuten).


    So sieht es bei mir gerade aus:


    DVB Karte: DvbSky S960 USB 2.0 Version 1
    PI: Version 3 mit [font="Tahoma, Helvetica"]Raspbian GNU/Linux 8 (jessie)[/font]
    Netzwerk: 100mbit an 100mbit Switch (Fritzbox)
    TV-Headend-Version: 4.08 -jessie


    So das Problem habe ich nur wenn ich mit einem Client (Windows Desktop PC oder Notebook) über Kodi oder VLC zugreiffe, leider auch mit Android und VLC -> Nur bei HD Streams (also z.B.: ZDF HD), SD geht ganz gut!
    Nehme ich das Programm aber auf meine NAS auf und rufe es später von der NAS ab, sind keine Darstellungsprobleme vorhanden, außer ich Spule vor, dann kommen sie auch. Bei normaler Geschwindigkeit aber nicht.
    Als Streamprofil ist Matroska als Standard eingestellt.


    Wie sind eure Erfahrungen mit dem Pi 2,3 und TVHeadend? Habt ihr die Einstellungen irgendwie angepasst?
    Anderer Version von TVHeadend?
    Netzwerk anders Konfigurieren? Switch statt Fritzbox? USB EthernetKarte an den Raspberry? Oder Netzwerkeinstellungen des Pi´s? Stehen derweil auf Standard -> Einfach eth0 mit eingeschaltetem DHCP.


    Oder wenn alles nichts hilft, habt ihr eine stromsparende Alternative zum PI? Worauf Debian und TVHeadend laufen würde? Oder vielleicht verwendet ja jemand eine Alternative? Auch wenn ich den Pi sehr gern mag, aber der würde auch einen anderen Anwendungszweck bekommen.


    Wäre cool wenn ihr einen Tipp oder Tipp´s für mich habt.

    Edited once, last by Anukad ().

  • Bei mir läuft tvheadend super mit genau der gleichen TV Karte. (Auch HD Sender)


    Eine USB Netzwerkkarte macht keinen Sinn weil die interne Netzwerkkarte ja auch über USB angeschlossen ist -> gleiche Geschwindigkeit.
    Kompilier doch Mal tvh selbst (ich nehme an du hast die Version aus dem packetquellen) Anleitungen gibts zB hier im forum


    Ich habe es Mal aufgeschrieben was ich bei mir gemacht hab

    External Content gist.github.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Hab Version 4.1-2187


    Vielleicht liegt es aber auch an zu schwachem Netzteil, zu wenig RAM an GPU etc pp

  • Wie sieht es denn auf der Client Seite aus? Mein Handy mit WLAN schafft HD auch nur bedingt, der PC aber hat keinerlei Artefakte bei der Darstellung

    Edited once, last by Sirel ().


  • Vielen Dank, für die Hilfe. Alles erledigt, GPU hat jetzt 256MB zugewiesen, Netzteil ist bereits ein 2,5 Amper und die neuste TVHeadend Version wurde auch installiert. Danke für deine Anleitung diesbezüglich, leider habe ich es damit nicht geschafft bekam kompelieren mehrere Fehlermeldungen, hab aber ein fertiges Paket gefunden im Netz mit der aktuellsten Version für den Pi.



    Wie sieht es denn auf der Client Seite aus? Mein Handy mit WLAN schafft HD auch nur bedingt, der PC aber hat keinerlei Artefakte bei der Darstellung


    Witzigerweise nach dem update von TV-Headend läuft es nun um einiges besser, nur noch wenige ausfälle am PC und gar keine mehr auf meinem Smartphone.
    Ich werde nun den Pi etwas anders in mein Netzwerk integrieren. Vermute mal das die Fritzbox nicht gerade einen sauberen Datenstrom schafft (werden immer schlechter diese Teile). Hab aber noch nen Managad Switch irgendwo rumeinern. Werde das die nächsten Tage probieren.


    Zu den Desktops Clients, sind beides Windows Maschienen beide mit Windows 7 Prof der Dekstop-Pc hat ne ATI R7 Grafikarte und einen AMD 4 Kernprozessor mit 3,2 Ghz. und das Notebook ist ein Acer mit Windows 7 Prof und einem Intel i5 und einer 2GB Ati Karte (Model habe ich gerade nicht im Kopf).


    Danke für die Hilfe Leute

  • Mich würde auch so ein fertiges Paket von TvHeaend für Raspi 3 interesiert. Wo hast Du es gefunden?
    Gruß


    Gesendet von meinem GT-P5110 mit Tapatalk

  • Also, beim Kompilieren gibt es Probleme mit ffmpeg.
    Dieses kann man aber ausschalten.

    Code
    ./configure --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libexecdir=${prefix}/lib/tvheadend --disable-maintainer-mode --disable-dependency-tracking --disable-ffmpeg_static --enable-hdhomerun_static  --enable-bundle


    Man braucht u.U. noch weitere Abhängkeiten zum Kompilieren
    Hier gibt es Version 4.09: https://dl.bintray.com/djbenson/deb/pool/stable/
    (Edit 2: Link hat ned passt)

    Edited once, last by Phaurevu ().


  • Mich würde auch so ein fertiges Paket von TvHeaend für Raspi 3 interesiert. Wo hast Du es gefunden?
    Gruß


    Gesendet von meinem GT-P5110 mit Tapatalk


    Ich hab diese verwendet:
    **LINK ENTFERNT**


    Die Anleitung hatte ich direkt aus dem TV Headend Forum. Hab leider den Link nicht mehr, werde aber suchen und falls ich finde hier posten. (Natürlich vorher die Regeln lesen ob das überhaupt darf....bin mir nicht mal bei dem oberen Eintrag sicher, falls nein, sorry und bitte entfernen (an die MODS und Admin) oder mir sagen und ich tue es weg.


    SOrry wollte den Link dan doch nicht posten, da ich die Regeln noch nicht gelesen habe. Aber füttert Tante Google einfach mit folgen Worten: [Unofficial] Raspberry Pi / armhf builds erster Link TVHeadend Forum und lesen :)

    Edited once, last by Anukad ().

  • Nur mal zur Info: Bei mir läuft ein rpi1 mit 512Mb Ram und 900 Mhz und 20€ Dvbt-stick als tvheadendserver (4.2). Funktioniert auch bei Dvbt2 (hevc) einwandfrei im Livestream. Probleme machen eher dir hevc-unfähigen Clients.
    Auf dem Linux Subnotebook (Asus x200) läufts nur mit mplayer rund. vlc zickt.
    Auf ner billigen Android-tv-box mit S905x-chip läuft es auch nicht rund bei Verwendung der Hersteller Firmware. Selbe Box mit Libreelec läuft astrein als client.


    Wenn die Aufnahmen fehlerfrei sind würde ich nur bei den Clients suchen.


  • Wo wird in Raspi 3 GPU -Zuweisung zb. 256 gemacht?


    Gruß


    Ich hatte schon gefunden


    Ganz einfach mit:
    1. sudo raspi-config
    2. advanced options
    3. Memory Split


    hier sollten 64 MB eingstellt sein. Etwas wenig für HD.


    Grundsätzlich ist mein Problem noch nicht ganz verschwunden, scheint wirklich mit den Clients zusammenhängen Kodi funkt besser als VLC unter Windows . Aber eine Verbesserung ist auf jedenfall eingetreten vorher konnte ich keine 2 Minuten gucken ohne Darstellungsfehler (Starke Pixelbildung) nun geht es auch mal gleich 2 Stunden gut ohne Fehler. Bin wirklich zufrieden bis jetzt. Ein paar Kleinigkeiten noch aber da komm ich auch noch drauf.
    Werde meine Lösungen natürlich weiter hier posten.


    LG