Stromversorgung WS2801

  • Hallo zusammen.


    Ich verfolge hier schon seit längerer Zeit einige Themen und Tutorials und habe auch schon das eine oder andere umgesetzt.


    Jetzt benötige ich einen kleinen Rat.


    Ich bin gerade mit unserem Neubau zugange.


    Wir haben hier eine gegossene Betontreppe (16 Stufen). Auf die Stufen werden noch Granitplatten verlegt, unter die dann LED-Stripes (WS2801) angebracht werden.
    Ich komme auf eine Gesamtzahl von ca. 450 LED. Ich habe mir dafür schon ein ausreichend starkes Netzteil rausgesucht (5V / 40A).


    Da ich noch eine RPi über habe, möchte ich die Stripes auch damit steuern können.
    Hierfür muss die CLK- und DATA-Leitungen der Stripes ja hintereinander geschaltet werden, so kenne ich das zumindest von meinem Ambilight. Die Spannungsversorgung habe ich beim Ambilight auch nur am Anfang angeklemmt und es passt auch ganz gut, sind aber auch nur knapp 90 LEDs.



    Wie regele ich jetzt die Spannungsversorgung bei 450LEDs ?
    1. Reicht es, wenn ich das NT am ersten Stripe anschließe?
    2. Muss ich das NT nochmal am Ende vom letzten Stripe anschließen?
    3. Oder sollte ich jeden Stripe einzeln an das NT anschließen?



    Beste Grüße und vielen Dank schon mal im Voraus!!
    Paul


  • Wie regele ich jetzt die Spannungsversorgung bei 450LEDs ?
    1. Reicht es, wenn ich das NT am ersten Stripe anschließe?
    2. Muss ich das NT nochmal am Ende vom letzten Stripe anschließen?
    3. Oder sollte ich jeden Stripe einzeln an das NT anschließen?


    1. Das wird dir definitiv nicht reichen. Die Leiterbahnen sind vermutlich auch nicht auf so viel Strom ausgelegt.
    2. Je öfter du die Stripes einspeiste desto besser ist es. (Ich habe bei meinem Ambilight bei einem 4 Meter Stripe, 4 mal eingespeist)
    3. Wenn du die Möglichkeit hast, dass du jede Treppe oder vielleicht jede 2 Treppe an das NT anschließt ist es sicherlich besser, als wenn du nur am Anfang und am Ende einspeist.

  • Dem schließe ich mich an. Die beste Lösung wird sein, jede Treppenstufe mindestens einmal anzuklemmen. Ansonsten könnte es passieren, dass die ersten LED heller leuchten als die letzten LED einer Kette.
    Ein zweites Problem könnte die Ansteuerung mit dem RasPi werden. Wie groß ist die Entfernung des RasPi zur LED Stripe?

  • 1. Das wird dir definitiv nicht reichen. Die Leiterbahnen sind vermutlich auch nicht auf so viel Strom ausgelegt.
    2. Je öfter du die Stripes einspeiste desto besser ist es. (Ich habe bei meinem Ambilight bei einem 4 Meter Stripe, 4 mal eingespeist)
    3. Wenn du die Möglichkeit hast, dass du jede Treppe oder vielleicht jede 2 Treppe an das NT anschließt ist es sicherlich besser, als wenn du nur am Anfang und am Ende einspeist.



    Das habe ich mir schon fast gedacht.
    Automatisch zusammengefügt:[hr]


    Dem schließe ich mich an. Die beste Lösung wird sein, jede Treppenstufe mindestens einmal anzuklemmen. Ansonsten könnte es passieren, dass die ersten LED heller leuchten als die letzten LED einer Kette.
    Ein zweites Problem könnte die Ansteuerung mit dem RasPi werden. Wie groß ist die Entfernung des RasPi zur LED Stripe?


    Vom RPi zum ersten Stripe werden es wohl 100cm sein.
    Automatisch zusammengefügt:[hr]
    Welche Frage mir sich jetzt noch stellt, ist der Anschluss vom Netzteil selber.
    Muss die Steckdose hier dann auch mit 40A abgesichert sein?

    Edited once, last by kane88 ().

  • Bei 100cm könntest Du ein Problem mit dem Signal bekommen. Das ließe sich dann zum Beispiel so lösen: http://www.forum-raspberrypi.d…uf-5v-z-b-raspi-zu-ws2801


    Zu Deiner Frage: Lies sie noch mal durch und denk mal drüber nach. Du kommst sicherlich selber auf die Antwort.
    Kleiner Tip:
    Eine normale Steckdose ist mit 16A abgesichert. Bei 230V macht das 230Vx16A = ?W
    Dein Netzteil hat welche Daten?


  • Ich wollte die Frage gerade zurückziehen, aber trotzdem danke.


    Reicht denn so eine Platine für alle Stripes?

  • Die GPIO des RasPi geben 3,3V aus. Deine LED-Kette erwartet ein 5V Signal. Auf kurze Distanz funktioniert es manchmal noch, aber spätestens bei größeren Distanzen gibt es Probleme mit dem Signal. Die verlinkte Lösung macht im Grunde nichts anderes, als das Signal von 3,3V auf 5V anzuheben. Rein theoretisch kann es natürlich sein, dass auf Grund der Gesamtlänge Deiner Konstruktion das Signal irgendwann wieder so weit abgeschwächt ist, dass es erneut angehoben werden muss. Aber auch das wäre kein Problem, sofern man an die Leitungen kommt.


  • Die GPIO des RasPi geben 3,3V aus. Deine LED-Kette erwartet ein 5V Signal. Auf kurze Distanz funktioniert es manchmal noch, aber spätestens bei größeren Distanzen gibt es Probleme mit dem Signal. Die verlinkte Lösung macht im Grunde nichts anderes, als das Signal von 3,3V auf 5V anzuheben. Rein theoretisch kann es natürlich sein, dass auf Grund der Gesamtlänge Deiner Konstruktion das Signal irgendwann wieder so weit abgeschwächt ist, dass es erneut angehoben werden muss. Aber auch das wäre kein Problem, sofern man an die Leitungen kommt.


    Die Aufgabe der Platine habe ich soweit verstanden.
    Sehe ich das dann richtig, dass ich für jede Anhebung eine weitere Platine benötige oder kann ich mit der v2 mehrere Einspeispunkte versorgen?

    Edited once, last by kane88 ().


  • Sollte die Spannung des Signals auf Grund der Leitungslänge wieder so weit abfallen, dass es Probleme gibt, dann musst Du den Pegel wieder anheben. Dazu benötigst Du dann jeweils eine Platine. Die Platinchen sind mit ca. 15x25mm aber überschaubar in ihren Ausmaßen.


    Gibt es denn Erfahrungswerte, nach welcher Länge die Spannung stark abfällt?


    Ich werde für die Verbindung zwischen den Stripes jeweils noch mindestens 1m Kabel benötigen.
    Wenn ich die Gesamtlänge zusammenrechne, dann komme ich auf über 32m, mit Reserven wohl auch auf 35m.
    Dann wäre es doch empfehlenswert, wenn ich nach jedem Stripe(ca. 2m inklusive Kabel) eine Pegelanhebung einsetze?

  • Deine Frage lässt sich so pauschal nicht beantworten. Es ist abhängig von Leitungswiderstand, der sich unter anderem aus Länge, Materialleitfähigkeit und Querschnitt zusammen setzt. Tendenziell ist es umso besser, je größer der Querschnitt des (Kupfer)Kabels ist. 35m ist natürlich schon eine ziemliche Hausnummer. Aber nach jeder Stufe eine Pegelanpassung vorzunehmen halte ich für übertrieben. Probier es doch erst mal mit einer Anhebung. Ab einer bestimmten Kabellänge werden die LEDs dann nicht mehr das tun, was sie sollen. Dann hast Du Deine maximale Länge ermittelt. Diese Länge abzüglich einer Reserve von x m kannst Du dann als Hausnummer nutzen.


    Bei meiner Aussage gehe ich davon aus, dass das Protokoll nur gesendet wird und keine Daten zurück zum RasPi gehen.

  • Wie eingangs erwähnt, habe ich bei meinem Ambilight bei 90 LEDs keine Pegelanpassung.
    Das Kabel vom RasPi zum Stripe beträgt hier auch gut 1m und danach kommen direkt alle 90 LEDs mit Verbindungsstücken an den TV-Ecken.
    Hier sieht alles ganz gut aus.


    Ich weiß nur nicht wie sich die 1m Zwischenstücke auswirken.


    Ich werde das mal später zu Hause als "Trockenübung" probieren. Ich werde mal ein paar Stripes und Kabelstücke miteinander verbinden.
    Habe bloß das große Netzteil noch nicht da, hätte aber noch eins mit 5V/10A, sollte wohl für 4 Segmente ausreichen.


    Ich berichte dann.


    Vielen Dank erstmal

  • bei meiner Wordclock24h sind 293 LEDs


    um die Ströme in den Griff zu bekommen habe ich alle 36 LEDs also 2 Stripes a 18 LEDs ein Stepdown eingebaut aus 5V


    Speisen tue ich mit einem 24V/4A SNT damit sind die Netzteilströme beherrschbar.


    Pro 2 Stripes 36 LEDs ein stepdown 1,- € ebay fest mit 43k auf 5V gestellt in die beiden Streifen, habe mehrere gebaut und die besten 8 ausgemessen auf 5V/2A


    40A ist ja kaum beherrschbar es sei denn du machst ein dickes Bündel 1,5mm² um einzelne Segmente zu speisen.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)


  • Was genau meinst du mit beherrschbar?
    Was ist denn, wenn ich vom NT zu jedem Stripe die Spannungsversorgung direkt anlege? Dann teilt sich ja die Stromstärke je angeschlossenem Kabel.
    Oder ich teile das auf mehrere Netzteile auf.
    Es kann ja ruhig hässlich aussehen, es wird alles unter der Treppe versteckt.

    Edited once, last by kane88 ().


  • Was genau meinst du mit beherrschbar?


    Spannungsabfall durch Strom!



    Was ist denn, wenn ich vom NT zu jedem Stripe die Spannungsversorgung direkt anlege? Dann teilt sich ja die Stromstärke je angeschlossenem Kabel.


    kann man machen: rechnen messen viele 1,5mm² nehmen zum Netzteil



    Oder ich teile das auf mehrere Netzteile auf.
    Es kann ja ruhig hässlich aussehen, es wird alles unter der Treppe versteckt.


    oder so die Verbindungen zum Stripe kurz, zur Netzspannung egal

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • ausrechnen, Länge, Querschnitt -> Leiterwiderstand, Strom, max. zulässiger Spannungsabfall


    was fragst du ohne Daten zu nennen?

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Hallo nochmal.


    Nach langen Abenden mit Bohren, UP-Dosen setzen und Kabel ziehen habe ich es fast geschafft.


    Ich benutze jetzt für jede 4 Stufen je ein Netzteil, machte insgesamt 4 Netzteile, die V- von den Netzteilen habe ich zusammengeschaltet.
    Jeder Stripe hat jetzt 31 LEDs, musste je um eine LED kürzen, da die Länge von den Baumaßnahmen her nicht gepasst hat.


    Die ersten 8 Stufen funktionieren ohne Probleme, bei den nächsten 4 habe ich Probleme.
    Das Signal vom Pi wird wohl nicht richtig übertragen. Ich habe zur möglichen Abhilfe auch schon die Pegelanpassung von 3,3V auf 5V an verschiedene Stellen zwischengeschaltet, leider keine Verbesserung. Wenn ich über die hyperion-remote die Farbe weiß sende, dann scheint alles gut auszusehen. Der Befehl geht wohl durch, aber bei genauem hinsehen, sieht man, dass die Leds ab Stufe 9 flackern. Besonders auffällig ist das wenn die die Befehle für rot, blau, oder grün sende. Dann flackern die LEDS in verschiedenen Farben.


    Ich habe schon öfters gelesen, dass der Pi über das selbe Netzteil betrieben werden soll, wie auch die Stripes.
    Das muss ich aber leider ausschließen, da ich die LEDs über eine Wechselschaltung an- und ausstellen möchte.
    Da würde es einfach zu lange dauern, bis der Pi hochfährt, geschweige denn dass ich durch das abrupte Abschalten das Dateisystem beschädigen könnte.


    Habt ihr noch einen Tipp für mich?


    Gruß,
    Paul