Hab ich meinen Zero gegrillt?

  • Hallo erstmal,
    hab ein wenig nachsicht mit mir bin Neu hier in dem Forum und auch im diesem Bereich (Elektrotechnik).
    Also hatte mir einen Pi Zero bestellt um damit ein wenig zu basteln und mein ein paar kentnisse anzueignen.
    Mich hatte dieses PWR Kabel rein raus gestecke genervt und da hab ich kurzerhand das Kabel via 3A ON/OFF Switsh an die GPIO Pins (2&6) geschlossen.
    Das lief auch die ganze zeit super bis ich in einem Video gesehen hatte das man die schalter an 5&6 schliessen sollte und dann die Einstellungen anpassen.
    Nun git es folgendes Problem Board schein nicht richtig anzusprechen keine der LED´s leuchtet auf, das einzige signal das noch durchkommt ist für den angeschlossenen HUB
    bei diesem leuten die LEDs weiter.


    Also hab ich meinen Zero jetzt gegrillt und wenn ja kan man das irgendwie beheben??
    :wallbash:

    Edited once, last by Scrabble ().

  • ist der zero gegrillt neu kaufen, ist es "nur" das Dateisystem der SD Karte, neu aufspielen und viel über den PI lernen vor dem basteln.

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • jar: erst lesen.



    Mich hatte dieses PWR Kabel rein raus gestecke genervt und da hab ich kurzerhand das Kabel via 3A ON/OFF Switsh an die GPIO Pins (1&5) geschlossen.


    Das lief auch die ganze zeit super bis ich in einem Video gesehen hatte das man die schalter an 5&6 schliessen sollte und dann die Einstellungen anpassen.


    In dem Video ging es vermutlich um was anderes. Welches Video war das?
    Merke: Nicht einfach blind irgendwas nach machen.


    Pins 1 & 5 macht aber genau so wenig Sinn wie 5 & 6.
    Die GPIO und Pins sind genau durch nummeriert, es gibt nur 2 Unterscheidungen: Physikalische und BCM Interne Nummerierung.
    Die Physikalische ist unten in dem Bild die Zahl innerhalb des Kreises, also die Pin-Nummer.
    Die BCM wiederum daneben, also die GPIO-Nummer.
    Daraus lässt sich erkennen: Die Stromführenden und GND sind KEINE GPIO!


    Ausserdem ist kein GPIO 5V tolerant! Mehr als 3V3 verkraften die nicht.
    Die GPIO gehen direkt und ungebuffert zur CPU.


    Jagst du mehr als 3V3 auf einen GPIO ist der Pi definitiv geschrottet.

  • Servus,
    sorry ... aber das ist Käse, was Du da geschrieben hast:


    Das lief auch die ganze zeit super bis ich in einem Video gesehen hatte das man die schalter an 5&6 schliessen sollte und dann die Einstellungen anpassen.
    ...


    wieso sollte der nicht mehr laufen, nur weil Du ein Video angechaut hast? :s
    Was hast Du jetzt genau wann und wie wo angeschlossen?


    cu,
    -ds-


  • jar: erst lesen.


    danke gerne zurück,


    Pin2 +5V & Pin6 GND am GPIO, wenn er dort unterbricht wird er wohl das Dateisystem geschrottet haben, hat er bei Anschliessen andere Pins erwischt wird er den PI geschrottet haben, auch für dich gilt erst lesen dann mich anmotzen, das kannst du dir wohl auch nie abgewöhnen!

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Hatte als ich das gepostet hab Seitenvertauscht gezählt und deswegen verbessert also war 2&6 vorher als es noch lief
    Naja gut jetzt bin ich ein paar Euro ärmer und vielleicht etwas schlauer R.I.P. Zero =(

    Edited once, last by Scrabble ().

  • Hi Dreamshader,



    Servus,
    sorry ... aber das ist Käse, was Du da geschrieben hast:


    wieso sollte der nicht mehr laufen, nur weil Du ein Video angechaut hast? :s


    :thumbs1: Ursache und Wirkung ... super getrennt!


    Die Frage, wass Scrabble jetzt wirklich gemacht und nicht nur angedeutet hat, interessiert mich jetzt auch - und seine Antwort wird zur Lösung führen.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Ich übersetz euch dann mal Beitrag#1...


    Erster Satz der interessiert:

    Mich hatte dieses PWR Kabel rein raus gestecke genervt und da hab ich kurzerhand das Kabel via 3A ON/OFF Switsh an die GPIO Pins (2&6) geschlossen.


    Zweiter Satz:

    Das lief auch die ganze zeit super bis ich in einem Video gesehen hatte das man die schalter an 5&6 schliessen sollte und dann die Einstellungen anpassen.


    "Einstellung angepassen" ist eine unglückliche Wortwahl - sagt aber vermutlich aus das er das übernommen hat.


    Seine Verbesserung dazu:

    Hatte als ich das gepostet hab Seitenvertauscht gezählt und deswegen verbessert also war 2&6 vorher als es noch lief


    Was er also gemacht hat ist: Den Anschluss des PWR Kabels verändert.
    Vorher lief es noch, weil es da korrekt war: 5V und GND


    Welche Pin# er jetzt hat weiß ich auch nicht - zuvor hat er sich verzählt jetzt vielleicht auch? Welches Video sagte er ebenfalls noch nicht.... Wenn es aber jetzt einfach nur von dem einen 5V auf den andern 5V gewechselt wurde, stellt sich die Frage:
    Welchen Unterschied macht das?
    Funktioniert es über die alte Belegung auch nicht mehr?


    Berechtigter Einwand von jar: Wurde der Pi ordnungsgemäß heruntergefahren oder einfach so getrennt? Wenn letztes könnte einfach nur das Dateisystem der SD beschädigt sein - das stumpfe abschalten der Stromzufuhr verursacht sowas bei jedem Computer, nicht nur dem Pi.

  • Hm ... ich sollte mir jetzt auf den Schlips getreten fühlen ... ok, tue ich jetzt hiermit :fies:


    Ich übersetz euch dann mal Beitrag#1...


    Stell uns nicht für dumm hin ... lesen können wir selber und auf Deine Übersetzung ist hier deshalb niemand angewiesen ... :fies:



    ....
    Zweiter Satz:


    "Einstellung angepassen" ist eine unglückliche Wortwahl - sagt aber vermutlich aus das er das übernommen hat.


    zumal Deine "Übersetzung" offensichtlich auch nur eine vage Vermutung ist und nachher wohl auch niemand schlauer ist wie vorher :fies:


    Inwieweit bzw. wie ernst das jetzt gemeint war, lasse ich jetzt mal offen ...


    cu,
    -ds-

  • So wieder da also meigrafd hat es soweit richtig Rekonstruiert


    Das Video das der auslöser zu meinen Zweifeln der anordnung der Kabel war
    Recalbox Power Switch


    Danach habe ich das Posetive kabel an Pin 5 angeschlossen hatte aber übersehen das der Strom noch lief

  • Da du davon sprichst, dass doch das ständig PWR rein raus gestecke genervt hat, handelt es sich also nicht wirklich nur um einen Taster sondern eben dem Kabel vom Netzteil - oder?


    Du möchtest POWER über die GPIO Leiste einspeisen.
    Der Typ im Video will aber einen SWITCH verwenden... Das sind 2 verschiedene Sachen. Der Typ im Video verwendet einen Taster über Pin#5 (GPIO#3) und Pin#6 (GND). Dazu richtet er noch ein Script ein um damit arbeiten zu können.



    @ds: Nein das war kein Ernst