5V Schock

  • Nachtrag..


    nach weiteren Tests, über längere Zeit zeigt sich, das beide Headsets mit der Weile immer mehr Strom zu ziehen scheinen.
    Wie weit das geht weiß ich nicht, die pi's laufen ohne Headsets stehst mit roter LED .


    danke

  • Fehlerketten Verarbeitung.


    Im weiteren habe ich festgestellt, das auch mit anderen USB -Geräten das Syntom der blinkenden roten LED
    aufkommt, die einfachste lösung könnte sein ein USB-Hub mit 5V aus dem zweiten Accuport.


    Aber es kam günstiger, man installiert den Prozessmonitor :


    https://jeffskinnerbox.wordpre…nky-for-the-raspberry-pi/


    sudo apt-get install conky-all


    und ich sehe das der eine Raspery ständig in den 1200Ghz Bereich wechselt 2xsekunde
    und der andere immer bei 600Mhz steht.


    Ich habe das erste Image nun auf die zweite SD-Karte kopiert , und das Problem der flackernden roten LED kam
    nie wieder und die CPU läuft durchgehend mit 600.

  • Hallo,


    wenn ich den Raspi über Batteriebetrieb laufen lassen müsste, würde ich einen normalen 12 V Akku nehmen. Bei Ebay gibt es Spannungsegler mit einem LM2596S, wo man die Spannung über ein Poti mit Feineinstellung exakt enstellen kann, für 1 € . Die geben bis 3 A sehr stabile Spannung ab. Und weil die Eingangsspannung bis über 30 V steigen kann, ohne das sich die Ausgangsspannung ändert, kann man jeder Zeit ein Ladegerät anhängen.


    Das ist mit Sicherheit preiswerter und stabiler.


  • Hallo,


    wenn ich den Raspi über Batteriebetrieb laufen lassen müsste, würde ich einen normalen 12 V Akku nehmen. Bei Ebay gibt es Spannungsegler mit einem LM2596S, wo man die Spannung über ein Poti mit Feineinstellung exakt enstellen kann, für 1 € . Die geben bis 3 A sehr stabile Spannung ab. Und weil die Eingangsspannung bis über 30 V steigen kann, ohne das sich die Ausgangsspannung ändert, kann man jeder Zeit ein Ladegerät anhängen.


    Das ist mit Sicherheit preiswerter und stabiler.


    Hallo,


    also der Betrieb mit einem gepulsten Akku der 5V liefert via USB erzeugt Probleme wenn die CPU hochfahren möchte beim PI3
    ist die Grundfrequenz 600Mhz wenn die CPU resourcen braucht, steigt der Stromverbrauch und sie darf bis 1200Mhz hochfahren.


    Beim PI 3 wurde das rumfingern in der Overclocking ausgeblendet.


    Lösung mit der gepulsten Akku Katastrophe ist es, selber die Config für die Maximale Hochfahr-Frequenz zu setzen. Und zwar genau auf die Frequenz
    die immer Standard sein sollt 600Mhz


    Dazu : sudo leafpad /boot/config.txt


    #uncomment to overclock the arm. 700 MHz is the default.
    arm_freq=600


    Eintrag auf 600 und die CPU versucht es nicht mehr hochzuziehen auf 1200 oder auch nur 700 schon das verursacht ein Energieversorgungsproblem
    mit der gepulsten USB-5v-Akku-Spannung. Der ganze Baustein kommt in einen desolaten Zustand, und die Power LED rot zündet sporadisch.


    Soundausgaben oder geregelte Datenströme sind dann nicht mehr gesichert.
    Es gibt keinen Grund den PI mit bis zu 1200 laufen zu lassen am Akku, der Gewinn gegenüber der Abwärme ist gering, liegt bei 10-20%


    Die Störungen beim Hochfahren der CPU von der Grundfreunz 600Mhz erzeugt im externen USB Audiosystem Störgeräche, bis soweit das
    die Linux-System Audiosoftware ALSA den Kontakt zum Device verliert, oder in einem bis zum Reset feststehen Zustand verkommt.
    All das kann also im Akku-Not-Betrieb verhindert werden, und so laufen die PI's auch recht lange, denn sie ziehen immer nur rund 400mA.


    Grüsschen
    Karsten

    Edited once, last by Achromat ().

  • Du hast mich erneut davon überzeugt das es Dir an Erfahrung und Wissen mangelt...


    Wenn du denn nur ein einziges mal eine Spannungsstabilisierung ausprobieren würdest, solltest auch Du bemerken das all deine "Berichte" plötzlich hinfällig sind und nicht mehr beachtet werden müssten.


    Wie dreamshader bereits anmerkte, umgehst du die ganze Zeit die Symptome und machst ein riesen Fass auf, obwohl es doch eigentlich so einfach wäre .... Ganz nach dem Motte "Warum einfach wenns auch kompliziert geht"



    Aber du scheinst wirklich Beratungsresistent zu sein...


    In sofern macht es sowieso kein Sinn mehr deinem Thread weiter zu folgen, warum auch immer du hier "Berichte" einstellst....
    Nur schade um das Geld deines Kunden.


    In diesem Sinne: Noch viel Vergnügen



    just my 2 cents


  • Du hast mich erneut davon überzeugt das es Dir an Erfahrung und Wissen mangelt...


    Ich brauche keine weiteren Regler und keine weiteren Teile eine geniale Lösung
    übrigens glauben ist das Gegenteil von Wissen. (Das muss man sich nämlich erarbeiten)

    Edited once, last by Achromat ().

  • Na ich tippe mal auf den Forumsclown, gibt es überall. Basiert auf ein Aufmerksamkeitsdefizit das ist behandelbar wie alle technischen Probleme.
    Ich kann den Thread nur empfehlen zeigt er wie nach und nach Problemketten sich vertiefen lassen bis hin zum Syndrom.
    feine Grüße
    aus Berlin
    Karsten

    Edited once, last by Achromat ().

  • Es scheint als würdest Du zum Mittel der Beleidigung greifen sobald dir vernünftige Argumente ausgehen .... Und Du scheinst da auch noch stolz drauf zu sein. :thumbs1:



    Man nehme sich einen 7.2V Akkupack wie er im Modellbaubereich üblich ist, sucht sich einen StepDown auf 5V mit für sein Vorhaben ausreichende Ampere, schließe den direkt an den Akku an, packt noch ein paar Kondensatoren und Spulen zur Entstörung/Glättung dazu - fertig. Keinerlei Probleme von wegen cpu scaling governor oder irgendwelcher USB Geräten etcpp..

  • Du hast ja gar nicht verstanden um was es geht ! Sicher kann man alles kaufen. Es geht so aber auch. Das ist wunderbar, denn der Akku
    muss auch anderen Spezifikationen genügen !


    Du bist einfach sehr unzufrieden mit Dir selber.

  • Du glaubst also, durch die Reduzierung der max. Taktfrequenz der CPU dein Stromversorgungsproblem zu lösen.
    Das nennt man Symptombehandlung - der techn. saubere Weg ist die Ursachenbehandlung.


    Aber wenn dein Kunde mit dieser Frickellösung zufrieden ist... ich zumindest könnte meinen Kunden da nicht mehr ohne Spiegelbrille ins Auge sehen...


    Bin dann auch raus, schade um die Zeit... - der Rest ist dir ja schon geschrieben worden.

  • Du der Akku muss ein USB Lade Akku sein mit 5V , dies ist die spec. Es ist rein technischer Aspekt alles läuft wunderbar stabil


    Und jetzt :


    Wenn man den Raspberry dadurch neu startest, indem man nach dem runterfahren den USB Stecker aus der AkkuBank zieht, ohne diese durch den Druckschalter abgestellt zu haben (Down time push),
    wird die Akkubank beim nächsten wieder einstecken des Pi's diesen mit weniger Strom versorgen. Es wurde die Spannungsbegrenzung aktiviert, über den Controller des Akkus.


    Der Akku muss also heruntergefahren werden um spannungslos zu sein, dieser enthält auch eine lade -Id für das Ladegerät.


    Ok dann werde ich mal lieber nichts mehr zu diesem Thema schreiben, für mich war es Bericht über eine lange Fehlerkette, und im Ernst ich hätte sie auch alleine aufgelößt,
    schade das keiner daran nutzen finden kann.


    bis bald

  • Nachtrag Sparmaßnamen erweitert.


    Nach der Festsetzung auf 600Mhz liefen die Systeme störungsfrei, jedoch nach 20 Stunden Dauerbetrieb ist der Akku nicht mehr
    der schärfste.


    Das Blinken war wieder da. Nun konnte durch abschalten des Bluetooth und des HDMI weiter Leistung reduziert/gespart werden,
    so das es nun bis zum ende des Akkus ausreicht.


    sudo nano /etc/modules
    # ic2 markiren ausmarkieren schaltet den Header ab ggf. hier auch noch andere Hardware enthalten


    Spannungsfrei schaltbar ist auch die interne Soundhardware
    In der letzten Zeile der Pixel distribution:
    sudo nano /boot/config.txt
    unten BCM hardware abschalten on durch off ersetzen.


    Seither rödeln de Pi's ungeblinkt. Sogar das erlauben auf 1200 zu kommen funktioniert dann wieder.
    Eine kleine Vox-Steuerung das nur gesendet wird wenn genug Amplitude da ist, spart Unmengen Strom
    der Pi hat an das W-Lan viel Strom zu geben..


    Grüße
    Karsten


  • Also der Raspberry pi3 braucht soweit ich weis nur 2,5 A mehr nicht und nicht 20. Hast ihn anscheinend weggebrannt. D:


  • _Bamba_: Bitte was?


    der Kollege spielt doch nur auf den Eröffnungsbeitrag an:



    ....gleich zwei Raspis und zwei riesen 20A 5V Akkus besorgt.


    nix von Ah zu lesen :)

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().