Richtiger Anschluss für Funksender und -empfänger

  • Hallo,


    ich habe Erfahrung mit Programmierung, im Bereich Elektrotechnik und Hardware würde ich mich aber nicht einmal als Anfänger bezeichnen.


    Derzeit versuche ich einfache Experimente mit einem Funksender und einem Funkempfänger. Meine Hauptquellen waren https://tutorials-raspberrypi.…unk-kommunizieren-lassen/ und https://www.einplatinencompute…z-funksteckdose-schalten/. Das sah gar nicht so schwer aus.


    Leider bekomme ich vom Funkempfänger keine Ausgabe mit WiringPi. Weder wenn ich mit WiringPi etwas sende noch wenn ich es mit einem 433Mhz Handsender für unsere Rollläden probiere. Deshalb zweifle ich bereits an meiner Verdrahtung (siehe Anhang). Ich hab leider kaum Ahnung, wie man so ein Steckbrett verwendet und bin durch Recherche nur wenig schlauer geworden.


    Es handelt sich um einen Raspberry Pi 3B.


    Vielen Dank für eure Hilfe!


  • Hi,
    bin auch noch absoluter Newbie in RasPi Basteldingen und habe gestern und heute die gleiche Anleitung verwendet. Erst ein Tutorial von video2brain, was aber nicht funktionierte, dann dieses
    https://tutorials-raspberrypi.…unk-kommunizieren-lassen/
    und gerade eben hatte ich vollen Erfolg.
    Ich denke, wenn du das Empfängermodul über die Strippen (Jumperkabel) direkt auf das GPIO steckst, fährst du besser, als über ein Breadboard. +5V und GND sind einfach und bei meinem Pi2 bin ich mit dem Datenpin (Empfänger 2ter von links, neben +5V) auf Pin 13 (PiB Rev1.0/GPIO21) gegangen. 17cm Litze oder Draht als Antenne angelötet und nach Anleitung installiert. Funktioniert bei mir. Verwende Pixel Lite.
    Achte mal auf Schreibfehler. Das passiert mir oft, dass ich mich vertippe, oder was weglasse. Dann kommen die tollsten Fehler raus, oder es tut sich gar nichts.


    Was ich auch bemerkt habe, RFSniffer oder der Pi sendet über mein PC mit Putty verzögert bzw. manchmal nichts. Über den Pi direkt, habe ich sofort eine Anzeige meiner Baumarkt Schaltdosen.


    Ich weiß nicht ob ich dir helfen konnte, aber immer weiter probieren. Manchmal sind es dumme Fehler die man macht. Wenn du noch andere Empfänger hast, probiere einen anderen aus.


    Grüße Jürgen


  • Ich habe leider keine Female-Female Jumperkabel. Nach mehrmaliger Kontrolle über den Befehl "gpio readall" bin ich mir ziemlich sicher, alles richtig verkabelt zu haben, trotz Steckbrett. Ich bekomme aber weder mit RFSniffer noch mit pigpio eine Ausgabe vom Empfänger. "watch -n1 gpio readall" zeigt auch keine Statusänderungen am Empfänger-PIN an. Gibt es irgendeine Methode herauszufinden, ob der Empfänger funktioniert bzw. richtig verkabelt ist?


    Kann ich den Empfänger vielleicht "simulieren", indem ich irgendwie ein Signal am Empfänger-PIN erzeuge?