WLAN zu WLAN durchreichen

  • Hallo zusammen,


    ich habe folgendes Setup:


    • Raspberry Pi 3. Generation
    • 32GB microSD-Karte
    • Raspbian von heute
    • 2x Edimax EW-7811Un (150Mbit/s)


    Ich möchte folgendes erreichen:


    • ein Edimax soll sich zu einem WLAN verbinden
    • Traffic soll durch Tor gehen
    • zweiter Edimax soll WLAN ausstrahlen und den Traffic da wieder durch routen.


    Ich verwende diese Anleitung von raspberry.tips. Leider ist sie von eth0 auf wlan0 (also wohl das integrierte WLAN-Modul?) - das hat in deren Konstrukt auch so funktioniert. Ich würde gerne wlan1 an wlan2 durchrouten und das interne WLAN-Modul deaktivieren / nicht nutzen.



    Hat jemand eine Idee, wie ich das machen kann? Wie müsste ich die entsprechende Anleitung oben modifizieren? Ich komme leider absolut nicht weiter.


    Edimax verbindet sich nicht mit WLAN.


    Ich habe beide Edimax-Sticks an den Pi gesteckt (USB) und dann aus meiner Sicht her logisch folgendes gemacht. "wlan0" deaktiviert, "wlan1" konfiguriert und an mein WLAN angebunden, "wlan2" in die Konfiguration mit eingebunden (anhand der Daten von "wlan1"). Mein Netzwerk-Interface sieht so aus:




    Meine /etc/wpa-supplicant/wpa_supplicant.conf sieht so aus:


    Code
    country=DE
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    network={
       ssid="Milch im Gemüsefach"
       psk="geheim"
    }


    Führe ich ifconfig aus, sieht man folgendes:






    Grüße,
    Jakob
    Automatisch zusammengefügt:[hr]
    Eventuell helfen die Ausgaben noch:


    lsusb:


    Code
    Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    dmesg:


    Edited once, last by jacboy ().

  • Vllt. fehlen ein paar Parameter, versuchs doch mal so, je nach dem wie dein Router, falls vorhanden, eingestellt ist.

  • Hi,


    das hat leider nicht geholfen. Hier mal die Ausgabe von iwlist wlan1 scan, eventuell hilft das weiter?



    Scheinbar hat das Gerät ein Problem mit dem Namen meines Netzwerks. Ich habe über unser Gast-Netwzerk internetz einwandfrei eine Verbindung herstellen können.


    ifconfig



    Meine WLAN-Konfiguration (/etc/wpa_supplicant/wpa_supplicant.conf) sieht nun so aus:




    Ich versuche nun erneut, den Hotspot zu erstellen und den Traffic durchzuleiten.

  • Jetzt scheinst du ja eine IP vom Router zu bekommen.
    Sonst hätte ich darauf getippt, einfach TKIP, statt CCMP zu probieren:

    Code
    pairwise=TKIP


    Wobei ich eher den Router auf CCMP stellen würde, statt den Client auf TKIP.