PiZero W [ W-Lan Problem ! ]

  • Hallo heute habe ich meinen neuen Raspberry Pi Zero W bekommen
    Da ich schon eine Fertige karte hatte im Alten Pi Zero hab ich diese Karte in den PiZ W getan ohne W-Lan Dongle anzuschließen.... ist klar weil W-Lan Onboard....


    Problem ist wlan0 oder 1 ist nicht vorhanden laut "LSUSB" aber ich denke der hängt nicht im USB sondern woanders.....


    Problem WLAN ist nicht vorhanden, kam auf dem Pim nur mit USB wlan rein per SSH


    Wo aktiviere ich das Wlan und Bluetooth oder ist es schon aktiviert ?


    Oder muss ich wieder eine Neue SD-Karte von Null auf wieder aufbauen ?

  • Hi,


    Werden dir mit

    Code
    1. iwlist wlan0 scan


    oder

    Code
    1. iwlist wlan1 scan


    Netzwerke angezeigt?


    Wie hast du die WLAN Konfiguration vorgenommen?
    Wie sieht deine /etc/wpa_supplicant/wpa_supplicant.conf aus?


    Alternativ kannst du die Karte mit einem Kartenleser am PC öffnen und dort die /etc/wpa_supplicant/wpa_supplicant.conf aufrufen und das Netzwerk einfügen:


    Code
    1. network={
    2.    ssid="MEINWLAN"
    3.    psk="DASPASSWORT"
    4. }


    Anschließend noch in der Datei /etc/network/interfaces


    Code
    1. pre-up iw dev wlan0 set power_save off
    2. post-down iw dev wlan0 set power_save on


    Damit verhinderst du den Energiesparmodus des WLAN-Moduls.


    Gruß Kokiri
    Automatisch zusammengefügt:[hr]


    Oder muss ich wieder eine Neue SD-Karte von Null auf wieder aufbauen ?


    Ja.


    Warum sollte das nötig sein?

    Edited once, last by Kokiri ().


  • Oder muss ich wieder eine Neue SD-Karte von Null auf wieder aufbauen ?


    Ja.


    Hat das was mit den Treibern und dem Kernel zu tun?


    Wäre da nich ein Apt-get upgrade ein Hilfe ... btw läuft gerade auf dem Pi Zero w...


    Wenn das nicht geht dann muss ich ein saubers Image aufsetzen ....grrrr


    danke

    Edited once, last by brenner23 ().

  • Quote

    upgrade ist immer so ne Sache!


    Das Problem ist nur ein raspi-upgrade, ein normales update & upgrade ist sogar empfehlenswert, damit aktuelle Pakete eingespielt werden, in denen Fehler gefixt wurden und als stabil gelten, während du dir mit raspi-upgrade eine instabile Test-Version installieren kannst, mit all den Folgeproblemen.

  • Habe nun ja auch meinen Pi Zero W... auch ich bekomme kein WLAN hin. :blush:


    Bevor ihr jetzt immer die genaue Ausgabe wollt:
    Ich muss dauernd den Monitor-Stecker wechseln (pc - zero w) und das nervt gewaltig!


    Die SD-Karte war noch in keinem Raspi und enhält Raspbian (aber nicht ganz aktuell).


    Vorweg:
    Ich habe das Geek-Magain zum Thema Zero W.



    Quote

    Werden dir mit

    Code
    1. iwlist wlan0 scan


    oder

    Code
    1. iwlist wlan1 scan


    Netzwerke angezeigt?


    Nein, kommt irgendwas mit "das Intercae kann nicht gescannt werden"


    Quote

    Wie hast du die WLAN Konfiguration vorgenommen?
    Wie sieht deine /etc/wpa_supplicant/wpa_supplicant.conf aus?


    Nachdem ich in der Boot-Partiotion die Datei wpa_supplicant.config nach folgendem Schema, mit Notepad++, angelegt hatte


    Code
    1. country=DE
    2. ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    3. update_config=1
    4. network={
    5. ssid="WLAN‑NAME"
    6. psk="WLAN‑Passwort"
    7. }


    und er die Datei zwar nach etc/wpa_supplicant verschoben hatte, diese aber ohne


    Code
    1. network={
    2.   ssid="MEINWLAN"
    3.   psk="DASPASSWORT"
    4. }


    war, habe ich diese per


    Code
    1. sudo nano


    editiert und die Zeilen


    Code
    1. network={
    2.   ssid="MEINWLAN"
    3.   psk="DASPASSWORT"
    4. }


    meinem WLAN-Netz angepasst, gespeichert und per


    Code
    1. sudo cat


    mir auch nochmal das Ergebnis anzeigen lassen.


    Trotz Neustarts findet er kein Wlan.


    Kommt der Pi nicht mit WPA2 zurecht? :s


    Wo finde ich die Mac-Adresse um diese in der FritzBox 7490 hinzuzufügen?


    Ein

    Code
    1. ifconfig


    bringt mir nur ein lo.

  • Hallo HimbeerPi(e),


    von wann ist denn dein Raspbian Image? Der Pi Zero W wird erst seit dem 02.03.2017 voll unterstützt:


    Quote

    2017-03-02:
    * Updated kernel and firmware (final Pi Zero W support)
    * Wolfram Mathematica updated to version 11
    * NOOBS installs now checks for presence of 'ssh' file on the NOOBS partition.


    Um Problemen aus dem Weg zu gehen würde ich das aktuelle Raspian (vom 10.04.2017) einsetzen.

  • Danke!
    Werde also erstmal das aktuelle Image auf die Karte kopieren.


    PS: Allen noch schöne Ostern!


    Edit:
    Lag bei mir wohl tatsächlich nur am Raspian-Image.
    Läuft!