Wlan0 und eth0 (TP-Link Powerline Netzwerkadapter) gleichzeitig verwenden!

  • [font="Verdana, sans-serif"]Hallo zusammen,[/font]
    [font="Verdana, sans-serif"] [/font]
    [font="Verdana, sans-serif"]ich habe alles Mögliche probiert, aber leider ohne Erfolg.[/font]
    [font="Verdana, sans-serif"] [/font]
    [font="Verdana, sans-serif"]Ich verwende Raspberry Pi 3. Natürlich mit integriertem WLAN. Ich habe den Pi zusätzlich über LAN Kabel an einem "[/font][font="Verdana, sans-serif"]TP-Link TL-PA4010PKIT AV500 Powerline Netzwerkadapter[/font][font="Verdana, sans-serif"]" angeschlossen. Also, ich möchte beide Interfaces (Wlan0 und eth0) gleichzeitig verwenden. Mit anderen Worten: der Pi soll über zwei IP Adressen erreichbar sein. Falls WLAN wieder abbricht, möchte ich gerne den Pi über eth0 erreichen. :)[/font]
    [font="Verdana, sans-serif"] [/font]
    [font="Verdana, sans-serif"]Am Anfang habe ich wie früher die Datei /etc/network/interfaces editiert. Ich habe im Internet gelesen, dass diese Methode der Konfiguration veraltet ist. Aus diesem Grund habe ich die zwei Interfaces (Wlan0 und eth0) so konfiguriert:[/font]
    [font="Verdana, sans-serif"] [/font]
    [font="Verdana, sans-serif"]Datei /etc/dhcpcd.conf so editiert:[/font]
    [font="Verdana, sans-serif"] [/font]


    [font="Verdana, sans-serif"]interface eth0[/font]
    [font="Verdana, sans-serif"]static ip_address=192.168.1.10/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1[/font]


    [font="Verdana, sans-serif"]interface wlan0[/font]
    [font="Verdana, sans-serif"]static ip_address=192.168.1.11/24
    static routers=192.168.1.1
    static domain_na[/font]
    [font="Verdana, sans-serif"]me_servers=192.168.1.1[/font]



    [font="Verdana, sans-serif"]Der Pi ist nur dann im LAN erreichbar, wenn ich den [/font][font="Verdana, sans-serif"]TP-Link Adapter abziehe!?! Wenn ich den TP-Link Adapter anschließe, dann kann ich über Pi nicht den Router anpingen bzw. ins Internet gehen. Der Pi funktioniert nur über wlan0. [/font]


    [font="Verdana, sans-serif"]Mir reicht es auch vollkommen aus, wenn ich den Pi nur mit dem TP-Link Adapter verwende, aber es funktioniert leider nicht! Ich habe den wlan0 mit ifconfig wlan0 down ausgeschaltet. Aber der Pi will einfach nicht über TP-Link Adapter ins Internet!?! Der Befehl ifconfig zeigt aber den Adapter bzw. den eth0 an.[/font]


    [font="Verdana, sans-serif"]Was mache ich falsch?[/font]
    [font="Verdana, sans-serif"] [/font]
    [font="Verdana, sans-serif"]Vielen Dank im Voraus für die Hilfe.[/font]
    [font="Verdana, sans-serif"] [/font]
    [font="Verdana, sans-serif"] [/font]

  • [font="Verdana, sans-serif"]ich habe alles Mögliche probiert, aber leider ohne Erfolg.[/font]


    Das kommt mir bekannt vor...


    Ich hatte in einem anderen Thread hier[font="Verdana, sans-serif"] ein sehr ähnliches (wenn nicht sogar gleiches) Problem geschildert. Aber letztendlich, nach vielem Hin und Her, was soll ich sagen: Es funktioniert noch immer nicht.


    Also freue ich mich schon auf die Lösung, die dann hier zustande kommt. ;-)[/font]


    Gruß, Michael


  • Also, ich möchte beide Interfaces (Wlan0 und eth0) gleichzeitig verwenden. Mit anderen Worten: der Pi soll über zwei IP Adressen erreichbar sein. Falls WLAN wieder abbricht, möchte ich gerne den Pi über eth0 erreichen



    [font="Verdana, sans-serif"]Was mache ich falsch?[/font]


    Konfiguriere die Interfaces deines PI3 so, dass diese IP-Adressen aus unterschiedlichen Subnetzen haben.
    Das wlan0-Interfaces z. B. mit dhcpcd.conf (für den Internetzugang) und das eth0-Interface mit systemd-nerworkd (... als fallback, ohne Internetzugang und Direktverbindung ohne Router/gateway).

    The most popular websites without IPv6 in Germany.

  • Hallo Michael !


    Probiere lieber die beiden Interfaces mit < nm-connection-editor > (im Terminal aufrufen, oder Rechtsklick auf nm - Verbindungen bearbeiten). Dann werden die Eintragungen für Deine Distribution richtig vorgenommen.


    Wenn WLAN und LAN gleichzeitig (automatisch) aktiviert werden, möchte der Kernel wahrscheinlich wissen über welches Interface er Routr und DNS Server erreichen soll. Dafür gibt es eine default Direktive falls das trotz nm-connection-editor nicht klappt.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hallo rpi444,


    wie sieht so eine Konfiguration mit systemd-nerworkd für das Interface eth0 aus, damit ich den Pi trotzdem im LAN erreichen kann, falls WLAN nicht verfügbar ist?


    Danke.



    Konfiguriere die Interfaces deines PI3 so, dass diese IP-Adressen aus unterschiedlichen Subnetzen haben.
    Das wlan0-Interfaces z. B. mit dhcpcd.conf (für den Internetzugang) und das eth0-Interface mit systemd-nerworkd (... als fallback, ohne Internetzugang und Direktverbindung ohne Router/gateway).


    Automatisch zusammengefügt:[hr]
    Mein Pi (jessie) ist ohne GUI Umgebung. Ich habe den nm-connection-editor nicht gefunden.




  • wie sieht so eine Konfiguration mit systemd-nerworkd für das Interface eth0 aus, damit ich den Pi trotzdem im LAN erreichen kann, falls WLAN nicht verfügbar ist?


    Auf meinem PI3 sieht das z. B. so aus:

    Code
    #:~ $ cat /etc/systemd/network/mylan.network
    [Match]
    Name=eth0
    [Network]
    DHCP=none
    IPv4LL=false
    IPv6LL=false
    Address=192.168.177.23/24


    Code
    :~ $ systemctl status systemd-networkd
    ● systemd-networkd.service - Network Service
      Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled)
      Active: active (running) since Thu 2017-04-20 22:57:26 CEST; 9h ago
        Docs: man:systemd-networkd.service(8)
    Main PID: 697 (systemd-network)
      Status: "Processing requests..."
      CGroup: /system.slice/systemd-networkd.service
              └─697 /lib/systemd/systemd-networkd


    Code
    :~ $ route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.178.1   0.0.0.0         UG    303    0        0 wlan0
    192.168.177.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.178.0   0.0.0.0         255.255.255.0   U     303    0        0 wlan0

    The most popular websites without IPv6 in Germany.

  • Es funktioniert. :)

    eth0 über systemd-networkd und wlan0 über dhcpcd.conf. Ich habe auch probiert, ob das Ganze (eth0 und wlan0) NUR über systemd-networkd funktioniert, aber es hat nicht funktioniert. Egal, ich lasse es jetzt so.


    Ich danke Euch.

  • Das Problem bei der ganzen Sache ist die Default-Route.


    Diese wird beim verbinden auf das Interface gesetzt, das verbunden wurde.
    Kommt nun ein zweites Interface hinzu, verändert die Netzwerk-Konfiguration per DHCP auch die Default-Route. Auch wenn beide Interfaces im gleichen Subnetz hängen.


    Konfiguriert man das Netz aber fest auf dem Rechner, kann es nur eine Default-Route geben. Und wenn diese nicht da ist, kommt der Rechner auch mit einem funktionierenden Interface nicht aus dem Netz.


    Man braucht also eine Software auf dem Rechner, die regelmäßig die Funktion des Interfaces testet, und bei bedarf die Default-Route ändert.
    Bei kabelgebundenen Netzwerkinterfaces kann man die Funktion "Kabel Steckt/Port aktiv" leicht prüfen, beim WLAN geht das schlechter, da das WLAN-Kabel einen zu geringen Widerstand hat.


    Ist das Default-Interface ein WLAN-Interface, kann man das nur prüfen, in dem man z.B. regelmäßig die Erreichbarkeit eines Systems im Netz (Access-Point, ...) testet.
    Es wird dann aber immer noch eine gewisse Zeit vergehen, bis das Script die Route umstellt.

    Selber denken,
    wie kann man nur?


  • Konfiguriert man das Netz aber fest auf dem Rechner, kann es nur eine Default-Route geben. Und wenn diese nicht da ist, kommt der Rechner auch mit einem funktionierenden Interface nicht aus dem Netz.


    Was meist Du mit "kommt der Rechner auch mit einem funktionierenden Interface nicht aus dem Netz."?


    Für das Interface (hier eth0) mit dem eine Direktverbindung zwischen PI3 und einem anderen Rechner hergestellt wird, wird eine Default-Route nicht benötigt. Deshalb auch "DHCP=none" in der *.network-Datei.

    The most popular websites without IPv6 in Germany.

  • Das gibt es doch nicht! Jetzt ist auf einmal der Pi nicht mehr im LAN erreichbar! Ich habe den Pi rebootet. Aber es geht immer noch nicht! Ich kann den Router nicht anpingen.


    Die Routing-Tabelle sieht seltsam aus!?! Die erste und die zweite Zeile sehen doch außer Metric identisch aus oder?


    route -n


    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
    0.0.0.0 192.168.1.1 0.0.0.0 UG 202 0 0 eth0
    192.168.1.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0


    Was bedeutet der Flag: UG? Heißt es, dass das default Routing ist? Wenn ja, dann ist eine Zeile zu viel oder? Aber warum hat die Tabelle zwei solche Einträge? Was ist, wenn der Metric-Wert > 0 ist?


  • Ich kann den Router nicht anpingen.


    D. h. Du willst den Zugang zum PI3 über eth0 nicht als fallback-Lösung bzw. nicht für lediglich eine Direktverbindung (ohne Router)?


    Dann ist die Konfiguration mit systemd-networkd (noch o. g. Beispiel) nicht das Richtige für deinen PI3.

    The most popular websites without IPv6 in Germany.

  • [font="Verdana, sans-serif"]Der Befehl ip addr zeigt, dass das Interface eth0 zwei IP Adressen hat!?! Die Datei [/font][font="Verdana, sans-serif"]/etc/systemd/network/mylan.network [/font][font="Verdana, sans-serif"]beinhaltet aber nur eine IP.[/font]


  • [font="Verdana, sans-serif"]Der Befehl ip addr zeigt, dass das Interface eth0 zwei IP Adressen hat!?! Die Datei [/font][font="Verdana, sans-serif"]/etc/systemd/network/mylan.network [/font][font="Verdana, sans-serif"]beinhaltet aber nur eine IP.[/font]


    Die Datei mylan.network ist ja auch nur für eine Direktverbindung (ohne Router) gedacht. Das willst Du anscheinend nicht.


    Die 2. IP-Adresse für eth0 wird daher kommen, weil Du in die dhcpcd.conf, das eth0-Interface nicht mit deny konfiguriert hast. Aber das brauchst Du jetzt ja nicht mehr, da Du mit eth0 auch deinen Router bzw. dein LAN verwenden willst.

    The most popular websites without IPv6 in Germany.

  • Heute morgen war der Pi im LAN erreichbar. Jetzt auf einmal nicht mehr. Warum kann es einfach nicht stabil laufen. Ich habe jede menge Linux Maschinen (Debian) installiert und einfach die Datei Interfaces editiert und fertig. schade, dass der Pi nicht stets erreichbar ist! Ich habe deswegen so viel Zeit investiert. Ich werde unter gleich die Logdateien anschauen. Irgendwo muss doch stehen, warum der Pi nicht ins Internet kommt bzw. den Router nicht anpingen kann!
    Automatisch zusammengefügt:[hr]
    Ich habe gerade folgendes probiert und es funktioniert, aber ich kann es nicht so belassen, weil ich kein langes RJ45 Kabel im Wohnzimmer möchte. Ich habe den Pi direkt an eine LAN-Buchse angeschlossen und auf Anhieb war der Pi im LAN erreichbar. Also, es sieht so aus, dass der "TP-Link TL-PA4010PKIT AV500 Powerline Netzwerkadapter" nicht wirklich mit Pi harmoniert!


  • Ich habe den Pi direkt an eine LAN-Buchse angeschlossen ...


    Eine LAN-Buchse von was? Hast Du evtl. eine direkte Kabelverbindung (ohne Router) zwischen deinem PI und einem anderen PC hergestellt? Wenn ja, mit welcher Konfiguration?


    EDIT:


    Wie ist dann die Ausgabe von:

    Code
    route -n
    ip a
    ip n s


    ?

    The most popular websites without IPv6 in Germany.

    Edited once, last by rpi444 ().

  • Ich habe den Powerline Adapter abgezogen. Ich verwende den Pi jetzt mit wlan0. Ich habe mit "wireless-power off" den Standby ausgeschaltet. Ich hoffe, dass dadurch die WLAN-Verbindung stets erhalten bleibt! schade, dass es mit dem Powerline Adapter nicht geklappt hat. Der Adapter wurde aber erkannt. Der ifconfig hat das Interface angezeigt und dmesg hat den Chip erkannt. Seltsam!


    route -n


    Kernel-IP-Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.1.1 0.0.0.0 UG 303 0 0 wlan0
    192.168.1.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0


    ip a


    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:2a:77:74 brd ff:ff:ff:ff:ff:ff
    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:7f:22:21 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.61/24 brd 192.168.1.255 scope global wlan0
    valid_lft forever preferred_lft forever



    ip ns


    192.168.1.102 dev wlan0 lladdr c4:85:08:e8:61:e7 REACHABLE ---> Hä, ich kenne diese Adresse nicht! Der Pi hat die IP 192.168.1.61


    192.168.1.1 dev wlan0 lladdr 08:96:d7:3b:78:74 REACHABLE



    Soll ich den Adapter wieder anschließen und die Befehle erneut ausführen?




    Automatisch zusammengefügt:[hr]
    Soll ich lieber das Ganze nur mit dhcpcd einrichten? Also so:


    #denyinterfaces wlan0
    #denyinterfaces eth0
    timeout 5


    interface eth0
    static ip_address=192.168.1.60/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1


    interface wlan0
    static ip_address=192.168.1.61/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1
    Automatisch zusammengefügt:[hr]
    Oh sorry, ich habe eine Deine Frage noch nicht beantwortet:


    >Eine LAN-Buchse von was?
    Ich habe in der Küche eine LAN-Buchse. Diese LAN-Buchse ist mit dem Cisco-Switch verbunden und der Cisco-Switch ist mit dem FritzBox verbunden.





    Automatisch zusammengefügt:[hr]
    Nur zur Info:
    Der zweite Powerline Adapter ist direkt mit dem FritzBox verbunden.


  • ... dem Powerline Adapter ...
    Ich habe in der Küche eine LAN-Buchse. Diese LAN-Buchse ist mit dem Cisco-Switch verbunden und der Cisco-Switch ist mit dem FritzBox verbunden.
    Der zweite Powerline Adapter ist direkt mit dem FritzBox verbunden.


    Bei solchen Konstellationen kann ich dir leider nicht weiter helfen.

    The most popular websites without IPv6 in Germany.

  • Die Netzwerkverbindung funktioniert nur teilweise. Heute hat für ein paar Stunden funktioniert. Der befehl ip ns zeigt folgendes:


    192.168.1.1 dev eth0 lladdr 08:96:d7:3b:78:74 DELAY


    Warum DELAY? Der gleiche Befehl hat bei einer funktionierenden Verbindung "REACHABLE" angezeigt. Wo kann ich genau nachschauen, warum DELAY auftaucht?


    Etwas ist faul hier. Nach 1 - 3 Stunden ist auf einmal der Pi nicht mehr erreichbar. Ich kann den Router nicht mehr anpingen. Vielleicht verliert der Pi nach einer bestimmten Zeit den Weg zum DNS-Server!


    Danke.