Bluetooth unter Kodi?

  • Hallo zusammen,


    ist es euch schon mal gelungen einen Bluetooth-Headset mit Kodi zu verbinden? Das automatische verbinden meines Headsets mit Raspbian funktioniert einwandfrei, wenn ich allerdings im Kodi die Audio-Ausgabe auf "Pulse Audio Server" ändere, kommt beim Headset kein Ton an.


    Ich hatte gehofft, dass sich die Bluetooth-Unterstützung unter Kodi 17 verbessert, allerdings scheint sich auch in dieser Version diesbezüglich nicht viel getan zu haben.


    Wenn es jemanden von euch gelungen ist unter Kodi (installiert unter raspbian) Bluetooth ans laufen zu bringen wwäre ich euch für einen Tipp sehr dankbar!


    Gruß, Rudi

  • Moin RUDI-TERROR,


    habe ich das richtig verstanden? Du hast Raspbian installiert und dann das Programm Kodi.


    Wenn das so ist, hast du dann auch pulseaudio nachinstalliert?


    Es gehört, zumindest bei mir Raspbian jessie lite, nicht zum Standard.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Genau, ich habe raspbian installiert und danach kodi über apt-get install kodi. Ob Pulseaudio in einer Abhängigkeit installiert wurde, oder bereits im raspbian enthalten war, kann ich gerade nicht beantworten, weil ich meinen raspi über die ferne abgeschossen habe (Netzwerk falsch konfiguriert ;-)).


    Mit OpenELEC scheint die Kodi Bluetooth Unterstützung ja schon ganz gut zu laufen, aber eben leider nicht über raspbian :(

    • Official Post

    Dann musst du dich wohl intensiver mit der konfiguration von PulseAudio auseinandersetzen und prüfen ob das alles so passt. Sound und Linux find ich immer noch unglaublich übertrieben komplex zu managen. Wer da keine Anfälle kriegt ist selber schuld. Blauzahn setzt dem ganzen dann noch die Krone auf.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.


  • ....Blauzahn setzt dem ganzen dann noch die Krone auf.


    stimmt unter wheezy lief mein BT Speaker unter jessie zuerst nicht, dann habe ich aufgegeben, Klinke reicht mir auf der Minibox
    [Blocked Image: https://www.arcotec.de/ebay_galaxyzz/img/artikel/mini-mobile-bluetooth-lautsprecher-speaker-handybox-iphone-ipod-mp3-player.jpg]

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Bei mir läuft KODI mit Bluetooth unter dem aktuellen Raspbian auf dem Pi 3.
    Ich bin folgendermaßen vorgegangen:


    Code
    sudo apt-get install -y pi-bluetooth blueman


    Anschliessend das Bluetooth Headset mit dem Raspberry Pi "pairen". Das muss man nur einmal machen.


    Wichtig: vor dem Aufruf von KODI dann den Raspberry Pi mit dem Bluetooth Headset verbinden - also das Bluetooth Headset als Tonausgabe-Kanal wählen.
    Das muss man jedesmal vor dem Aufruf von KODI machen. Dazu auf dem Desktop das Lautsprechersymbol rechts oben mit einem rechten Mausklick anklicken.
    Dann KODI aufrufen und die Ton-Ausgabe erfolgt über Bluetooth.

    Edited once, last by kaiuwe ().

  • Ich habe diverse Einstellungen ausprobiert, bis es funktioniert hat, deshalb kann ich das nicht 100% sagen.
    Probiere mal in den System Settings von KODI alle Audio Output Kanäle aus, bis es funktioniert.
    Leider kann ich bis zum Wochenende nicht nachschauen, was bei mir aktuell eingestellt ist.

  • Moin kaiuwe,
    danke für das Angebot.
    Ich hatte nur im Interesse des Erstellers der Anfrage gefragt. Mhm, was für ein Satz....


    Weil bei ihm ja Raspbian und BT geht. Nur Kodi nicht.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.