Plötzlich Pi über SSH nicht mehr erreichbar

  • Moin Leute,


    ich kann es mir nicht erklären, aber plötzlich funktioniert meine SSH Verbindung nicht mehr. Habe Die SSH in der Config enabled, aber ich komme mit meinem PC einfach nicht mehr drauf, obwohl ich eigentlich auf dem PI nichts verändert habe. Vom PC bekomme ich bei einem Ping eine positive Antwort. Auch den Port 22 habe ich auf dem PI überprüft und ist noch immer der gleiche. Der Pi wird auch noch in meinem Router angezeigt und ich komme mit ihm auch noch ins Internet. Es muss also irgendeine Ursache in den Einstellungen bzgl. SSH sein. Kann mir jemand weiterhelfen und erklären, wie ich den Fehler finden kann? Bin kein besonders großer Profi mit dem PI. Deshalb wäre ich für einfache Worte sehr dankbar.


    Viele Grüße,
    Alex

  • Hi,


    wie genau lautet denn die Fehlermeldung, wenn du versuchst via ssh auf den Pi zu gelangen?



    Checke mal, ob der ssh daemon noch läuft:


    service sshd status


    oder:


    service ssh status


    Außerdem nochmal checken, ob der Dienst noch auf dem Port "lauscht":


    sudo netstat -tulpen


    Und die Ausgaben ggf mal hier posten.

  • Die Fehlermeldung via Putty lautet: Network error: Connection timed out


    Das Ergebnis der zwei Befehle:
    pi@raspberrypi:~ $ service sshd status
    ● sshd.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)
    pi@raspberrypi:~ $ service ssh status
    ● ssh.service - OpenBSD Secure Shell server
    Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
    Active: active (running) since Do 2017-06-01 18:27:58 CEST; 42min ago
    Main PID: 541 (sshd)
    CGroup: /system.slice/ssh.service
    └─541 /usr/sbin/sshd -D
    pi@raspberrypi:~ $

  • (Es konnten nicht alle Prozesse identifiziert werden; Informationen über
    nicht-eigene Processe werden nicht angezeigt; Root kann sie anzeigen.)
    Aktive Internetverbindungen (Nur Server)
    Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 0 10525 -
    tcp6 0 0 :::22 :::* LISTEN 0 10527 -
    udp 0 0 0.0.0.0:68 0.0.0.0:* 0 10589 -
    udp 0 0 0.0.0.0:59506 0.0.0.0:* 105 7684 -
    udp 0 0 192.168.2.103:123 0.0.0.0:* 106 11700 -
    udp 0 0 127.0.0.1:123 0.0.0.0:* 0 7872 -
    udp 0 0 0.0.0.0:123 0.0.0.0:* 0 7865 -
    udp 0 0 0.0.0.0:5353 0.0.0.0:* 1000 14505 1105/libpepflashpla
    udp 0 0 0.0.0.0:5353 0.0.0.0:* 105 7682 -
    udp6 0 0 :::47481 :::* 105 7685 -
    udp6 0 0 fe80::1811:6183:a20:123 :::* 106 10631 -
    udp6 0 0 ::1:123 :::* 0 7873 -
    udp6 0 0 :::123 :::* 0 7866 -
    udp6 0 0 :::5353 :::* 1000 14506 1105/libpepflashpla
    udp6 0 0 :::5353 :::* 105 7683 -

  • Siehst du auf dem Pi entsprechende Logs? Z.B.:


    tail -f /var/log/auth.log


    Parallel dazu mal einen Verbindungsaufbau probieren. Hat die SSH-Verbindung denn wirklich shcon mal funktioniert? Existiert eine Firewall? Hast du den SSH-Port mal geändert ?


    Verwendest du tatsächlich die richtige IP-Adresse? Auf dem Pi prüfen mit: ip a | grep inet


    Versuchst du dich mit einem Benutzer zu verbinden? z.B. root@<ip-raspberrypi>

  • Quote from &quot;AlexTheMan&quot; pid='285505' dateline='1496335611'

    einfach nicht mehr drauf, obwohl ich eigentlich auf dem PI nichts verändert habe.


    Was heisst "eigentlich" nichts verändert.
    Hast Du vor dem Fehler ein Update durchgeführt, allenfalls sogar ein rpi-update ?



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hallo..

    Dieser Beitrag ist schon älter, aber klingt genau, wie mein aktuelles Problem..

    Auch ich habe nichts verändert.. Der ioBroker auf dem Pi 3 läuft auch noch wie eine Eins und startet auch nach

    Neustart ganz normal..

    Nur weder Putty noch FileZilla bekommen plötzlich Verbindung..


    LAN Verbindung ist über die Fritzbox gegeben !


    Gab es hier nach den letzten Beiträgen noch irgendwelche Erkenntnisse ?


    Viele Grüße

    Andre

  • Hallo Andre,

    Dieser Beitrag ist schon älter, aber klingt genau, wie mein aktuelles Problem..

    Sich in ein bestehendes Thema einzuklinken, ist ein weit verbreiteter "Anfängerfehler".


    Du solltest ein eigenes "Thema" anlegen.

    • Damit ist gewährleistet, daß alle Antworten auf das Thema sich auf ein einziges (nämlich Dein) Problem beziehen.
    • Außerdem gibt es fast immer Unterschiede: neue Raspberry Pi Modelle, neues Raspbian-Betrebssystem, zusätzliche Hardware, ...

    Ein weiterere Anfängerfehler: ein Leser Deines Themas steht nicht hinter Dir, er kennt Deinen Aufbau nicht. Deshalb solltest Du Dein Problem so beschreiben, daß sich der Leser ein Bild machen kann.

    Lies bitte mal Wie Frage ich nach Hilfe? damit Du eine Vorstellung bekommst, was ein Leser wissen muß, um Dir zu helfen.

    ------------

    Model: RPi 3B (oder RPi 3B+)

    Internet: mit LAN-Kabel an Fritzbox

    Programm: ioBroker


    Problem: kein Zugriff über ssh/putty oder Filezilla

    -------------

    Du weißt, daß Du (seit Raspbian vom 25.11.2016) ssh aktivieren mußt (dazu reicht es, eine leere Datei ssh oder ssh.txt z.B. unter Windows auf die SD-Karte zu schreiben). Siehe auch

    Setting up a Raspberry Pi headless.


    Du hast kontrolliert, daß der Raspi in der Fritzbox erkannt wird?

    Schönen Gruß, kle

  • Ich weiß nicht, ob ich falsch liege, aber Gestern kam mit dem Upgrade eine neue Version für rpi-eeprom. Bei mir funktionierte weder auf dem 3a, 3b oder 4b (alle Buster) ssh auch nicht mehr.

    Ein Aufruf von raspi-config zeigte, dass ssh deaktiviert war. Je ein Klick, ein Reboot und alles war wieder gut.

    Warnung: Raspi und Co. machen süchtig!! (:

  • Nur weder Putty noch FileZilla bekommen plötzlich Verbindung..


    LAN Verbindung ist über die Fritzbox gegeben !

    Mach mal aus dem (W)LAN der FritzBox einen Portscan auf den lauschenden TCP-Port 22 deines PI3.

    The most popular websites without IPv6 in Germany.