Raspberry Pi mit 512MB RAM - Firmware Update

  • Hallo,
    ich habe meinen Pi erst seit ein paar Wochen (mit 512mb Ram, stand jedenfalls drauf) und weis dashalb nicht so viel.
    Kann mir bitte jemand schreiben wie man das Update genau macht (Bitte mit Befehlen).


    Danke
    Math2002

    Edited once, last by ps915 ().

  • Hallo,
    ich habe meinen Pi erst seit ein paar Wochen (mit 512mb Ram, stand jedenfalls drauf) und weis dashalb nicht so viel.
    Kann mir bitte jemand schreiben wie man das Update genau macht (Bitte mit Befehlen).


    Danke
    Math2002

    ..


    Welche Distribution setzt du denn ein ?


    für Debian / Raspbian im Terminal folgendes nacheinander eingeben ..


    Code
    sudo -i
    cd /boot
    rm start.elf bootcode.bin kernel.img
    
    
    EDIT: Links angepasst...
    wget https://github.com/raspberrypi/firmware/blob/master/boot/bootcode.bin?raw=true
    wget https://github.com/raspberrypi/firmware/blob/master/boot/kernel.img?raw=true
    wget https://github.com/raspberrypi/firmware/blob/master/boot/start.elf?raw=true


    danach muss noch die config.txt angepasst werden um der Grafikkarte den Ram zu zuweisen..


    gpu_mem=16
    gpu_mem=32
    gpu_mem=64
    gpu_mem=128
    gpu_mem=246


    hier nur eine Einstellung auswählen und in die config.txt eintragen.


    Code
    nano /boot/config.txt


    nun nur noch einen reboot durchführen..


    Code
    reboot

    I sometimes feel that I have nothing to say and I want to communicate this.

    Edited once, last by klecks ().

  • Hallo,
    da ich Debian verwende hast du schon das richtige geschrieben.
    Vielen Dank, Morgen Probier ich es mal aus.

    Edited once, last by Math2002 ().

  • Hey,


    habe es gerade probiert, das neuste rasbian + alles wie oben ausgeführt und jetzt bootet er nicht mehr^^
    Ich habe die 3 Dateien gelöscht und die neuen über den PI direkt gedownloaded.
    Und dann einfach gpu_meme=64 in die config ganz unten schreiben, das richtig oder?


    Möchte eigentlich nur gern meine 512MB nutzen :D

    aktuell im Einsatz:
    Raspberry Pi Model B Rev. 2 | Raspberry Pi 2 Model B | Banana Pi

    Edited once, last by Akitoyo ().


  • Wenn, dann mit gpu_mem=64 probieren und nicht mit gpu_meme....

    Ups, habe schon in der config mem genommen nur hier vertippt. Die Datei sieht so aus:

    aktuell im Einsatz:
    Raspberry Pi Model B Rev. 2 | Raspberry Pi 2 Model B | Banana Pi

  • Ja die Dateien sind alle vorhanden :)


    Alles andere ist vom originalen Image, das ist ja okay oder?


    Edit: Habe nun nochmal alle Ordner aus dem boot Ordner heruntergeladen und ersetzt und voila es geht =)
    Danke für eure Antworten :)


    btw wieviel MB Ram sollte für die GPU reichen um die grafische Oberfläche gut darstellen zu können? Fürs Internet surfen und so keine Spiele.

    aktuell im Einsatz:
    Raspberry Pi Model B Rev. 2 | Raspberry Pi 2 Model B | Banana Pi

    Edited once, last by Akitoyo ().

  • Ja die Dateien sind alle vorhanden :)


    Alles andere ist vom originalen Image, das ist ja okay oder?


    soweit ist das ok..


    die Dateien sollten auch folgende Größe haben...


    Code
    bootcode.bin 17,3 KB (17.764 Bytes)
    Kernel.img 2,57 MB (2.695.192 Bytes)
    start.elf 2,23 MB (2.347.668 Bytes)



    EDIT:


    Du kannst dir die Dateien auch hier herunterladen und per PC auf die SD-Karte schieben..



    bootcode.bin
    kernel.img
    start.elf

    I sometimes feel that I have nothing to say and I want to communicate this.

    Edited once, last by klecks ().

  • Hey,


    Habe es nun nochmal über PC gemacht und bootet nun korrekt =)




    btw wieviel MB Ram sollte für die GPU reichen um die grafische
    Oberfläche gut darstellen zu können? Fürs Internet surfen und so keine
    Spiele.

    aktuell im Einsatz:
    Raspberry Pi Model B Rev. 2 | Raspberry Pi 2 Model B | Banana Pi

  • hallo,


    64MB sollten dafür ausreichen, solltest du merken das es nicht so rund läuft kannst du es ja jederzeit erhöhen...

    I sometimes feel that I have nothing to say and I want to communicate this.



  • Ich hatte es auch nach dieser Anleitung gemacht und hatte ebenfalls das Ergebnis das der RPi nicht mehr gebootet hat.

    "The best way to predict your future is to create it!"

  • Mein Pi stürzt beim Booten immer ab und da steht so was:
    Memory 0*000000000 (0mb).
    Das komische:
    Nach dem Update startete stellte ich die Sprache ein.
    Dann wollte ich neustarten und das ging nicht.
    Infos: Ich hab das Update mit meinem PC gemacht.
    (Alte Daten gelöscht, neue reinkopiert. Sollte ich die alten
    Daten vielleicht drinlassen ?)

    Edited once, last by Math2002 ().

  • Sry, muss gerade Weg. In einer ca einer Stunde kann ich die Config.txt Posten.
    [hr]
    Ich muss doch nicht weg.
    Hier die Config.txt:


    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1


    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1


    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16


    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720


    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1


    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1


    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2


    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4


    # uncomment for composite PAL
    #sdtv_mode=2


    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800


    # for more options see http://elinux.org/RPi_config.txt

    Edited once, last by Math2002 ().

  • @ Math2002


    so wie es aussieht hast du vergessen deine config.txt mit der zuweisung des Grafikspeichers anzupassen..


    Code
    gpu_mem=16
    gpu_mem=32
    gpu_mem=64
    gpu_mem=128
    gpu_mem=246



    @ s-e-a


    von Github heruntergeladen

    I sometimes feel that I have nothing to say and I want to communicate this.

  • Muss man dieses gpu_mem... Als Befehl eingeben(Befehlszeile)?
    Wenn das der fall ist dann kann ich es nicht.(Fährt ja nicht hoch)