Edimax Wlan Treiber lässt sich nicht installieren

  • Hallo liebe Community!


    Ich habe mir neulich einen Wlan Adapter für mein Raspberry Pi zugelegt.
    Edimax-EW-7811UAC
    Habe vor dem Kauf noch geguckt, ob der vom Pi unterstützt wird und mich deshalb auch für den entschieden.
    Nur leider schaffe ich es ihn nicht zum laufen zu kriegen. Treiber sind für Linux auf einer CD beigelegt.
    Dachte, dass man einen extra Treiber für den raspi braucht und mich auf die Suche begeben.
    Hab dann auch diverse Treiber gefunden, aber bei alllen kommt dieselbe Fehlermeldung:


    Code
    make ARCH=armv6l CROSS_COMPILE= -C /lib/modules/4.9.32+/build M=/media/usb/Edimax-EW-7811UAC/edimax-driver-rtl8821AU_linux_v4.3.14  modules
    make[1]: Entering directory '/lib/modules/4.9.32+/build'
    make[1]: *** No rule to make target 'modules'.  Stop.
    make[1]: Leaving directory '/lib/modules/4.9.32+/build'
    Makefile:1551: recipe for target 'modules' failed
    make: *** [modules] Error 2


    Was bedeutet das genau? Bin mit meinem Latein langsam am Ende.
    Liegt es nun am Stick, dass der raspi den nicht will, oder fehlt meinem raspi irgendwas?
    Habe dann auch update, upgrade und rpi-update gemacht, aber ohne erfolg.


    bei iwconfig und ifconfig ist der stick auch nicht gelistet.

  • Hi, den edimax hat er bei mir und Jessie sofort erkannt.


    Mach mal


    lsusb


    und schau ob er den edimax sieht.


    Grüße mojopi


    Gesendet von meinem UMI TOUCH mit Tapatalk

  • Auf meinem raspi läuft wheezy. Ich hatte mal einen anderen wlan stick, der wurde auch sofort erkannt.


    Ja, er sieht den.


    lsusb liefert:
    Bus 001 Device 005: ID 7392:a812 Edimax Technology Co., Ltd

  • Moin lemonhead,


    erstmal: Herzlich Willkommen im Forum!


    Die Meldung

    Code
    make[1]: *** No rule to make target 'modules'.  Stop.

    bedeutet nur das keine Makefile vorhanden ist.Oder es ist eines da, aber da steht nichts von modules.


    Was mir aber aufgefallen ist. Du hast einen Kernel 4.9.34. Den gibt es offiziell noch nicht. Aktuell ist 4.9.24.
    Du hast leider rpi-update gemacht. Ich hoffe bei dir geht noch alles...


    Ich bezweifel auch das für Raspbian whezzy noch Kernel gemacht werden.


    Aber du kannst einfach feststellen ob der Stick erkannt wird.
    Gebe ein

    Code
    lsmod

    ein. Dort sollte dann dann was mit 8821au stehen.
    Auch ein Blick in die Logdateien könnte helfen. Zum Beispiel die Eingabe von dmesg.


    Was ich dir aber auf jeden Fall empfehlen kann. Bau dir eine SD-Karte mit Jessie. Da sind definitiv neuere Treiber bei.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Ja, hab rpi-update gemacht. Allerdings ging es vor dem Update schon nicht. Ich dachte, rpi-update ändert das.
    Sonst geht noch alles ;)


    Bei lsusb steht nichts von 8821au.


    Werde mal versuchen den raspi mit jessie neu aufzusetzen.
    Hoffe das hilft.

  • So! Ich habe Wheezy nun runtergeschmissen und Jessie installiert.
    Kernel ist jetzt 4.9.24
    Stick wird immernoch nicht erkannt. Treiber lassen sich auch nicht installieren. :/


    Hat jemand noch eine Idee, was da los sein könnte?

  • Funktioniert unter Windows ohne Probleme.
    Automatisch zusammengefügt:[hr]
    dmesg spuckt das aus:


  • war da nicht so eine Mini CD mit im Paket und einer Linux Library drauf? Ich erinner mich dunkel das da was beigelegt war. Mit normalen Boardmitteln ist der Stick echt zickig. Ich weiß noch das ich auch drei Tage dran gesessen hab und es erst mit dieser Library lösen konnte.

  • Hallo lemonhead !


    Wird bei angestecktem Stick eine CD gemounted ? Nämlich die interne CD vom Stick, die unter Windows die Treiber installiert.
    Dann müssest Du statt idVendor=148f, idProduct=3070 eine alternative ProductID am Stick eintragen, damit der nicht zuerst seine Windows Treiber CD zum Automount anbietet.



    Servus !



    Sorry, hab das mit dem UMTS Stick verwechselt.

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • Auf der CD ist nicht viel drauf.
    Treiber für Windows, Mac, Linux, quick installation guide, adobe.


    Was meinst du mit der libraray? Kann ich die irgendwo runterladen?

  • Moin lemonhead,


    so, ich habe nun eine 8812au.ko.


    Ich kann aber nicht sagen ob die Datei funktionsfähig ist. Ich habe den Stick nicht.


    Ich habe mir von der Edimax-Seite die Datei EW-7811UTC_Linux_Driver_4.3.19.5.zip geholt.


    Dann auf dem Raspberry entpackt, die Datei install.sh ausführbar gemacht.


    Nun fehlen noch die Headerdateien. Also

    Code
    sudo apt-get update
    
    
    sudo apt-get install raspberrypi-kernel-headers


    Weil irgendein Makefile unbedingt das Verzeichnis armv7l haben wollte, es aber nicht da war.
    In das Verzeichnis /usr/scr/linux-header-4.9.24-v7+ gewechselt und nachfolgende Befehle eingegeben.

    Code
    mkdir armv7l
    
    
    sudo cp -a arm/. armv7l


    Tja, und dann sudo ./install.sh und hoffen das alles fehlerfrei durchläuft.


    Wenn fehlerfrei, dann sollte ein lsmod den Treiber 8812au zeigen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • hi DG8BR,


    danke für deine Hilfe. Ich habe den Treiber auch von der Homepage runtergeladen. Bei mir war es nicht "/usr/src/linux-header-4.9.24-v7+/armv71" sondern "/usr/src/linux-headers-4.9.24+/arch/armv61".
    Er kommt bei der Installation schon etwas weiter, bekomme jetzt aber eine neue Fehlermeldung.
    Verstehe da kein Wort :(




    Hab mal versucht in der Makefile folgenden Eintrag zu ändern, bekomme da aber auch eine Fehlermeldung.
    CONFIG_PLATFORM_I386_PC = n
    CONFIG_PLATFORM_ARM_RPI = y


    Code
    Authentication requested [root] for make driver:
    make ARCH= CROSS_COMPILE= -C  M=/home/pi/downloads/EW-7811UAC_Linux_Driver_4.3.19/driver/rtl8821AU_linux_v4.3.19.5_17672.20160506_BTCOEX20150921-58  modules
    make[1]: *** M=/home/pi/downloads/EW-7811UAC_Linux_Driver_4.3.19/driver/rtl8821AU_linux_v4.3.19.5_17672.20160506_BTCOEX20150921-58: No such file or directory.  Stop.
    Makefile:1623: recipe for target 'modules' failed
    make: *** [modules] Error 2
    ##################################################
    Compile make driver error: 2
    Please check error Mesg
    ##################################################


    Obwohl der Ordner da ist, er wird schließlich erzeugt, wenn das Archiv entpackt wird.

  • Moin lemonhead,


    darum hatte ich auch das Treiberpaket für den UTC geholt. In dem UAC war bei mir auch was kaputt.


    Nee, ich hatte beide geholt. Mit dem UTC getestet. Da ging es. Dann das UAC genommen. Ging nicht.


    Aber das UTC erzeugt auch ein einen 8812au.ko.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • Achso! Das mit UTC habe ich überlesen.
    Habe das nochmal mit dem UTC Treiber versucht. Funktioniert immernoch nicht :wallbash:
    Kann das vielleicht daran liegen, dass ich einen Raspberry Pi 1 habe? Das kann doch nicht sein, dass es sich bei Bernd installieren lässt und bei mir nicht! :/


    Hier die Fehlermeldung:

  • Moin lemonhead,
    ich muss gestehen das ich das auf einen Raspberry 2b gemacht habe.


    Ich kann dir also auch nichts schicken.


    Ok dann versuchen wir es mal.
    Diese Datei ist da?

    Code
    /home/pi/downloads/EW-7811UTC_Linux_Driver_4.3.19/driver/rtl8821AU_linux_v4.3.19.5_17672.20160506_BTCOEX20150921-58/core/rtw_cmd.o


    Es kann sein das sie beim Aufräumen, sprich Beenden, gelöscht wird. Die Endung "o" deutet auf schon compiliert.


    Ev. mit einen 2ten Terminal das Verzeichnis beobachten.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin lemonhead,


    ich habe eben gesehen, das dein Zip-Archiv ein älteres ist.
    Ich habe es mit

    Code
    EW-7811UTC_Linux_Driver_4.3.19.5.zip


    Geh mal bitte auf die amerikanische Seite. Da gibt es neuere Treiber

    Code
    http://us.edimax.com/edimax/download/download/data/edimax/us/download/


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Geilon!


    Installation hat geklappt! :thumbs1:
    Stick wird auch erkannt. Danke!
    Weiß aber nicht, ob der Treiber auch 5GHz kann. Ich will den nämlich als AP einrichten.
    Das werde ich aber erst nächste Woche ausprobieren können.
    Bis dahin ein schönes Wochenende und nochmal einen fetten Dank! :)

  • Moin lemonhead,


    das freut mich!!


    Du kannst ja mal so tun, als wenn du ein neues Wlan suchst. Vielleicht ist ja ein 5Ghz dabei.
    Dann weisst du das es geht.
    Übrigens , unter der gleichen Webadresse ist auch eine 7811UAC . Schon probiert?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.