Problem mit "Unerfüllte Abhängigkeiten"

  • Guten Morgen,


    mit meinem Raspberry habe ich ein Problem mit unerfüllten Abhängigkeiten (jessie) und ich weiß nicht wie ich es lösen kann.


    Nach sudo apt-get update habe ich sudo apt-get upgrade durchgeführt und das Ergebnis sieht so aus:


    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren.
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    libgnutls-openssl27 : Hängt ab von: libgnutls-deb0-28 (= 3.3.8-6+deb8u6) aber 3 .3.8-6+deb8u5 ist installiert
    E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.


    Den Parameter -f habe ich auch schon verwendet.


    Vielen Dank.


    whitechristmas

  • Moin whitechristmas,


    du hast also

    Code
    sudo apt-get -f install

    gemacht?
    Hast du denn schon mal versucht die angemeckerte Datei nachzuinstallieren?

    Code
    sudo apt-get install libgnutls-deb0-28

    Entweder er macht es und installiert die neueste Version oder er sagt das es schon die neueste Version ist.
    Dann sehen wir weiter.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    danke für Deine Hilfe. Folgend die Meldungen:


    sudo apt-get install libgnutls-deb0-28


    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
    libgssapi3-heimdal libheimntlm0-heimdal libkdc2-heimdal libxfce4ui-1-0
    xfce-keyboard-shortcuts
    Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
    Vorgeschlagene Pakete:
    gnutls-bin
    Die folgenden Pakete werden aktualisiert (Upgrade):
    libgnutls-deb0-28
    1 aktualisiert, 0 neu installiert, 0 zu entfernen und 57 nicht aktualisiert.
    31 nicht vollständig installiert oder entfernt.
    Es müssen noch 0 B von 630 kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 4.096 B Plattenplatz freigegeben.
    E: Ungültige Archivbestandteil-Kopfzeile .
    This package contains the clearlookspix theme engine.


    P!<arch>
    E: Prior errors apply to /var/cache/apt/archives/libgnutls-deb0-28_3.3.8-6+deb8u6_armhf.deb
    debconf: apt-extracttemplates schlug fehl: Datei oder Verzeichnis nicht gefunden
    dpkg-deb (Unterprozess): Archiv-Element wird dekomprimiert: interner gzip-Lesefehler: »<fd:4>: invalid distance too far back«
    tar: Das sieht nicht wie ein „tar“-Archiv aus.
    tar: Beende mit Fehlerstatus aufgrund vorheriger Fehler
    dpkg-deb: Fehler: Unterprozess tar gab den Fehlerwert 2 zurück
    dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libgnutls-deb0-28_3.3.8-6+deb8u6_armhf.deb (--unpack):
    Unterprozess dpkg-deb --control gab den Fehlerwert 2 zurück
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/libgnutls-deb0-28_3.3.8-6+deb8u6_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Hast Du eine Idee, was ich noch mal kann?


    Viele Grüße


    whitechristmas

  • Moin whitechristmas,


    ich denke man müsste mal aufräumen. Du kannst mal folgendes probieren.


    Erstmal nachsehen, ob die angemeckerte Datei noch da ist.

    Code
    ls -l /var/cache/apt/archives/


    Dann das Aufräumen

    Code
    sudo apt-get autoremove
    sudo apt-get autoclean
    sudo apt-get clean


    Kontrolle ob die Datei weg ist, mit dem ersten Befehl (ls -l). Weil, die wurde ja als fehlerhaft angemeckert.


    Tja, und nun bin ich am zweifeln...
    Mach erstmal ein

    Code
    sudo apt-get update

    und dann versuch die Datei nochmal zu installieren.


    Sollte das nicht funktionieren, dann machen wir anhand der Fehlermeldung weiter.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    habe Deine Anleitung durchgeführt. Es hat sich nichts geändert.


    Nach sudo apt-get update und dann mit upgrade kommt folgende Meldung:


    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren.
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    libgnutls-openssl27 : Hängt ab von: libgnutls-deb0-28 (= 3.3.8-6+deb8u6) aber 3.3.8-6+deb8u5 ist installiert
    E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.


    Das ist eine verflixte Geschichte...


    hyle: sudo apt-get -f install hatte ich zu Beginn schon gemacht und es hat nicht den gewünschten Erfolg gebracht.


    Danke an Euch. Habt Ihr noch eine Idee?


    VG whitechristmas

  • Quote from &quot;whitechristmas&quot; pid='291861' dateline='1500624077'


    libgnutls-openssl27 : Hängt ab von: libgnutls-deb0-28 (= 3.3.8-6+deb8u6) aber 3.3.8-6+deb8u5 ist installiert


    Hast Du etwas manuell installiert, das von der Version 3.3.8-6+deb8u5 abhängig ist?


    Mach mal eine Simulation für das reinstall der libgnutls-deb0-28:

    Code
    apt-get -s install --reinstall libgnutls-deb0-28

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hallo,



    ich habe nichts manuell installiert. Lediglich in regelmäßigen Abstände für ich sudo apt-get update und sudo apt-get upgrade durch, um das System aktuell zu halten.


    Hier die Ausgabe:


    sudo apt-get -s install --reinstall libgnutls-deb0-28


    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
    libgssapi3-heimdal libheimntlm0-heimdal libkdc2-heimdal libxfce4ui-1-0
    xfce-keyboard-shortcuts
    Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
    Vorgeschlagene Pakete:
    gnutls-bin
    Die folgenden Pakete werden aktualisiert (Upgrade):
    libgnutls-deb0-28
    1 aktualisiert, 0 neu installiert, 0 zu entfernen und 57 nicht aktualisiert.
    31 nicht vollständig installiert oder entfernt.
    Inst libgnutls-deb0-28 [3.3.8-6+deb8u5] (3.3.8-6+deb8u6 Raspbian:oldstable [armhf])
    Conf libcomerr2 (1.43.3-1~bpo8+1 Raspberry Pi Foundation:stable [armhf])
    Conf man-db (2.7.5-1~bpo8+1 Raspberry Pi Foundation:stable [armhf])
    Conf libtasn1-6 (4.2-3+deb8u3 Raspbian:oldstable [armhf])
    Conf libgnutls-deb0-28 (3.3.8-6+deb8u6 Raspbian:oldstable [armhf])
    Conf libgnutls-openssl27 (3.3.8-6+deb8u6 Raspbian:oldstable [armhf])
    Conf perl-modules (5.20.2-3+deb8u7 Raspbian:oldstable [all])
    Conf perl (5.20.2-3+deb8u7 Raspbian:oldstable [armhf])
    Conf libisc-export95 (1:9.9.5.dfsg-9+deb8u12 Raspbian:oldstable [armhf])
    Conf libdns-export100 (1:9.9.5.dfsg-9+deb8u12 Raspbian:oldstable [armhf])
    Conf libexpat1 (2.1.0-6+deb8u4 Raspbian:oldstable [armhf])
    Conf libffi6 (3.1-2+deb8u1 Raspbian:oldstable [armhf])
    Conf libgraphite2-3 (1.3.10-1~deb8u1 Raspbian:oldstable [armhf])
    Conf libisccfg-export90 (1:9.9.5.dfsg-9+deb8u12 Raspbian:oldstable [armhf])
    Conf libirs-export91 (1:9.9.5.dfsg-9+deb8u12 Raspbian:oldstable [armhf])
    Conf mysql-common (5.5.55-0+deb8u1 Raspbian:oldstable [all])
    Conf libmysqlclient18 (5.5.55-0+deb8u1 Raspbian:oldstable [armhf])
    Conf libnss3 (2:3.26-1+debu8u2 Raspbian:oldstable [armhf])
    Conf libwbclient0 (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf samba-libs (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf libsmbclient (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf libtiff5 (4.0.3-12.3+deb8u4 Raspbian:oldstable [armhf])
    Conf python-samba (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf samba-common (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [all])
    Conf samba-common-bin (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf samba-dsdb-modules (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf samba (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf librtmp1 (2.4+20150115.gita107cef-1+deb8u1 Raspbian:oldstable [armhf])
    Conf libc-dev-bin (2.19-18+deb8u10 Raspbian:oldstable [armhf])
    Conf libc6-dev (2.19-18+deb8u10 Raspbian:oldstable [armhf])
    Conf libexpat1-dev (2.1.0-6+deb8u4 Raspbian:oldstable [armhf])
    Conf samba-vfs-modules (2:4.2.14+dfsg-0+deb8u7 Raspbian:oldstable [armhf])
    Conf libc6-dbg (2.19-18+deb8u10 Raspbian:oldstable [armhf])


    Vielen Dank.


    whitechristmas


  • OK, dann versuch mal jetzt:

    Code
    sudo apt-get autoremove
    sudo dpkg --configure -a
    sudo apt-get install --reinstall libgnutls-deb0-28
    sudo apt-get -f install
    sudo dpkg --configure -a

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Moin whitechristmas,


    das habe ich ja auch nicht geschrieben.
    Du solltest nach der Aufräumerei nur ein apt-get update machen und dann diese Datei installieren.
    Von upgrade habe ich nicht geschrieben.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Guten Morgen zusammen,


    nichts, hab jetzt alle Lösungsvorschläge durch. Die Fehlermeldung kommt immer noch. Habt ihr noch eine Idee. Ansonsten muss ich wohl oder übel das System neu aufsetzen.


    Vielen Dank und einen schönen Tag.


    whitechristmas

  • Quote from &quot;whitechristmas&quot; pid='291961' dateline='1500708224'


    nichts, ...


    Wie sind die Ausgaben von:

    Code
    sudo apt-get install --reinstall libgnutls-deb0-28
    apt-cache policy libgnutls-deb0-28


    ?


    EDIT:


    Mach dann immer:

    Code
    sudo apt-get update && sudo apt-get dist-upgrade


    und nicht "sudo apt-get upgrade".

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Hallo zusammen,


    ich habe jetzt eure Vorschläge versucht, irgendwie wollte es nicht fruchten. Ich denke, dass ich ein neues Raspbian aufsetze. Ich danke euch ganz herzlich für die Unterstützung.
    Eine Frage hätte ich aber noch. Kann ich einen Fehler machen, wenn ich nacheinander apt-get update und apt-get upgrade durchführe? Das Problem entstand nämlich danach.


    Liebe Grüße.


    whitechristmas

  • Quote from &quot;whitechristmas&quot; pid='291989' dateline='1500734338'


    ich habe jetzt eure Vorschläge versucht, ...


    Nein, das hast Du nicht.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden