Raspberry Pi Dcf77 Pollin

  • Hm, ich hab mal spaßhalber nach DCF Modulen gesucht

    Ein Klick auf den Link von Raspberry-Geek hätte genügt, da sind auch die Anschlusspläne.


    Ich habe das auf einer kleinen Platine mit einer RealTimeClock(DS3231)

    und zu invertieren mit einen einzelnen Inverter (74LVC1G14GV) kombiniert.


    Ist das "DCF Empfänger Modul 641138" von Conrad und auch eines der teuren.

    Man kann alles fertig bekommen, es hat nur seinen Preis: https://www.meinberg.de/german/info/dcf77.htm

    Bei mir stand das Basteln im Vordergrund.


    MfG


    Jürgen

  • Man kann alles fertig bekommen, es hat nur seinen Preis: https://www.meinberg.de/german/info/dcf77.htm

    So etwas habe ich noch aus PC Anfangszeiten rumliegen, könnte sogar noch aus Amiga Zeiten stammen.

    Eine DCF77 clock mouse von Hopf mit serieller Schnittstelle.

    Die funktioniert sogar noch und dient mir als Tischuhr am Schreibtisch wo mein Bildschirm steht.

    Seriell angeschlossen ist sie allerdings schon lange nicht mehr, bekommt aber an und an Neue Batterien.

    Bei mir stand das Basteln im Vordergrund.


    MfG


    Jürgen

    Bei mir normalerweise früher auch, aber seit meinen "Grauer Star" Operationen und Kunstlinsen in den Augen, sehe ich nicht mehr so gut und habe daher Schwierigkeiten bei dem kleinen Zeugs.

  • Hallo zusammen,


    nach einier Zeit des passiven mitlesen, hab ich mich mal angemeldet.


    Ich habe mit dem Pi3B+ und der DCF77 die selben Probleme. Ich nutze das Modul von Reichelt, welches baugleich zu dem von Conrad ist, meldet sich auch als solches.


    Die Zeitimpulse kommen am Pi an, lassen sich auch per Script mitlesen ( hab ich im Netz gefunden das Testscript ) aber das Signal scheint unbrauchbar zu sein für den Pi.

  • Wie sieht Deine /etc/ntp.conf aus?

    Hier mal einen Auszug aus meiner:

    Code
    # DCF77 Pollin
    server 127.127.8.0 mode 5 minpoll 3 maxpoll 8 iburst prefer
    fudge 127.127.8.0 stratum 1 refid DCF


    MfG


    Jürgen


    P.S.: Willkommen im Forum

  • Hallo zusammen,


    erst mal danke Jürgen für die Arbeit und das Zusammenfassen der einzelnen Schritte!


    Vorweg, ich bin ein absoluter Noob was den Raspberry Pi angeht und meine Programmier-Kenntnisse beschränken sich auf ein wenig Java und Delphi aus meiner Schulzeit.


    Nun zu meinem Problem. Ich versuche zur Zeit mit Hilfe eines Raspberry Pi 3B V 1.2 (Raspbian GNU/Linux 9 (stretch)) und dem DCF77 Modul von Conrad einen NTP-Server aufzubauen, der später die Uhrzeit in einem Netzwerk bereitstellen soll, ohne auf das Internet zugreifen zu müssen und zu können.

    Ich habe die Anleitung von Jürgen wie beschrieben befolgt, das Modul ist auch angeschlossen und ich habe mit einem 2,2kOhm Wiederstand und einer LED die Anschlüsse überprüft, bis dahin sieht das auch alles gut aus.


    Jetzt ist es nur leider so, dass wenn ich mir per watch -n 1 ntpq -c as -c cv -c rv -p 127.0.0.1 anschaue, was die Uhr genau macht, sehe ich, dass scheinbar kein Signal beim Raspberry ankommt. Jetzt ist die Frage, ob es am Code liegt, oder die Antenne blöd liegt (in der Nähe eines Fensters Blickrichtung Frankfurt).


    Wie gesagt, ich bin ein absoluter Noob und über jede Hilfe dankbar! Die letzten Tage war Google und dieser Thread mein bester freund, aber jetzt bin ich leider mit meinem Latein am Ende...


    Danke schon mal im Voraus und beste Grüße!

  • Es kann sein das Dir Bluetooth in die Suppe spuckt, das muss deakitviert werden.

    In der /boot/config.txt unten einfügen:

    Code
    # Disable Bluetoothdtoverlay=pi3-disable-bt

    Aber mit dem neuen RPi3B+ und Stretch habe ich noch keine Erfahrung, da musst Du erstmal selbst ein bißchen experimentieren.


    MfG


    Jürgen

  • Danke für die schnelle Antwort! Bluetooth war es leider nicht...


    Liegt es im Zweifel eher an der Hardware, also dem Raspi, oder an der Raspbian-Version? Könnte ich eine ältere Raspbian Version nutzen, oder ist das Peng?


    Entschuldigung für die vielleicht blöden Fragen...


    Beste Grüße!

  • Wie hast Du das festgestellt, was hast Du gemacht?

    Ich habe den Befehl von Jürgen eingefügt, gespeichert, den Raspi neu gebootet und dann watch -n 1 ntpq -c as -c cv -c rv -p 127.0.0.1 eingegeben. Da steht dann weiterhin "timecode=" und fertig, also sieht es (für mich) so aus, als ob beim Pi weiterhin nichts ankommt.


    Beste Grüße

  • Da ist was zusammengekleckst, was nicht zusammen gehört. ;)


    Der richtige Eintrag wäre:

    Code
    dtoverlay=pi3-disable-bt

    in der /boot/config.txt.

    Ich hab's mir gedacht und selbst korrigiert, da ging's nicht.


    Hab's jetzt nochmal neu eingegeben und siehe da:


    Code
    timecode="--#--#----##--#--D--S-24-1--P---81-p1-4--2--4--4--1--81---p"


    Danke! :danke_ATDE: Ich melde mich nochmal, falls ich nicht weiter komme!


    Beste Grüße!