Pi-Zero MicroSD Karte im Readonly?

  • hallo,
    ich stelle wieder fest das ich nun das 2te mal mein PiZeroW meine MicroSD-Karte gesschrottet hat , bezw ich denk mir das mal...


    Dieser Läuft mit einem Dispay LCD modul um mir diverse dinge anzuzeigen, Wetter,Temperatur... etc


    ich wollte wieder ein Backup machen und meine routine brach ab ...


    ich probierte folgendes


    root@pidisp:~# mkdir backup
    mkdir: cannot create directory âtestâ: Read-only file system


    komischerweise kann ich im ordner boot noch was erstelle aber da denke ich das diese daten flüchtig sind...


    root@pidisp:/boot# nano hallo.txt
    Error writing /root/.nano_history: Read-only file system


    Ich geh mal wieder von aus das nun die nächste MicroSD durch ist, komischer weise ist es nur bei dem PiZeroW mit dem Display alle anderen laufen 100 % und kein ausfall irgendeiner Karte....


    Davor hatte ich einen PiZero(ohne W) dafür in arbeit... der nun andere aktivitäten macht und 100 % läuft ...


    Hab ich evtl pech mit den MiroSD-Karten, (in diesen fällen hab ich immer eine 8 GB für den PiZero verwendet ?
    Ich werd mal eine 16 GB mal einsetzen vlt. hält diese länger ?
    Mir geht eine Frage auf ,
    Haben 8 GB karten Weniger schreib/Lese Zyklen als z.b. 16 GB oder größer?
    Wo bekomme ich infos wieviele eine vom werk hat ?
    Vlt hat jemand ne idee ???
    lg


    ps .
    Im Readonly modus werden meine Pythoscripte alle noch ausgeführt( weil sie nur lesen,Sensoren,Datenbank. etc) aber das ist ja keine Lösung !

  • Hallo Brenner23,


    wie sind denn die Ausgaben von

    Code
    df
    mount


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • root@pidisp:~# df
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 7346472 3012700 4005496 43% /
    devtmpfs 218256 0 218256 0% /dev
    tmpfs 222540 0 222540 0% /dev/shm
    tmpfs 222540 4496 218044 3% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 222540 0 222540 0% /sys/fs/cgroup
    /dev/mmcblk0p1 63503 20757 42746 33% /boot


    root@pidisp:~# mount
    /dev/mmcblk0p2 on / type ext4 (ro,relatime,data=ordered)
    devtmpfs on /dev type devtmpfs (rw,relatime,size=218256k,nr_inodes=54564,mode=755)
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
    tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    configfs on /sys/kernel/config type configfs (rw,relatime)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    /dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
    root@pidisp:~#




    wenns hilft :)

  • Servus brenner23,

    Quote from "brenner23" pid='296186' dateline='1503262738'


    ...
    root@pidisp:~# mount
    /dev/mmcblk0p2 on / type ext4 (ro,relatime,data=ordered)


    Ist klar, dass das nicht geht ... Du hast die root-Partition readonly eingehängt.
    Was hast Du da für ein System drauf bzw. was hattest Du da so alles verändert?
    Versuch das mal zu "remounten":

    Code
    sudo mount -o rw,remount /dev/mmcblk0p2 /


    cu,
    -ds-

  • seltsam nachdem geht es wiieder... sogar der apache ist wieder online :-/


    ich denke mal cer PiZero ist mal abgeschmiert und ich hatte ihn vom strom getrennt
    ich werde es weiter beobachten :-)