Quake 3 installieren ... und starten (?)

Ein neuer Artikel wurde veröffentlicht
  • Ich habe mir Quake 3 heruntergeladen (für Raspian GNU/Linux 8.0 [Jessie]Kernel: 4.4.34-v7*). Sogenanntes Quake III Arena und zwei io-Quake Pakete wurden installiert. Dann will ich Quake3 starten aber dann kommt folgende Fehlermeldung;


    Use game-data-packager to build and install the quake3-data package.
    You will need these two files:




    Ich besitze die originale Quake 3 CD und demesprechend auch diese PAK-Dateien. Ich habe nur keine Ahnung wie das gemeint ist "build and install the Quake 3 package". Ich hätte jetzt gedacht das ich nur die PAK0.PK3 irgendwo hin kopieren muss ... aber wohin ist mir völlig schleierhaft :/ Beim googeln stoße ich nur auf Intallationsanleitungen für veraltete Versionen die nichtmehr funktionieren.
    Was muss ich nun tun?

  • Anhand der Ausgabe würde ich erst mal denken dass das nicht funktionieren wird, auch wenn du das Verzeichnis für die pak0.pk3 findest... Denn die zweite Datei die du installieren sollst enthält "x86" im Dateinamen, der Pi ist aber nicht x86 sondern ARM - nicht kompatibel.

  • Der Dateimanager hat nur nach Dateien, nicht nach Ordnern, gesucht (nehme ich mal an). Habe das Verzeichnis nun beim manuellen stöbern entdeckt und die eine Datei ins besagte Verzeichnis kopiert und die andere in den Ordner vor dem besagen Verzeichnis (Quake3).


    Wie verwende ich nun dieses Game-data-package?
    In der Konsole kann ich Game-data-package eingeben, nur was muss ich dazu eingeben und wie muss ich vorgehen?
    Ich habe es mit "game-data-packager quake3 -i" versucht und er versucht sich seit Stunden mit toten Servern zu verbinden :bussi2:

    Raspberry Pi 3
    Raspian GNU/Linux 8.0 (Jessie)
    Kernel: 4.9.35-v7*

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Turrican2k ()

  • Ich habe das nun aufgegeben und eine andere Variante gesucht und diese hier versucht;


    http://www.gtkdb.de/index_7_1792.html


    Bei dem Punkt diesen Komplimentiervorgang zu starten (dieser eigentlich eine Stunde dauern soll) wird in wenigen Sekunden hiermit abgebrochen;


    ./build.sh


    anstatt src habe ich games/quake3 anstatt dieses srv/quake3 verwendet, aber nochmal in der beschriebenen Variante versucht ... gleicher Fehler!
    Was stimmt da nicht???

  • Da hast du anscheint einen Schritt der Anleitung übersprungen :huh:


    Zitat


    Zum Schluss kommentieren Sie noch die Option CROSS_COMPILE aus.


    #CROSS_COMPILE=bcm2708-


    Aus-kommentieren bedeutet man soll ein # an den Zeilenanfang setzen.

  • Hey, genau das war es, danke! Aber ich wurde wieder mit einem neuen Fehler überrascht;



    Das Verfahren sollte eine Stunde dauern, aber nach 5min wurde es mit dieser Meldung abgebrochen :(


    Was bedeutet das?

  • Ich habe Quake 3 Arena vor einigen Jahren auf meinem Pi zum Laufen gebracht und hatte eine gute Anleitung dafür im Netz gefunden. Leider finde ich sie jetzt nicht mehr. Ein Ersatz ist möglicher Weise diese hier: https://www.raspberrypi.org/bl…-bounty-we-have-a-winner/

    Ich habe nicht geprüft, ob die Anleitung richtig, vollständig und verständlich ist. Probier es einfach aus. Am besten fängst du dafür noch einmal ganz von vorn an (also mit dem Installieren der benötigten Tools und dem Herunterladen der Quellcodes). Ich hoffe, du bist des Englischen mächtig.

    Wenn es Probleme gibt, melde mich, dann gucke ich mir die Stelle in der Anleitung an versuche zu helfen.


    Viel Erfolg!