Win10 IoT Regenbildschirm

  • Hallo zusammen,


    ich habe eben meinen neuen Raspberry 3 mit der akutellen Version von Windows 10 IoT geflasht und an den Fernseher angeschlossen.
    Leider kommt immer wieder dieses Bild und geht nicht weg. Auf der Fritzbox wird mir der Raspberry ebenfalls nicht angezeigt.


    Die SD-Karte habe ich mehrmals neu geflasht um dort einen Fehler auszuschließen.
    Google hilft mir nicht groß. Hatte mal was gelesen, dass es eventuell aussagen könnte, dass er zu wenig Strom bekommt. Jedoch ist das netzteil eigentlich groß genug.


    Danke und viele Grüße

  • Moin.
    Wie linusg schreibt gibt es mehrere Fehlermöglichkeiten die mir ad hoc einfallen:
    1. Netzteil zu leistungsschwach
    2. du hast etwas beim "flashen" falsch gemacht
    3. SD-Karte defekt.
    4. Kartenleser/slot defekt



    Quote

    Coloured splash screen


    With current firmware, a coloured splash screen (actually its just four pixels "blown up" by the GPU to full screen) is displayed after GPU firmware (start.elf) is loaded. This should be replaced by linux console a second later. However if the coloured screen remains, it suggests the kernel.img file is failing to boot. Try replacing it with a known good one.


    Immediately after displaying the splash screen, the PI starts consuming a little more current. If the PI resets at that moment, it is an indication that the power supply isn't able to deliver the full current your PI requires, but dips its output voltage below a minimum when loaded with the full current the PI needs.


    Quelle: http://elinux.org/R-Pi_Trouble…ng#Coloured_splash_screen


    Um Fehler 1 und 3 auszuschließen würde ich zum Test auf die SD-Karte die aktuelle Raspbian Version (nicht Noobs!)
    aufspielen und testen.
    Um Fehler 4 auszuschließen anderen Kartenleser nehmen.

    Edited once, last by ait ().

  • Moin!


    Windows 10 IoT core muss!! mit einem Microsofttool auf die SD gebracht werden.
    Ich könnte nun die Suchmaschine anschmeissen, aber.... Noe!!


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Guten Morgen,
    ich hatte schon die Suchmaschine benutzt. Die hat mich leider nur nicht viel weiter geführt.
    Um ein paar Fragen aufzulösen:


    - Netzteil: Output: +5V; 2A
    - MircoSD-Karte: Class10 (mehrere pobiert; jedesmal gleicher Fehler)
    - Vorgehen zum flashen:
    -> Erster Versuch übers IoT-Dashboard war erfolglos
    -> Habe im weiteren Versuch die flash.ffu mit einem phyton-skript in eine img konvertiert und mit meinem MacBook auf die SD-Karte geflasht ebenfalls gleiches Problem


    Achja, der Raspberry war niegel nagel neu...

  • Quote from "Theki" pid='300902' dateline='1506157424'


    Guten Morgen,


    Mahlzeit


    Quote from "Theki" pid='300902' dateline='1506157424'


    Um ein paar Fragen aufzulösen:
    - Netzteil: Output: +5V; 2A
    - MircoSD-Karte: Class10 (mehrere pobiert; jedesmal gleicher Fehler)


    echt jetzt?
    keine Markennamen, keine Links, nicht mal Bilder davon.
    Ist ja nicht nötig weil es weltweit nur "ein Netzteil" und nur "eine microSD" gibt.....


    Meine Schuhe drücken mich auch Größe 45, reicht ja völlig.

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Hallo Theki,


    also mit Win10-IoT hast Du zumindest für den Einstieg auf dem RPi keine gute Wahl getroffen. Und das ist jetzt nicht das übliche Anti-Windows-Gefasel, das sich in der Linux-Szene schnell mal breit macht, sondern konkret bei Win10-IoT für den RPi leider Tatsache.


    Es fängt damit an, dass man, wie >> DG8BR << bereits in >> Beitrag #8 << schreibt, für das Flashen des Betriebssystems auf die SD-Karte einen PC mit Windows 10 benötigt, um besagtes Microsoft-Tool zum korrekten Beschreiben der SD-Karte überhaupt aufrufen zu können.
    Ein einfaches Rüberschieben der heruntergeladenen Datei auf die SD-Karte mit win32diskimager oder unter Linux mit dd reicht definitiv nicht! Daher erhältst Du auch das große vierfarbige Bild auf Deinem Fernseher.
    Wenn zusätzlich noch die Stromversorgung mau ist, wird dieses Bild auf dem Bildschirm rechts oben in klein angezeigt (oder neuerdings auch ein gelber Blitz), das scheint auf Deinem Foto zusätzlich noch der Fall zu sein (das sogenannte "Mysterium")!


    Der nächste Punkt ist kein wirklicher Nachteil, aber insbesondere für Anfänger relevant:
    Win10-IoT ist kein Windows mit schöner GUI, wie man es vom PC her kennt, sondern ein Betriebssystem, das hauptsächlich für Konsolenarbeit gedacht ist. Grafik ist zwar möglich, aber wohl eher aufwändig zu realisieren. An dieser Stelle ähnelt Win10-IoT von der Machart her eher >> Raspbian LITE << als >> Raspbian with Desktop (PIXEL) <<


    Abschließend weise ich noch darauf hin, dass dieses Betriebssystem von den Mitgliedern (nicht nur) dieses Forums äußerst selten bis gar nicht genutzt wird. Schon alleine mangels Erfahrung der Community kann dir daher wohl keiner richtige Hilfe zukommen lassen.



    Ich rate Dir deshalb, mit >> Raspbian << zu beginnen, und zwar direkt und nicht über NOOBS! Nach ersten Erfahrungen kannst Du ja dann immer noch auf Win10-IoT umsteigen, falls Dich bis dahin die Linux-Sucht noch nicht erwischt hat ;)
    Meinen persönlichen Eintieg in die RPi-Welt habe ich einem anderen Mitglied kürzlich >> hier << beschrieben. Dir rate ich insbesondere, baldmöglichst ein vernünftiges Netzteil zu organisieren wegen des kleinen farbigen Bildes rechts oben...


    Ich wünsche Dir einen guten Einstieg und viel Erfolg!
    schlizbäda

  • Hallo Theki,


    schlizbäda hat bereits einen sehr guten Beitrag zum Thema geschrieben.


    Um noch meine Erfahrungswerte mit Windows 10 IoT beizusteuern:


    * Das Windows IoT Dashboard funktioniert leider nicht immer einwandfrei.
    * Beim ersten Boot kann das Raspi gut und gerne mal ein paar Minuten benötigen, da anscheinend das Betriebssystem eingerichtet wird
    * Ich persönlich habe Win10IoT bisher ausschließlich auf dem Pi 2 bisher zum laufen bekommen. Die wenigen Versuche mit dem Pi 3 habe ich relativ schnell abgebrochen. Letzendlich konnte keine Verbindung vom IoT Dashboard oder von Visual Studio zum Gerät hergestellt werden und es war nie wirklich klar, ob das Gerät überhaupt fehlerfrei ins Betriebssystem gebootet wurde.


    Den Pi samt Windows habe ich nie an einen Bildschirm angeschlossen, daher kann ich dir nicht genau sagen, ob Windows 10 IoT überhaupt standardmäßig ein Signal ans HDMI (?) ausgibt.


    Das nur noch einmal ergänzend dazu :).

    .NET-, Unity3D-, Web-Dev.
    Mikrocomputer-Hobbyist.

  • Da ich bereits Projekte mit W10 IoT umgesetzt habe:


    Die SD Karte ausschließlich mit dem W10 Dashboard von einem anderen Computer beschreiben.
    Alles andere führt zu dem Bildschirm.


    Für den betrieb des Dashboards , W10 immer aktuell halten. Also immer alle Updates laufen lassen.