Upgrade von Jessie auf Stretch - Phpmyadmin funktioniert nicht

  • Hallo zusammen,


    wollte gestern Abend dann endlich mal upgraden.
    Soweit alles gut, nur hat PHPMYADMIN ein Problem.


    Es fragte dauernd während des Upgradeprozesses nach einen Kennwort und einem User für die PHPMYADMIN-Datenbank... das konnte ich nicht herausfinden.
    Daher wollte ich PHPMYADMIN komplett deinstallieren (apt-get remove phpmyadmin, purge und autoremove), anschließend neu aufsetzen auf dem System, was auch fehlschlug. Das Problem ist immer das gleiche: Es werden Login und Kennwort abgefragt.


    Da mein PHPMYADMIN jetzt irgendwie Schrott ist... und es wohl nur Teildeinstalliert ist...


    Wie bekomme ich es 1.) komplett bereinigt wieder weg und 2.) neu installiert...


    MariaDB / MySQL scheint noch zu laufen!


    Vielen Dank für die Hilfe.

  • Hallo walterschmitz,
    steht denn dran, was für ein Kennwort abgefragt wird? Spontan würde ich vermuten, dass es das MySQL (root?) Kennwort ist, das phpMyAdmin zum anlegen der eigenen Datenstrukturen benötigt.


    Gruß
    Christian

  • Das hab ich ja versucht. Root und das entsprechende Kennwort. Hab es extra von Hand in der MySQL Konsole mal ausprobiert.. . Da ging es.


    Muss ich root@irgendwas eintragen? Oder reicht nur Root


    Gruss

  • So jetzt hab ich Zeit das ganze im Detail mal mit dem PC direkt nachzuvollziehen:


    Code
    sudo apt-get install phpmyadmin


    danach läuft das ganze durch und im Verlauf wird dann folgendes gefragt:
    Bemerkung: Root (MySQL) Kennwort ist mir bekannt!


    Im Feld Konfiguriere phpmyadmin... die Frage

    Code
    Konfigurieren der Datenbank für phpmyadmin mit dbconfig-common?

    mit Ja beantwortet!


    dann:

    Code
    │ Bitte geben Sie ein Passwort ein, mit dem sich phpmyadmin beim        │
      │ Datenbankserver anmelden kann. Falls Sie das Feld frei lassen, wird   │
      │ automatisch ein zufälliges Passwort erzeugt.                          │
      │                                                                       │
      │ MySQL-Anwendungspasswort für phpmyadmin:

    das entspreche Root-MySQL-Kennwort eingegeben. Bemerkung: Bis jetzt wurde KEIN Benutzer abgefragt.
    Jetzt kommt folgende Fehlermeldung:



    Anschließend die Fragen wiederholen:
    Jetzt kommt zusätzlich folgende Fragen:

    Code
    │ Standardmäßig wird phpmyadmin so konfiguriert, dass ein MySQL-Server      │
     │ über einen lokalen UNIX-Socket angesprochen wird (ermöglicht die beste    │
     │ Geschwindigkeit). Um sich mit einer anderen Methode anzumelden oder       │
     │ einen komplett anderen Server zu verwenden, wählen Sie aus den Optionen   │
     │ hier die geeignete aus.                                                   │
     │                                                                           │
     │ Verbindungsmethode an die MySQL-Datenbank von phpmyadmin:


    Antwort: UNIX-Socket


    Code
    │ Bitte einen Namen für die MySQL-Datenbank, die vom Paket phpmyadmin   │
       │ verwendet werden soll, eingeben.                                      │
       │                                                                       │
       │ MySQL-Datenbankname für phpmyadmin:


    Antwort: (vorgegeben war) phpmyadmin



    dann

    Code
    │ MySQL-Benutzername für phpmyadmin:  │
      │                                      │
      │  root@localhost_____________________


    Hier ist egal, ob ich root@localhost, nur root oder was auch immer eingebe...


    dann wird das Kennwort abgefragt:

    Code
    │  Bitte geben Sie ein Passwort ein, mit dem sich phpmyadmin beim        │
       │ Datenbankserver anmelden kann. Falls Sie das Feld frei lassen, wird   │
       │ automatisch ein zufälliges Passwort erzeugt.                          │
       │                                                                       │
       │ MySQL-Anwendungspasswort für phpmyadmin:


    Natürlich das richtige Root-Kennwort eingetragen
    und entsprechend ein zweites Mal bestätigt!


    Dann kommt folgende Meldung:


    Ich versteh nicht, warum jetzt wieder der User debian-sys-maint eingetragen ist. Hiermist stimmt natürlich das Kennwort nicht... aber wo kann ich das verändern?


    Ich denke anschließend sollte dann auch das Installationsproblem verschwunden sein.


    Kann mir nochmal jemand helfen.
    Danke