Pi-Hole Installation mit Fehlermeldung bei FTL

  • Problem gelöst: Anscheinend stimmte was mit den FTL Quellen nicht


    Hey,


    ich wollte gerade mal Pi-Hole auf meinem ZeroW installieren (aktuelles Stretch).

    Code
    1. sudo curl -sSL https://install.pi-hole.net | bash

    Während der Installation gibt es aber einen Fehler bei der Installation von FTL:

    Code
    1. ::: Downloading latest version of FTL...
    2. ::: Detected ARM-hf architecture (armv6 or lower)
    3. ::: Using ARM binary
    4. ::: Installing FTL... curl: (56) SSL read: error:00000000:lib(0):func(0):reason(0), errno 104
    5. failed (URL not found.)


    Wie bekomme ich diesen Fehler gelöst?

    Habe es auch mal auf einem frischen Image probiert und bekomme die selbe Fehlermeldung. Ich kann zwar das Admin Panel aufrufen, aber dort wird mir natürlich angezeigt, dass der FTL Dienst nicht läuft und dementsprechend gehen die Anzeigen auch nicht.


    Hatte das schon mal jemand?



    Edited once, last by IcedEarth ().

  • Ist openSSL korrekt installiert?

    Versuch mal direkt via curl eine beliebige https-Verbindung herzustellen und überprüfe ob auch hier ein Fehler auftritt.

  • Jop:

    openssl is already the newest version (1.1.0f-3).


    Das Github Repo wird doch über https gezogen. Dann sollte das doch auch mit FTL gehen, oder?

    Wie gesagt gehen alle anderen Teilpakete problemlos durch.


    Edit:

    curl https://www.google.degibt mir zumindest den HTML Inhalt aus

    Edited once, last by IcedEarth ().

  • Seltsam.

    Die betreffende Fehlermeldung taucht wohl des öfteren in Verbindung mit einer falsch konfigurierten php.ini auf.

    PiHole hat laut GitHub auch ein paar Prozent php-Code, was der genau tut keine Ahnung.

    Du solltest aber mal überprüfen ob dein php openssl kann.

    Code
    1. php -i | grep -i openssl

    Sollte da weitere Anhaltspunkte liefern.


    Mal so an Rande:

    der Pi Zero W ist tatsächlich auch nicht auf der Liste der kompatiblen Hardware.

    der Pi Zero jedoch schon und der SoC ist soweit ich weiß identisch.

    Edited once, last by orchard ().

  • Danke für den Hinweis. PhP scheint openSSL zu beherrschen:

    Code
    1. pi@raspberrypi:~ $ php -i | grep -i openssl
    2. openssl
    3. OpenSSL support => enabled
    4. OpenSSL Library Version => OpenSSL 1.1.0f 25 May 2017
    5. OpenSSL Header Version => OpenSSL 1.1.0e 16 Feb 2017
    6. Openssl default config => /usr/lib/ssl/openssl.cnf
    7. openssl.cafile => no value => no value
    8. openssl.capath => no value => no value
    9. Native OpenSSL support => enabled
    10. pi@raspberrypi:~ $



    Gerade deinen Edit gesehen:

    Was vielleicht auch interessant ist, dass da lediglich Jessie aufgeführt wird und nicht stretch. Wobei es im Netz ja einiges zu Stretch und PiHole gibt...

    Ich pack mal testweise Jessie drauf und teste es nochmals.


    Und noch ein Edit:

    Code
    1. pi@raspberrypi:~ $ lscpu
    2. Architecture: armv6l

    Scheint doch was anderes zu sein, als der armv6 vom Pi ZeroohneW, oder hat der auch armv61?


    Und ein letzter Edit:

    Unter Jessie geht es ebenfalls nicht. Also ist entweder der Installer von FTL hinüber, oder der ZeroW wird noch nicht unterstützt.

    Edited 4 times, last by IcedEarth ().

  • So,

    ich habe es eben nochmal neu installiert. Jetzt ging tatsächlich alles durch - auch FTL.

    Es schien also an einem FTL-spezifischen Problem gelegen zu haben.


    Ich habe anscheinend immer Pech mit dem Timing :-P