wo feste Route mit raspbian stretch setzen

  • Hi!

    Bin das erste Mal mit raspbian strecht unterwegs. Die Netzwerkkonfiguration mit jessie war/ist ja schon gewöhunungsbedürftig, aber wo setzt man jetzt eine permanete Route? Die "alten" Verzeichnisse für das Skript fehlen z.B. /etc/sysconfig/network-scripts/route-eth0

    Danke für Hilfe

    cu

  • Die Netzwerkkonfiguration mit jessie war/ist ja schon gewöhunungsbedürftig, aber wo setzt man jetzt eine permanete Route?

    Z. B., wenn Du systemd-networkd benutzt, in einer *.network-Datei:

  • wenn Du systemd-networkd benutzt, in einer *.network-Datei:

    habe das Ganze über dhcpcd gemacht. läuft auch so einwandfrei. Da ich den raspi aber gern als Subnetzrouter hätte, habe ich die eth0 für ein zweites Netz benutzt (wlan0 fürs 1.) und gleichzeitig einen dhcp-Server für dieses installiert. Vom Raspi komme ich sauber ins 2. Netz. Aus dem ersten kann ich auch die Gatewayadresse für das zweite erreichen, nur keine Clents in eben diesem. Manuell lässt sich die Routingtabelle ändern, aber eben nicht permanent.:cursing:

  • Manuell lässt sich die Routingtabelle ändern, aber eben nicht permanent.:cursing:

    Wie hast Du die Routingtabelle manuel geändert? "permanent" heiß auch nach einem reboot? Evtl. die Routingtabelle dann nach dem reboot, nicht manuell sondern mit einem Script ändern (lassen).


    BTW: Welchen dhcp-Server hast Du auf deinem Pi installiert?

  • @ rpi444:

    Danke für die Hilfe :thumbup:

    hatte ein script erstell, welches auch korrekt die Routingtabelle ändert. War in /etc/network/if-pre-up.d/ und dann nach if-up.d/ verschoben. Beides hat nicht funtioniert. Weiterhin habe ich festgestellt, dass ich nach Ausführung von route add zwei Routen für das 2. Netzwerk 192.168.2.0 hatte: Eine mit 0.0.0.0 als Gateway und eine korrekt mit 192.168.2.59 (eth0).


    Ich habe isc-dhcp-server installiert.

  • Aus deinem letzten Beitrag geht aber (noch) nicht hervor, ob bzw. wie es evtl. jet

    Nein, es funtioniert nicht. Ich hatte den Verdacht, dass in if-pre-up.d das Netzwerk noch nicht steht und habe daher das Script nach if-up.d verschoben. Ohne Erfolg. Zusätzlich gesetze Routen nach dem Reboot weg.

  • Nein, es funtioniert nicht.

    Dann versuch mal das Script, mit der dhcpcd.conf zu starten/auszuführen. Mit "script /<Pfad>/<zum>/-Script>" für eth0 an der richtigen Stelle in der dhcpcd.conf. Evtl. dort auch "waitip 4" an der richtigen Stelle eintragen.

  • Habe ich ausprobiert und es funzt, wenn das geroutete Netzwerk schon da ist. Habe waitip 4 nicht genutzt, da es für meine Testzwecke hier nicht notwendig ist. Mein Problem ist damit gelöst. Für mich bleibt die Frage, warum die Route nicht richtig automatisch gesetzt wird. Aber das ist eine andere Sache.

    Vielen Dank für die Hilfe :thumbup:

  • Moin raspi_1952,


    nur ein Tip. In raspi-config gibt es einen Parameter Waiting for network


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"